Upstream information

CVE-2017-8872 at MITRE

Description

The htmlParseTryOrFinish function in HTMLparser.c in libxml2 2.9.4 allows attackers to cause a denial of service (buffer over-read) or information disclosure.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.4 1.9
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P AV:L/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network Local
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact Partial None
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.1
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1038444 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • libxml2 >= 2.9.4-46.3.2
  • libxml2-2 >= 2.9.4-46.3.2
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-1326
SUSE CaaS Platform ALL
  • caasp-container-manifests >= 0.0.0+git_r155_93e40ab-2.3.3
  • container-feeder >= 0.0.0+20170901.git_r55_17ecbd3-2.3.3
  • sles12-mariadb-docker-image >= 1.1.0-2.3.10
  • sles12-pause-docker-image >= 1.1.0-2.3.11
  • sles12-pv-recycler-node-docker-image >= 1.1.0-2.3.10
  • sles12-salt-api-docker-image >= 1.1.0-2.3.9
  • sles12-salt-master-docker-image >= 1.1.0-4.3.10
  • sles12-salt-minion-docker-image >= 1.1.0-2.3.8
  • sles12-velum-docker-image >= 1.1.0-4.3.9
Patchnames:
SUSE-CAASP-ALL-2017-1531
SUSE Linux Enterprise Desktop 12 SP2
  • libxml2 >= 2.9.4-46.3.2
  • libxml2-2 >= 2.9.4-46.3.2
  • libxml2-2-32bit >= 2.9.4-46.3.2
  • libxml2-tools >= 2.9.4-46.3.2
  • python-libxml2 >= 2.9.4-46.3.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1326
SUSE Linux Enterprise Desktop 12 SP3
  • libxml2 >= 2.9.4-46.3.2
  • libxml2-2 >= 2.9.4-46.3.2
  • libxml2-2-32bit >= 2.9.4-46.3.2
  • libxml2-tools >= 2.9.4-46.3.2
  • python-libxml2 >= 2.9.4-46.3.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1326
SUSE Linux Enterprise Module for Containers 12
  • sles12sp2-docker-image >= 1.0.2-20180821
Patchnames:
SUSE-SLE-Module-Containers-12-2018-1762
SUSE Linux Enterprise Server 11 SP4
  • libxml2 >= 2.7.6-0.77.3.2
  • libxml2-32bit >= 2.7.6-0.77.3.2
  • libxml2-doc >= 2.7.6-0.77.3.2
  • libxml2-python >= 2.7.6-0.77.3.5
  • libxml2-x86 >= 2.7.6-0.77.3.2
Patchnames:
slessp4-libxml2-13228
SUSE Linux Enterprise Server 12 SP2
  • libxml2 >= 2.9.4-46.3.2
  • libxml2-2 >= 2.9.4-46.3.2
  • libxml2-2-32bit >= 2.9.4-46.3.2
  • libxml2-doc >= 2.9.4-46.3.2
  • libxml2-tools >= 2.9.4-46.3.2
  • python-libxml2 >= 2.9.4-46.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1326
SUSE Linux Enterprise Server 12 SP3
  • libxml2 >= 2.9.4-46.3.2
  • libxml2-2 >= 2.9.4-46.3.2
  • libxml2-2-32bit >= 2.9.4-46.3.2
  • libxml2-doc >= 2.9.4-46.3.2
  • libxml2-tools >= 2.9.4-46.3.2
  • python-libxml2 >= 2.9.4-46.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1326
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libxml2 >= 2.9.4-46.3.2
  • libxml2-2 >= 2.9.4-46.3.2
  • libxml2-doc >= 2.9.4-46.3.2
  • libxml2-tools >= 2.9.4-46.3.2
  • python-libxml2 >= 2.9.4-46.3.2
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1326
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libxml2 >= 2.7.6-0.77.3.2
  • libxml2-32bit >= 2.7.6-0.77.3.2
  • libxml2-doc >= 2.7.6-0.77.3.2
  • libxml2-python >= 2.7.6-0.77.3.5
  • libxml2-x86 >= 2.7.6-0.77.3.2
Patchnames:
slessp4-libxml2-13228
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libxml2 >= 2.9.4-46.3.2
  • libxml2-2 >= 2.9.4-46.3.2
  • libxml2-2-32bit >= 2.9.4-46.3.2
  • libxml2-doc >= 2.9.4-46.3.2
  • libxml2-tools >= 2.9.4-46.3.2
  • python-libxml2 >= 2.9.4-46.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1326
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libxml2 >= 2.9.4-46.3.2
  • libxml2-2 >= 2.9.4-46.3.2
  • libxml2-2-32bit >= 2.9.4-46.3.2
  • libxml2-doc >= 2.9.4-46.3.2
  • libxml2-tools >= 2.9.4-46.3.2
  • python-libxml2 >= 2.9.4-46.3.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1326
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libxml2 >= 2.7.6-0.77.3.2
  • libxml2-devel >= 2.7.6-0.77.3.2
  • libxml2-devel-32bit >= 2.7.6-0.77.3.2
Patchnames:
sdksp4-libxml2-13228
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libxml2 >= 2.9.4-46.3.2
  • libxml2-devel >= 2.9.4-46.3.2
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1326
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libxml2 >= 2.9.4-46.3.2
  • libxml2-devel >= 2.9.4-46.3.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1326
openSUSE Leap 42.2
  • libxml2 >= 2.9.4-5.17.1
  • libxml2-2 >= 2.9.4-5.17.1
  • libxml2-2-32bit >= 2.9.4-5.17.1
  • libxml2-2-debuginfo >= 2.9.4-5.17.1
  • libxml2-2-debuginfo-32bit >= 2.9.4-5.17.1
  • libxml2-debugsource >= 2.9.4-5.17.1
  • libxml2-devel >= 2.9.4-5.17.1
  • libxml2-devel-32bit >= 2.9.4-5.17.1
  • libxml2-doc >= 2.9.4-5.17.1
  • libxml2-tools >= 2.9.4-5.17.1
  • libxml2-tools-debuginfo >= 2.9.4-5.17.1
  • python-libxml2 >= 2.9.4-5.17.1
  • python-libxml2-debuginfo >= 2.9.4-5.17.1
  • python-libxml2-debugsource >= 2.9.4-5.17.1
Patchnames:
openSUSE-2017-942
openSUSE Leap 42.3
  • libxml2 >= 2.9.4-12.1
  • libxml2-2 >= 2.9.4-12.1
  • libxml2-2-32bit >= 2.9.4-12.1
  • libxml2-2-debuginfo >= 2.9.4-12.1
  • libxml2-2-debuginfo-32bit >= 2.9.4-12.1
  • libxml2-debugsource >= 2.9.4-12.1
  • libxml2-devel >= 2.9.4-12.1
  • libxml2-devel-32bit >= 2.9.4-12.1
  • libxml2-doc >= 2.9.4-12.1
  • libxml2-tools >= 2.9.4-12.1
  • libxml2-tools-debuginfo >= 2.9.4-12.1
  • python-libxml2 >= 2.9.4-12.1
  • python-libxml2-debuginfo >= 2.9.4-12.1
  • python-libxml2-debugsource >= 2.9.4-12.1
Patchnames:
openSUSE-2017-942


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
OpenStack Cloud Magnum Orchestration 7.0 libxml2 Released
SUSE Linux Enterprise Desktop 12 SP1 libxml2 Affected
SUSE Linux Enterprise Desktop 12 SP2 libxml2 Released
SUSE Linux Enterprise Desktop 12 SP3 libxml2 Released
SUSE Linux Enterprise SDK 11 SP4 libxml2 Released
SUSE Linux Enterprise SDK 12 SP1 libxml2 Affected
SUSE Linux Enterprise SDK 12 SP2 libxml2 Released
SUSE Linux Enterprise SDK 12 SP3 libxml2 Released
SUSE Linux Enterprise Server 11 SP3 LTSS libxml2 Affected
SUSE Linux Enterprise Server 11 SP4 libxml2 Released
SUSE Linux Enterprise Server 12 GA LTSS libxml2 Affected
SUSE Linux Enterprise Server 12 SP1 libxml2 Affected
SUSE Linux Enterprise Server 12 SP2 libxml2 Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI libxml2 Released
SUSE Linux Enterprise Server 12 SP3 libxml2 Released