Upstream information

CVE-2017-8422 at MITRE

Description

KDE kdelibs before 4.14.32 and KAuth before 5.34 allow local users to gain root privileges by spoofing a callerID and leveraging a privileged helper app.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.15
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High

This issue is currently rated as having important severity.

SUSE Bugzilla entries: 1033300 [RESOLVED / ], 1036244 [IN_PROGRESS], 1041511 [RESOLVED / ], 749065 [RESOLVED / ], 869959 [RESOLVED / ]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Build System Kit 12 SP1
  • kdelibs4 >= 4.12.0-10.1
  • kdelibs4-branding-upstream >= 4.12.0-10.1
  • kdelibs4-core >= 4.12.0-10.1
  • kdelibs4-doc >= 4.12.0-10.1
  • libkde4-devel >= 4.12.0-10.1
  • libkdecore4-devel >= 4.12.0-10.1
Patchnames:
SUSE-SLE-BSK-12-SP1-2017-805
SUSE Linux Enterprise Build System Kit 12 SP2
  • kdelibs4 >= 4.12.0-10.1
  • kdelibs4-branding-upstream >= 4.12.0-10.1
  • kdelibs4-core >= 4.12.0-10.1
  • kdelibs4-doc >= 4.12.0-10.1
  • libkde4-devel >= 4.12.0-10.1
  • libkdecore4-devel >= 4.12.0-10.1
Patchnames:
SUSE-SLE-BSK-12-SP2-2017-805
SUSE Linux Enterprise Desktop 12 SP1
  • kdelibs4 >= 4.12.0-10.1
  • libkde4 >= 4.12.0-10.1
  • libkde4-32bit >= 4.12.0-10.1
  • libkdecore4 >= 4.12.0-10.1
  • libkdecore4-32bit >= 4.12.0-10.1
  • libksuseinstall1 >= 4.12.0-10.1
  • libksuseinstall1-32bit >= 4.12.0-10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-805
SUSE Linux Enterprise Desktop 12 SP2
  • kdelibs4 >= 4.12.0-10.1
  • libkde4 >= 4.12.0-10.1
  • libkde4-32bit >= 4.12.0-10.1
  • libkdecore4 >= 4.12.0-10.1
  • libkdecore4-32bit >= 4.12.0-10.1
  • libksuseinstall1 >= 4.12.0-10.1
  • libksuseinstall1-32bit >= 4.12.0-10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-805
SUSE Linux Enterprise Server 12 SP1
  • kdelibs4 >= 4.12.0-10.1
  • libkde4 >= 4.12.0-10.1
  • libkde4-32bit >= 4.12.0-10.1
  • libkdecore4 >= 4.12.0-10.1
  • libkdecore4-32bit >= 4.12.0-10.1
  • libksuseinstall1 >= 4.12.0-10.1
  • libksuseinstall1-32bit >= 4.12.0-10.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-805
SUSE Linux Enterprise Server 12 SP2
  • kdelibs4 >= 4.12.0-10.1
  • libkde4 >= 4.12.0-10.1
  • libkde4-32bit >= 4.12.0-10.1
  • libkdecore4 >= 4.12.0-10.1
  • libkdecore4-32bit >= 4.12.0-10.1
  • libksuseinstall1 >= 4.12.0-10.1
  • libksuseinstall1-32bit >= 4.12.0-10.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-805
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • kdelibs4 >= 4.12.0-10.1
  • libkde4 >= 4.12.0-10.1
  • libkdecore4 >= 4.12.0-10.1
  • libksuseinstall1 >= 4.12.0-10.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-805
openSUSE Leap 42.1
  • kauth >= 5.21.0-16.1
  • kauth-debugsource >= 5.21.0-16.1
  • kauth-devel >= 5.21.0-16.1
  • kauth-devel-32bit >= 5.21.0-16.1
  • kdelibs4 >= 4.14.18-18.1
  • kdelibs4-apidocs >= 4.14.18-18.1
  • kdelibs4-branding-upstream >= 4.14.18-18.1
  • kdelibs4-core >= 4.14.18-18.1
  • kdelibs4-core-debuginfo >= 4.14.18-18.1
  • kdelibs4-debuginfo >= 4.14.18-18.1
  • kdelibs4-debugsource >= 4.14.18-18.1
  • kdelibs4-doc >= 4.14.18-18.1
  • kdelibs4-doc-debuginfo >= 4.14.18-18.1
  • libKF5Auth5 >= 5.21.0-16.1
  • libKF5Auth5-32bit >= 5.21.0-16.1
  • libKF5Auth5-debuginfo >= 5.21.0-16.1
  • libKF5Auth5-debuginfo-32bit >= 5.21.0-16.1
  • libKF5Auth5-lang >= 5.21.0-16.1
  • libkde4 >= 4.14.18-18.1
  • libkde4-32bit >= 4.14.18-18.1
  • libkde4-debuginfo >= 4.14.18-18.1
  • libkde4-debuginfo-32bit >= 4.14.18-18.1
  • libkde4-devel >= 4.14.18-18.1
  • libkdecore4 >= 4.14.18-18.1
  • libkdecore4-32bit >= 4.14.18-18.1
  • libkdecore4-debuginfo >= 4.14.18-18.1
  • libkdecore4-debuginfo-32bit >= 4.14.18-18.1
  • libkdecore4-devel >= 4.14.18-18.1
  • libkdecore4-devel-debuginfo >= 4.14.18-18.1
  • libksuseinstall-devel >= 4.14.18-18.1
  • libksuseinstall1 >= 4.14.18-18.1
  • libksuseinstall1-32bit >= 4.14.18-18.1
  • libksuseinstall1-debuginfo >= 4.14.18-18.1
  • libksuseinstall1-debuginfo-32bit >= 4.14.18-18.1
Patchnames:
openSUSE-2017-575
openSUSE Leap 42.2
  • kauth >= 5.26.0-2.3.1
  • kauth-debugsource >= 5.26.0-2.3.1
  • kauth-devel >= 5.26.0-2.3.1
  • kauth-devel-32bit >= 5.26.0-2.3.1
  • kdelibs4 >= 4.14.25-7.4.1
  • kdelibs4-apidocs >= 4.14.25-7.4.1
  • kdelibs4-branding-upstream >= 4.14.25-7.4.1
  • kdelibs4-core >= 4.14.25-7.4.1
  • kdelibs4-core-debuginfo >= 4.14.25-7.4.1
  • kdelibs4-debuginfo >= 4.14.25-7.4.1
  • kdelibs4-debugsource >= 4.14.25-7.4.1
  • kdelibs4-doc >= 4.14.25-7.4.1
  • kdelibs4-doc-debuginfo >= 4.14.25-7.4.1
  • libKF5Auth5 >= 5.26.0-2.3.1
  • libKF5Auth5-32bit >= 5.26.0-2.3.1
  • libKF5Auth5-debuginfo >= 5.26.0-2.3.1
  • libKF5Auth5-debuginfo-32bit >= 5.26.0-2.3.1
  • libKF5Auth5-lang >= 5.26.0-2.3.1
  • libkde4 >= 4.14.25-7.4.1
  • libkde4-32bit >= 4.14.25-7.4.1
  • libkde4-debuginfo >= 4.14.25-7.4.1
  • libkde4-debuginfo-32bit >= 4.14.25-7.4.1
  • libkde4-devel >= 4.14.25-7.4.1
  • libkdecore4 >= 4.14.25-7.4.1
  • libkdecore4-32bit >= 4.14.25-7.4.1
  • libkdecore4-debuginfo >= 4.14.25-7.4.1
  • libkdecore4-debuginfo-32bit >= 4.14.25-7.4.1
  • libkdecore4-devel >= 4.14.25-7.4.1
  • libkdecore4-devel-debuginfo >= 4.14.25-7.4.1
  • libksuseinstall-devel >= 4.14.25-7.4.1
  • libksuseinstall1 >= 4.14.25-7.4.1
  • libksuseinstall1-32bit >= 4.14.25-7.4.1
  • libksuseinstall1-debuginfo >= 4.14.25-7.4.1
  • libksuseinstall1-debuginfo-32bit >= 4.14.25-7.4.1
Patchnames:
openSUSE-2017-575


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise SDK 11 SP4
  • SUSE Linux Enterprise Server 11 SP3 LTSS
  • SUSE Linux Enterprise Server 11 SP4
  • SUSE Linux Enterprise Server 12 GA
  • SUSE Linux Enterprise Server for SAP 11 SP3
  • SUSE Linux Enterprise Server for SAP 11 SP4
  • SUSE Linux Enterprise Server for SAP 12 GA
kdelibs4