Upstream information

CVE-2017-8386 at MITRE

Description

git-shell in git before 2.4.12, 2.5.x before 2.5.6, 2.6.x before 2.6.7, 2.7.x before 2.7.5, 2.8.x before 2.8.5, 2.9.x before 2.9.4, 2.10.x before 2.10.3, 2.11.x before 2.11.2, and 2.12.x before 2.12.3 might allow remote authenticated users to gain privileges via a repository name that starts with a - (dash) character.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.52 6.52
Vector AV:N/AC:L/Au:S/C:P/I:P/A:P AV:N/AC:L/Au:S/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication Single Single
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High

This issue is currently rated as having important severity.

SUSE Bugzilla entry: 1038395 [RESOLVED / ]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • git >= 2.12.3-26.1
  • git-core >= 2.12.3-26.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-830
SUSE Linux Enterprise Server 12 SP1
  • git >= 2.12.3-26.1
  • git-core >= 2.12.3-26.1
  • git-doc >= 2.12.3-26.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-830
SUSE Linux Enterprise Server 12 SP2
  • git >= 2.12.3-26.1
  • git-core >= 2.12.3-26.1
  • git-doc >= 2.12.3-26.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-830
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • git >= 2.12.3-26.1
  • git-core >= 2.12.3-26.1
  • git-doc >= 2.12.3-26.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-830
SUSE Linux Enterprise Software Development Kit 11 SP4
  • git >= 1.7.12.4-0.17.1
  • git-arch >= 1.7.12.4-0.17.1
  • git-core >= 1.7.12.4-0.17.1
  • git-cvs >= 1.7.12.4-0.17.1
  • git-daemon >= 1.7.12.4-0.17.1
  • git-email >= 1.7.12.4-0.17.1
  • git-gui >= 1.7.12.4-0.17.1
  • git-svn >= 1.7.12.4-0.17.1
  • git-web >= 1.7.12.4-0.17.1
  • gitk >= 1.7.12.4-0.17.1
Patchnames:
sdksp4-git-13129
SUSE Linux Enterprise Software Development Kit 12 SP1
  • git >= 2.12.3-26.1
  • git-arch >= 2.12.3-26.1
  • git-core >= 2.12.3-26.1
  • git-cvs >= 2.12.3-26.1
  • git-daemon >= 2.12.3-26.1
  • git-doc >= 2.12.3-26.1
  • git-email >= 2.12.3-26.1
  • git-gui >= 2.12.3-26.1
  • git-svn >= 2.12.3-26.1
  • git-web >= 2.12.3-26.1
  • gitk >= 2.12.3-26.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-830
SUSE Linux Enterprise Software Development Kit 12 SP2
  • git >= 2.12.3-26.1
  • git-arch >= 2.12.3-26.1
  • git-core >= 2.12.3-26.1
  • git-cvs >= 2.12.3-26.1
  • git-daemon >= 2.12.3-26.1
  • git-doc >= 2.12.3-26.1
  • git-email >= 2.12.3-26.1
  • git-gui >= 2.12.3-26.1
  • git-svn >= 2.12.3-26.1
  • git-web >= 2.12.3-26.1
  • gitk >= 2.12.3-26.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-830
SUSE Studio Onsite 1.3
  • git >= 1.7.12.4-0.17.1
  • git-core >= 1.7.12.4-0.17.1
Patchnames:
slestso13-git-13129
openSUSE Leap 42.2
  • git >= 2.12.3-5.6.1
  • git-arch >= 2.12.3-5.6.1
  • git-core >= 2.12.3-5.6.1
  • git-core-debuginfo >= 2.12.3-5.6.1
  • git-credential-gnome-keyring >= 2.12.3-5.6.1
  • git-credential-gnome-keyring-debuginfo >= 2.12.3-5.6.1
  • git-cvs >= 2.12.3-5.6.1
  • git-daemon >= 2.12.3-5.6.1
  • git-daemon-debuginfo >= 2.12.3-5.6.1
  • git-debugsource >= 2.12.3-5.6.1
  • git-doc >= 2.12.3-5.6.1
  • git-email >= 2.12.3-5.6.1
  • git-gui >= 2.12.3-5.6.1
  • git-svn >= 2.12.3-5.6.1
  • git-svn-debuginfo >= 2.12.3-5.6.1
  • git-web >= 2.12.3-5.6.1
  • gitk >= 2.12.3-5.6.1
Patchnames:
openSUSE-2017-624


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server 12 GA
  • SUSE Linux Enterprise Server for SAP 12 GA
git