Upstream information

CVE-2017-7995 at MITRE

Description

Xen PV guest before Xen 4.3 checked access permissions to MMIO ranges only after accessing them, allowing host PCI device space memory reads, leading to information disclosure. This is an error in the get_user function. NOTE: the upstream Xen Project considers versions before 4.5.x to be EOL.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 1.73 3.51
Vector AV:L/AC:L/Au:S/C:P/I:N/A:N AV:L/AC:H/Au:S/C:P/I:P/A:P
Access Vector Local Local
Access Complexity Low High
Authentication Single Single
Confidentiality Impact Partial Partial
Integrity Impact None Partial
Availability Impact None Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 3.8
Vector AV:L/AC:L/PR:L/UI:N/S:C/C:L/I:N/A:N
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Changed
Confidentiality Impact Low
Integrity Impact None
Availability Impact None

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1033948 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Point of Sale 11 SP3
  • xen >= 4.2.5_21-41.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.99-41.1
  • xen-kmp-pae >= 4.2.5_21_3.0.101_0.47.99-41.1
  • xen-libs >= 4.2.5_21-41.1
  • xen-tools-domU >= 4.2.5_21-41.1
Patchnames:
sleposp3-xen-13085
SUSE Linux Enterprise Server 11 SP3-LTSS
  • xen >= 4.2.5_21-41.1
  • xen-doc-html >= 4.2.5_21-41.1
  • xen-doc-pdf >= 4.2.5_21-41.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.99-41.1
  • xen-kmp-pae >= 4.2.5_21_3.0.101_0.47.99-41.1
  • xen-libs >= 4.2.5_21-41.1
  • xen-libs-32bit >= 4.2.5_21-41.1
  • xen-tools >= 4.2.5_21-41.1
  • xen-tools-domU >= 4.2.5_21-41.1
Patchnames:
slessp3-xen-13085
SUSE Manager 2.1
  • xen >= 4.2.5_21-41.1
  • xen-doc-html >= 4.2.5_21-41.1
  • xen-doc-pdf >= 4.2.5_21-41.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.99-41.1
  • xen-libs >= 4.2.5_21-41.1
  • xen-libs-32bit >= 4.2.5_21-41.1
  • xen-tools >= 4.2.5_21-41.1
  • xen-tools-domU >= 4.2.5_21-41.1
Patchnames:
sleman21-xen-13085
SUSE Manager Proxy 2.1
  • xen >= 4.2.5_21-41.1
  • xen-doc-html >= 4.2.5_21-41.1
  • xen-doc-pdf >= 4.2.5_21-41.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.99-41.1
  • xen-libs >= 4.2.5_21-41.1
  • xen-libs-32bit >= 4.2.5_21-41.1
  • xen-tools >= 4.2.5_21-41.1
  • xen-tools-domU >= 4.2.5_21-41.1
Patchnames:
slemap21-xen-13085
SUSE OpenStack Cloud 5
  • xen >= 4.2.5_21-41.1
  • xen-doc-html >= 4.2.5_21-41.1
  • xen-doc-pdf >= 4.2.5_21-41.1
  • xen-kmp-default >= 4.2.5_21_3.0.101_0.47.99-41.1
  • xen-libs >= 4.2.5_21-41.1
  • xen-libs-32bit >= 4.2.5_21-41.1
  • xen-tools >= 4.2.5_21-41.1
  • xen-tools-domU >= 4.2.5_21-41.1
Patchnames:
sleclo50sp3-xen-13085


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server for SAP 11 SP3
xen