Upstream information

CVE-2017-7798 at MITRE

Description

The Developer Tools feature suffers from a XUL injection vulnerability due to improper sanitization of the web page source code. In the worst case, this could allow arbitrary code execution when opening a malicious page with the style editor tool. This vulnerability affects Firefox ESR

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  SUSE
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  SUSE
Base Score 7.5
Vector AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity High
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1052829 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-translations >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1603
SUSE Linux Enterprise Desktop 12 SP3
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-translations >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1603
SUSE Linux Enterprise Module for Desktop Applications 15
  • MozillaFirefox >= 52.7.3-1.35
  • MozillaFirefox-devel >= 52.7.3-1.35
  • MozillaFirefox-translations-common >= 52.7.3-1.35
  • MozillaFirefox-translations-other >= 52.7.3-1.35
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA MozillaFirefox
SUSE Linux Enterprise Point of Sale 11 SP3
  • MozillaFirefox >= 52.3.0esr-72.9.1
  • MozillaFirefox-branding-SLED >= 52-24.5.1
  • MozillaFirefox-translations >= 52.3.0esr-72.9.1
Patchnames:
sleposp3-MozillaFirefox-13254
SUSE Linux Enterprise Server 11 SP3-LTSS
  • MozillaFirefox >= 52.3.0esr-72.9.1
  • MozillaFirefox-branding-SLED >= 52-24.5.1
  • MozillaFirefox-translations >= 52.3.0esr-72.9.1
Patchnames:
slessp3-MozillaFirefox-13254
SUSE Linux Enterprise Server 11 SP4
  • MozillaFirefox >= 52.3.0esr-72.9.1
  • MozillaFirefox-branding-SLED >= 52-24.5.1
  • MozillaFirefox-translations >= 52.3.0esr-72.9.1
Patchnames:
slessp4-MozillaFirefox-13254
SUSE Linux Enterprise Server 12 SP1-LTSS
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-devel >= 52.3.0esr-109.3.1
  • MozillaFirefox-translations >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1603
SUSE Linux Enterprise Server 12 SP2
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-translations >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1603
SUSE Linux Enterprise Server 12 SP3
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-translations >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1603
SUSE Linux Enterprise Server 12-LTSS
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-devel >= 52.3.0esr-109.3.1
  • MozillaFirefox-translations >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-SERVER-12-2017-1603
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-translations >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1603
SUSE Linux Enterprise Server for SAP Applications 11 SP3-LTSS
  • MozillaFirefox >= 52.3.0esr-72.9.1
  • MozillaFirefox-branding-SLED >= 52-24.5.1
  • MozillaFirefox-translations >= 52.3.0esr-72.9.1
Patchnames:
slessp3-MozillaFirefox-13254
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • MozillaFirefox >= 52.3.0esr-72.9.1
  • MozillaFirefox-branding-SLED >= 52-24.5.1
  • MozillaFirefox-translations >= 52.3.0esr-72.9.1
Patchnames:
slessp4-MozillaFirefox-13254
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-devel >= 52.3.0esr-109.3.1
  • MozillaFirefox-translations >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2017-1603
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-devel >= 52.3.0esr-109.3.1
  • MozillaFirefox-translations >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1603
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-translations >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1603
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-translations >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1603
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-devel >= 52.3.0esr-109.3.1
  • MozillaFirefox-translations >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-SERVER-12-2017-1603
SUSE Linux Enterprise Software Development Kit 11 SP4
  • MozillaFirefox >= 52.3.0esr-72.9.1
  • MozillaFirefox-devel >= 52.3.0esr-72.9.1
Patchnames:
sdksp4-MozillaFirefox-13254
SUSE Linux Enterprise Software Development Kit 12 SP2
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-devel >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1603
SUSE Linux Enterprise Software Development Kit 12 SP3
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-devel >= 52.3.0esr-109.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1603
SUSE Linux Enterprise Workstation Extension 15
  • MozillaThunderbird >= 52.8-1.2
  • MozillaThunderbird-devel >= 52.8-1.2
  • MozillaThunderbird-translations-common >= 52.8-1.2
  • MozillaThunderbird-translations-other >= 52.8-1.2
Patchnames:
SUSE Linux Enterprise Workstation Extension 15 GA MozillaThunderbird
SUSE OpenStack Cloud 6
  • MozillaFirefox >= 52.3.0esr-109.3.1
  • MozillaFirefox-devel >= 52.3.0esr-109.3.1
  • MozillaFirefox-translations >= 52.3.0esr-109.3.1
Patchnames:
SUSE-OpenStack-Cloud-6-2017-1603
SUSE Package Hub for SUSE Linux Enterprise 12
  • MozillaThunderbird >= 52.3.0-42.1
  • MozillaThunderbird-buildsymbols >= 52.3.0-42.1
  • MozillaThunderbird-debuginfo >= 52.3.0-42.1
  • MozillaThunderbird-debugsource >= 52.3.0-42.1
  • MozillaThunderbird-devel >= 52.3.0-42.1
  • MozillaThunderbird-translations-common >= 52.3.0-42.1
  • MozillaThunderbird-translations-other >= 52.3.0-42.1
Patchnames:
openSUSE-2017-955
openSUSE Leap 15.0
  • MozillaFirefox >= 60.0-lp150.2.2
  • MozillaFirefox-translations-common >= 60.0-lp150.2.2
  • MozillaFirefox-translations-other >= 60.0-lp150.2.2
  • MozillaThunderbird >= 52.7-lp150.2.16
  • MozillaThunderbird-translations-common >= 52.7-lp150.2.16
  • MozillaThunderbird-translations-other >= 52.7-lp150.2.16
Patchnames:
openSUSE Leap 15.0 GA MozillaFirefox
openSUSE Leap 15.0 GA MozillaThunderbird
openSUSE Leap 42.2
  • MozillaFirefox >= 52.3.0-57.15.1
  • MozillaFirefox-branding-upstream >= 52.3.0-57.15.1
  • MozillaFirefox-buildsymbols >= 52.3.0-57.15.1
  • MozillaFirefox-debuginfo >= 52.3.0-57.15.1
  • MozillaFirefox-debugsource >= 52.3.0-57.15.1
  • MozillaFirefox-devel >= 52.3.0-57.15.1
  • MozillaFirefox-translations-common >= 52.3.0-57.15.1
  • MozillaFirefox-translations-other >= 52.3.0-57.15.1
  • MozillaThunderbird >= 52.3.0-41.15.1
  • MozillaThunderbird-buildsymbols >= 52.3.0-41.15.1
  • MozillaThunderbird-debuginfo >= 52.3.0-41.15.1
  • MozillaThunderbird-debugsource >= 52.3.0-41.15.1
  • MozillaThunderbird-devel >= 52.3.0-41.15.1
  • MozillaThunderbird-translations-common >= 52.3.0-41.15.1
  • MozillaThunderbird-translations-other >= 52.3.0-41.15.1
Patchnames:
openSUSE-2017-921
openSUSE-2017-955
openSUSE Leap 42.3
  • MozillaFirefox >= 52.3.0-60.1
  • MozillaFirefox-branding-upstream >= 52.3.0-60.1
  • MozillaFirefox-buildsymbols >= 52.3.0-60.1
  • MozillaFirefox-debuginfo >= 52.3.0-60.1
  • MozillaFirefox-debugsource >= 52.3.0-60.1
  • MozillaFirefox-devel >= 52.3.0-60.1
  • MozillaFirefox-translations-common >= 52.3.0-60.1
  • MozillaFirefox-translations-other >= 52.3.0-60.1
  • MozillaThunderbird >= 52.3.0-44.1
  • MozillaThunderbird-buildsymbols >= 52.3.0-44.1
  • MozillaThunderbird-debuginfo >= 52.3.0-44.1
  • MozillaThunderbird-debugsource >= 52.3.0-44.1
  • MozillaThunderbird-devel >= 52.3.0-44.1
  • MozillaThunderbird-translations-common >= 52.3.0-44.1
  • MozillaThunderbird-translations-other >= 52.3.0-44.1
Patchnames:
openSUSE-2017-921
openSUSE-2017-955


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 MozillaFirefox Released
SUSE Linux Enterprise Desktop 12 SP3 MozillaFirefox Released
SUSE Linux Enterprise SDK 11 SP4 MozillaFirefox Released
SUSE Linux Enterprise SDK 12 SP2 MozillaFirefox Released
SUSE Linux Enterprise SDK 12 SP3 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP3 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP4 MozillaFirefox Released
SUSE Linux Enterprise Server 12 GA LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 12 SP1 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 12 SP2 MozillaFirefox Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI MozillaFirefox Released
SUSE Linux Enterprise Server 12 SP3 MozillaFirefox Released