Upstream information

CVE-2017-7760 at MITRE

Description

The Mozilla Windows updater modifies some files to be updated by reading the original file and applying changes to it. The location of the original file can be altered by a malicious user by passing a special path to the callback parameter through the Mozilla Maintenance Service, allowing the manipulation of files in the installation directory and privilege escalation by manipulating the Mozilla Maintenance Service, which has privileged access. Note: This attack requires local system access and only affects Windows. Other operating systems are not affected. This vulnerability affects Firefox ESR

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 1043960 [RESOLVED / FIXED], 1044239 [RESOLVED], 1044240 [RESOLVED], 1044241 [RESOLVED], 1044242 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Desktop Applications 15
  • MozillaFirefox >= 52.7.3-1.35
  • MozillaFirefox-devel >= 52.7.3-1.35
  • MozillaFirefox-translations-common >= 52.7.3-1.35
  • MozillaFirefox-translations-other >= 52.7.3-1.35
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA MozillaFirefox
openSUSE Leap 42.2
  • MozillaFirefox >= 52.2-57.12.2
  • MozillaFirefox-branding-upstream >= 52.2-57.12.2
  • MozillaFirefox-buildsymbols >= 52.2-57.12.2
  • MozillaFirefox-debuginfo >= 52.2-57.12.2
  • MozillaFirefox-debugsource >= 52.2-57.12.2
  • MozillaFirefox-devel >= 52.2-57.12.2
  • MozillaFirefox-translations-common >= 52.2-57.12.2
  • MozillaFirefox-translations-other >= 52.2-57.12.2
  • MozillaThunderbird >= 52.2-41.9.2
  • MozillaThunderbird-buildsymbols >= 52.2-41.9.2
  • MozillaThunderbird-debuginfo >= 52.2-41.9.2
  • MozillaThunderbird-debugsource >= 52.2-41.9.2
  • MozillaThunderbird-devel >= 52.2-41.9.2
  • MozillaThunderbird-translations-common >= 52.2-41.9.2
  • MozillaThunderbird-translations-other >= 52.2-41.9.2
  • java-1_8_0-openjdk >= 1.8.0.131-10.10.3
  • java-1_8_0-openjdk-accessibility >= 1.8.0.131-10.10.3
  • java-1_8_0-openjdk-debuginfo >= 1.8.0.131-10.10.3
  • java-1_8_0-openjdk-debugsource >= 1.8.0.131-10.10.3
  • java-1_8_0-openjdk-demo >= 1.8.0.131-10.10.3
  • java-1_8_0-openjdk-demo-debuginfo >= 1.8.0.131-10.10.3
  • java-1_8_0-openjdk-devel >= 1.8.0.131-10.10.3
  • java-1_8_0-openjdk-devel-debuginfo >= 1.8.0.131-10.10.3
  • java-1_8_0-openjdk-headless >= 1.8.0.131-10.10.3
  • java-1_8_0-openjdk-headless-debuginfo >= 1.8.0.131-10.10.3
  • java-1_8_0-openjdk-javadoc >= 1.8.0.131-10.10.3
  • java-1_8_0-openjdk-src >= 1.8.0.131-10.10.3
  • libfreebl3 >= 3.28.5-40.6.1
  • libfreebl3-32bit >= 3.28.5-40.6.1
  • libfreebl3-debuginfo >= 3.28.5-40.6.1
  • libfreebl3-debuginfo-32bit >= 3.28.5-40.6.1
  • libsoftokn3 >= 3.28.5-40.6.1
  • libsoftokn3-32bit >= 3.28.5-40.6.1
  • libsoftokn3-debuginfo >= 3.28.5-40.6.1
  • libsoftokn3-debuginfo-32bit >= 3.28.5-40.6.1
  • mozilla-nss >= 3.28.5-40.6.1
  • mozilla-nss-32bit >= 3.28.5-40.6.1
  • mozilla-nss-certs >= 3.28.5-40.6.1
  • mozilla-nss-certs-32bit >= 3.28.5-40.6.1
  • mozilla-nss-certs-debuginfo >= 3.28.5-40.6.1
  • mozilla-nss-certs-debuginfo-32bit >= 3.28.5-40.6.1
  • mozilla-nss-debuginfo >= 3.28.5-40.6.1
  • mozilla-nss-debuginfo-32bit >= 3.28.5-40.6.1
  • mozilla-nss-debugsource >= 3.28.5-40.6.1
  • mozilla-nss-devel >= 3.28.5-40.6.1
  • mozilla-nss-sysinit >= 3.28.5-40.6.1
  • mozilla-nss-sysinit-32bit >= 3.28.5-40.6.1
  • mozilla-nss-sysinit-debuginfo >= 3.28.5-40.6.1
  • mozilla-nss-sysinit-debuginfo-32bit >= 3.28.5-40.6.1
  • mozilla-nss-tools >= 3.28.5-40.6.1
  • mozilla-nss-tools-debuginfo >= 3.28.5-40.6.1
Patchnames:
openSUSE-2017-712
openSUSE Leap 42.3
  • MozillaFirefox >= 52.2-58.2
  • MozillaFirefox-translations-common >= 52.2-58.2
Patchnames:
openSUSE Leap 42.3 GA MozillaFirefox


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 MozillaFirefox Released
SUSE Linux Enterprise SDK 11 SP4 MozillaFirefox Released
SUSE Linux Enterprise SDK 12 SP2 MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP3 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 11 SP4 MozillaFirefox Released
SUSE Linux Enterprise Server 12 GA LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 12 SP1 LTSS MozillaFirefox Released
SUSE Linux Enterprise Server 12 SP2 MozillaFirefox Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI MozillaFirefox Released
SUSE Linux Enterprise Server for VMWare 11 SP2 MozillaFirefox Already fixed
SUSE Linux Enterprise Server for VMWare 11 SP3 MozillaFirefox Affected