Upstream information

CVE-2017-7555 at MITRE

Description

Augeas versions up to and including 1.8.0 are vulnerable to heap-based buffer overflow due to improper handling of escaped strings. Attacker could send crafted strings that would cause the application using augeas to copy past the end of a buffer, leading to a crash or possible code execution.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.4
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:L/Au:N/C:N/I:P/A:P
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial None
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 6.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Access Vector Network Network
Access Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High Low
SUSE Bugzilla entry: 1054171 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 augeas Unsupported
OpenStack Cloud Magnum Orchestration 7.0 augeas Affected
SUSE Linux Enterprise Desktop 12 SP2 augeas Affected
SUSE Linux Enterprise Desktop 12 SP3 augeas Affected
SUSE Linux Enterprise SDK 11 SP4 augeas Affected
SUSE Linux Enterprise SDK 12 SP2 augeas Affected
SUSE Linux Enterprise SDK 12 SP3 augeas Affected
SUSE Linux Enterprise Server 11 SP3 LTSS augeas Affected
SUSE Linux Enterprise Server 11 SP4 augeas Affected
SUSE Linux Enterprise Server 12 GA LTSS augeas Affected
SUSE Linux Enterprise Server 12 SP1 LTSS augeas Affected
SUSE Linux Enterprise Server 12 SP2 augeas Affected
SUSE Linux Enterprise Server 12 SP3 augeas Affected