Upstream information

CVE-2017-7547 at MITRE

Description

PostgreSQL versions before 9.2.22, 9.3.18, 9.4.13, 9.5.8 and 9.6.4 are vulnerable to authorization flaw allowing remote authenticated attackers to retrieve passwords from the user mappings defined by the foreign server owners without actually having the privileges to do so.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4 4.9
Vector AV:N/AC:L/Au:S/C:P/I:N/A:N AV:N/AC:M/Au:S/C:P/I:P/A:N
Access Vector Network Network
Access Complexity Low Medium
Authentication Single Single
Confidentiality Impact Partial Partial
Integrity Impact None Partial
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 8.8 5.4
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required Low Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High Low
Integrity Impact High Low
Availability Impact High None
SUSE Bugzilla entries: 1051685 [RESOLVED / FIXED], 1054365 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-libs >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1460
SUSE-SLE-DESKTOP-12-SP2-2017-1461
SUSE Linux Enterprise Desktop 12 SP3
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-libs >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1461
SUSE Linux Enterprise Point of Sale 11 SP3
  • libecpg6 >= 9.4.13-0.23.5.1
  • libpq5 >= 9.4.13-0.23.5.1
  • postgresql94 >= 9.4.13-0.23.5.1
  • postgresql94-contrib >= 9.4.13-0.23.5.1
  • postgresql94-docs >= 9.4.13-0.23.5.1
  • postgresql94-libs >= 9.4.13-0.23.5.1
  • postgresql94-server >= 9.4.13-0.23.5.1
Patchnames:
sleposp3-postgresql94-13247
SUSE Linux Enterprise Server 11 SP3-LTSS
  • libecpg6 >= 9.4.13-0.23.5.1
  • libpq5 >= 9.4.13-0.23.5.1
  • libpq5-32bit >= 9.4.13-0.23.5.1
  • postgresql94 >= 9.4.13-0.23.5.1
  • postgresql94-contrib >= 9.4.13-0.23.5.1
  • postgresql94-docs >= 9.4.13-0.23.5.1
  • postgresql94-libs >= 9.4.13-0.23.5.1
  • postgresql94-server >= 9.4.13-0.23.5.1
Patchnames:
slessp3-postgresql94-13247
SUSE Linux Enterprise Server 11 SP4
  • libecpg6 >= 9.4.13-0.23.5.1
  • libpq5 >= 9.4.13-0.23.5.1
  • libpq5-32bit >= 9.4.13-0.23.5.1
  • postgresql94 >= 9.4.13-0.23.5.1
  • postgresql94-contrib >= 9.4.13-0.23.5.1
  • postgresql94-docs >= 9.4.13-0.23.5.1
  • postgresql94-libs >= 9.4.13-0.23.5.1
  • postgresql94-server >= 9.4.13-0.23.5.1
Patchnames:
slessp4-postgresql94-13247
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-libs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1460
SUSE-SLE-SERVER-12-SP1-2017-1461
SUSE Linux Enterprise Server 12 SP2
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-libs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1460
SUSE-SLE-SERVER-12-SP2-2017-1461
SUSE Linux Enterprise Server 12 SP3
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-libs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1461
SUSE Linux Enterprise Server 12-LTSS
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql93 >= 9.3.18-25.5.1
  • postgresql93-contrib >= 9.3.18-25.5.1
  • postgresql93-docs >= 9.3.18-25.5.1
  • postgresql93-server >= 9.3.18-25.5.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-libs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SERVER-12-2017-1368
SUSE-SLE-SERVER-12-2017-1460
SUSE-SLE-SERVER-12-2017-1461
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-libs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1460
SUSE-SLE-RPI-12-SP2-2017-1461
SUSE Linux Enterprise Software Development Kit 11 SP4
  • postgresql94-devel >= 9.4.13-0.23.5.1
  • postgresql94-libs >= 9.4.13-0.23.5.1
Patchnames:
sdksp4-postgresql94-13247
SUSE Linux Enterprise Software Development Kit 12 SP2
  • postgresql94-devel >= 9.4.13-21.5.1
  • postgresql94-libs >= 9.4.13-21.5.1
  • postgresql96-devel >= 9.6.4-3.6.1
  • postgresql96-libs >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1460
SUSE-SLE-SDK-12-SP2-2017-1461
SUSE Linux Enterprise Software Development Kit 12 SP3
  • postgresql96-devel >= 9.6.4-3.6.1
  • postgresql96-libs >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1461
SUSE Linux Enterprise for SAP 12
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql93 >= 9.3.18-25.5.1
  • postgresql93-contrib >= 9.3.18-25.5.1
  • postgresql93-docs >= 9.3.18-25.5.1
  • postgresql93-server >= 9.3.18-25.5.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-libs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SAP-12-2017-1368
SUSE-SLE-SAP-12-2017-1460
SUSE-SLE-SAP-12-2017-1461
SUSE Linux Enterprise for SAP 12 SP1
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-libs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2017-1460
SUSE-SLE-SAP-12-SP1-2017-1461
SUSE OpenStack Cloud 6
  • libecpg6 >= 9.6.4-3.6.1
  • libpq5 >= 9.6.4-3.6.1
  • libpq5-32bit >= 9.6.4-3.6.1
  • postgresql94 >= 9.4.13-21.5.1
  • postgresql94-contrib >= 9.4.13-21.5.1
  • postgresql94-docs >= 9.4.13-21.5.1
  • postgresql94-server >= 9.4.13-21.5.1
  • postgresql96 >= 9.6.4-3.6.1
  • postgresql96-contrib >= 9.6.4-3.6.1
  • postgresql96-docs >= 9.6.4-3.6.1
  • postgresql96-libs >= 9.6.4-3.6.1
  • postgresql96-server >= 9.6.4-3.6.1
Patchnames:
SUSE-OpenStack-Cloud-6-2017-1460
SUSE-OpenStack-Cloud-6-2017-1461
openSUSE Leap 42.2
  • libecpg6 >= 9.6.4-5.1
  • libecpg6-32bit >= 9.6.4-5.1
  • libecpg6-debuginfo >= 9.6.4-5.1
  • libecpg6-debuginfo-32bit >= 9.6.4-5.1
  • libpq5 >= 9.6.4-5.1
  • libpq5-32bit >= 9.6.4-5.1
  • libpq5-debuginfo >= 9.6.4-5.1
  • libpq5-debuginfo-32bit >= 9.6.4-5.1
  • postgresql93 >= 9.3.18-5.12.1
  • postgresql93-contrib >= 9.3.18-5.12.1
  • postgresql93-contrib-debuginfo >= 9.3.18-5.12.1
  • postgresql93-debuginfo >= 9.3.18-5.12.1
  • postgresql93-debugsource >= 9.3.18-5.12.1
  • postgresql93-devel >= 9.3.18-5.12.1
  • postgresql93-devel-debuginfo >= 9.3.18-5.12.1
  • postgresql93-docs >= 9.3.18-5.12.1
  • postgresql93-libs >= 9.3.18-5.12.1
  • postgresql93-libs-debugsource >= 9.3.18-5.12.1
  • postgresql93-plperl >= 9.3.18-5.12.1
  • postgresql93-plperl-debuginfo >= 9.3.18-5.12.1
  • postgresql93-plpython >= 9.3.18-5.12.1
  • postgresql93-plpython-debuginfo >= 9.3.18-5.12.1
  • postgresql93-pltcl >= 9.3.18-5.12.1
  • postgresql93-pltcl-debuginfo >= 9.3.18-5.12.1
  • postgresql93-server >= 9.3.18-5.12.1
  • postgresql93-server-debuginfo >= 9.3.18-5.12.1
  • postgresql93-test >= 9.3.18-5.12.1
  • postgresql94 >= 9.4.13-9.9.1
  • postgresql94-contrib >= 9.4.13-9.9.1
  • postgresql94-contrib-debuginfo >= 9.4.13-9.9.1
  • postgresql94-debuginfo >= 9.4.13-9.9.1
  • postgresql94-debugsource >= 9.4.13-9.9.1
  • postgresql94-devel >= 9.4.13-9.9.1
  • postgresql94-devel-debuginfo >= 9.4.13-9.9.1
  • postgresql94-docs >= 9.4.13-9.9.1
  • postgresql94-libs >= 9.4.13-9.9.1
  • postgresql94-libs-debugsource >= 9.4.13-9.9.1
  • postgresql94-plperl >= 9.4.13-9.9.1
  • postgresql94-plperl-debuginfo >= 9.4.13-9.9.1
  • postgresql94-plpython >= 9.4.13-9.9.1
  • postgresql94-plpython-debuginfo >= 9.4.13-9.9.1
  • postgresql94-pltcl >= 9.4.13-9.9.1
  • postgresql94-pltcl-debuginfo >= 9.4.13-9.9.1
  • postgresql94-server >= 9.4.13-9.9.1
  • postgresql94-server-debuginfo >= 9.4.13-9.9.1
  • postgresql94-test >= 9.4.13-9.9.1
  • postgresql96 >= 9.6.4-5.1
  • postgresql96-contrib >= 9.6.4-5.1
  • postgresql96-contrib-debuginfo >= 9.6.4-5.1
  • postgresql96-debuginfo >= 9.6.4-5.1
  • postgresql96-debugsource >= 9.6.4-5.1
  • postgresql96-devel >= 9.6.4-5.1
  • postgresql96-devel-debuginfo >= 9.6.4-5.1
  • postgresql96-docs >= 9.6.4-5.1
  • postgresql96-libs >= 9.6.4-5.1
  • postgresql96-libs-debugsource >= 9.6.4-5.1
  • postgresql96-plperl >= 9.6.4-5.1
  • postgresql96-plperl-debuginfo >= 9.6.4-5.1
  • postgresql96-plpython >= 9.6.4-5.1
  • postgresql96-plpython-debuginfo >= 9.6.4-5.1
  • postgresql96-pltcl >= 9.6.4-5.1
  • postgresql96-pltcl-debuginfo >= 9.6.4-5.1
  • postgresql96-server >= 9.6.4-5.1
  • postgresql96-server-debuginfo >= 9.6.4-5.1
  • postgresql96-test >= 9.6.4-5.1
Patchnames:
openSUSE-2017-1020
openSUSE-2017-1021
openSUSE-2017-985
openSUSE Leap 42.3
  • libecpg6 >= 9.6.4-6.1
  • libecpg6-32bit >= 9.6.4-6.1
  • libecpg6-debuginfo >= 9.6.4-6.1
  • libecpg6-debuginfo-32bit >= 9.6.4-6.1
  • libpq5 >= 9.6.4-6.1
  • libpq5-32bit >= 9.6.4-6.1
  • libpq5-debuginfo >= 9.6.4-6.1
  • libpq5-debuginfo-32bit >= 9.6.4-6.1
  • postgresql93 >= 9.3.18-8.1
  • postgresql93-contrib >= 9.3.18-8.1
  • postgresql93-contrib-debuginfo >= 9.3.18-8.1
  • postgresql93-debuginfo >= 9.3.18-8.1
  • postgresql93-debugsource >= 9.3.18-8.1
  • postgresql93-devel >= 9.3.18-8.1
  • postgresql93-devel-debuginfo >= 9.3.18-8.1
  • postgresql93-docs >= 9.3.18-8.1
  • postgresql93-libs >= 9.3.18-8.1
  • postgresql93-libs-debugsource >= 9.3.18-8.1
  • postgresql93-plperl >= 9.3.18-8.1
  • postgresql93-plperl-debuginfo >= 9.3.18-8.1
  • postgresql93-plpython >= 9.3.18-8.1
  • postgresql93-plpython-debuginfo >= 9.3.18-8.1
  • postgresql93-pltcl >= 9.3.18-8.1
  • postgresql93-pltcl-debuginfo >= 9.3.18-8.1
  • postgresql93-server >= 9.3.18-8.1
  • postgresql93-server-debuginfo >= 9.3.18-8.1
  • postgresql93-test >= 9.3.18-8.1
  • postgresql94 >= 9.4.13-12.1
  • postgresql94-contrib >= 9.4.13-12.1
  • postgresql94-contrib-debuginfo >= 9.4.13-12.1
  • postgresql94-debuginfo >= 9.4.13-12.1
  • postgresql94-debugsource >= 9.4.13-12.1
  • postgresql94-devel >= 9.4.13-12.1
  • postgresql94-devel-debuginfo >= 9.4.13-12.1
  • postgresql94-docs >= 9.4.13-12.1
  • postgresql94-libs >= 9.4.13-12.1
  • postgresql94-libs-debugsource >= 9.4.13-12.1
  • postgresql94-plperl >= 9.4.13-12.1
  • postgresql94-plperl-debuginfo >= 9.4.13-12.1
  • postgresql94-plpython >= 9.4.13-12.1
  • postgresql94-plpython-debuginfo >= 9.4.13-12.1
  • postgresql94-pltcl >= 9.4.13-12.1
  • postgresql94-pltcl-debuginfo >= 9.4.13-12.1
  • postgresql94-server >= 9.4.13-12.1
  • postgresql94-server-debuginfo >= 9.4.13-12.1
  • postgresql94-test >= 9.4.13-12.1
  • postgresql96 >= 9.6.4-6.1
  • postgresql96-contrib >= 9.6.4-6.1
  • postgresql96-contrib-debuginfo >= 9.6.4-6.1
  • postgresql96-debuginfo >= 9.6.4-6.1
  • postgresql96-debugsource >= 9.6.4-6.1
  • postgresql96-devel >= 9.6.4-6.1
  • postgresql96-devel-debuginfo >= 9.6.4-6.1
  • postgresql96-docs >= 9.6.4-6.1
  • postgresql96-libs >= 9.6.4-6.1
  • postgresql96-libs-debugsource >= 9.6.4-6.1
  • postgresql96-plperl >= 9.6.4-6.1
  • postgresql96-plperl-debuginfo >= 9.6.4-6.1
  • postgresql96-plpython >= 9.6.4-6.1
  • postgresql96-plpython-debuginfo >= 9.6.4-6.1
  • postgresql96-pltcl >= 9.6.4-6.1
  • postgresql96-pltcl-debuginfo >= 9.6.4-6.1
  • postgresql96-server >= 9.6.4-6.1
  • postgresql96-server-debuginfo >= 9.6.4-6.1
  • postgresql96-test >= 9.6.4-6.1
Patchnames:
openSUSE-2017-1020
openSUSE-2017-1021
openSUSE-2017-985


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 postgresql Affected
SUSE Linux Enterprise Desktop 12 SP2 postgresql94 Released
SUSE Linux Enterprise Desktop 12 SP2 postgresql96 Released
SUSE Linux Enterprise Desktop 12 SP3 postgresql96 Released
SUSE Linux Enterprise SDK 12 SP2 postgresql Affected
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql Ignore
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql91 Affected
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql94 Released
SUSE Linux Enterprise Server 11 SP4 postgresql Ignore
SUSE Linux Enterprise Server 11 SP4 postgresql94 Released
SUSE Linux Enterprise Server 12 GA LTSS postgresql94 Released
SUSE Linux Enterprise Server 12 GA LTSS postgresql96 Released
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql94 Released
SUSE Linux Enterprise Server 12 SP1 LTSS postgresql96 Released
SUSE Linux Enterprise Server 12 SP2 postgresql94 Released
SUSE Linux Enterprise Server 12 SP2 postgresql96 Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI postgresql94 Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI postgresql96 Released
SUSE Linux Enterprise Server 12 SP3 postgresql96 Released
SUSE Linux Enterprise Workstation Extension 12 SP2 postgresql Affected