Upstream information

CVE-2017-7507 at MITRE

Description

GnuTLS version 3.5.12 and earlier is vulnerable to a NULL pointer dereference while decoding a status response TLS extension with valid contents. This could lead to a crash of the GnuTLS server application.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1043398 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • gnutls >= 3.2.15-18.3.1
  • libgnutls28 >= 3.2.15-18.3.1
  • libgnutls28-32bit >= 3.2.15-18.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1133
SUSE Linux Enterprise Server 12 SP2
  • gnutls >= 3.2.15-18.3.1
  • libgnutls-openssl27 >= 3.2.15-18.3.1
  • libgnutls28 >= 3.2.15-18.3.1
  • libgnutls28-32bit >= 3.2.15-18.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1133
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gnutls >= 3.2.15-18.3.1
  • libgnutls-openssl27 >= 3.2.15-18.3.1
  • libgnutls28 >= 3.2.15-18.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1133
SUSE Linux Enterprise Software Development Kit 12 SP2
  • gnutls >= 3.2.15-18.3.1
  • libgnutls-devel >= 3.2.15-18.3.1
  • libgnutls-openssl-devel >= 3.2.15-18.3.1
  • libgnutlsxx-devel >= 3.2.15-18.3.1
  • libgnutlsxx28 >= 3.2.15-18.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1133
openSUSE Leap 42.2
  • gnutls >= 3.2.15-11.3.1
  • gnutls-debuginfo >= 3.2.15-11.3.1
  • gnutls-debugsource >= 3.2.15-11.3.1
  • libgnutls-devel >= 3.2.15-11.3.1
  • libgnutls-devel-32bit >= 3.2.15-11.3.1
  • libgnutls-openssl-devel >= 3.2.15-11.3.1
  • libgnutls-openssl27 >= 3.2.15-11.3.1
  • libgnutls-openssl27-debuginfo >= 3.2.15-11.3.1
  • libgnutls28 >= 3.2.15-11.3.1
  • libgnutls28-32bit >= 3.2.15-11.3.1
  • libgnutls28-debuginfo >= 3.2.15-11.3.1
  • libgnutls28-debuginfo-32bit >= 3.2.15-11.3.1
  • libgnutlsxx-devel >= 3.2.15-11.3.1
  • libgnutlsxx28 >= 3.2.15-11.3.1
  • libgnutlsxx28-debuginfo >= 3.2.15-11.3.1
Patchnames:
openSUSE-2017-824


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 gnutls Released
SUSE Linux Enterprise High Availability Extension 11 SP4 gnutls Not affected
SUSE Linux Enterprise SDK 11 SP4 gnutls Not affected
SUSE Linux Enterprise SDK 12 SP2 gnutls Released
SUSE Linux Enterprise Server 11 SP3 LTSS gnutls Not affected
SUSE Linux Enterprise Server 11 SP4 gnutls Not affected
SUSE Linux Enterprise Server 12 GA gnutls Affected
SUSE Linux Enterprise Server 12 SP1 gnutls Affected
SUSE Linux Enterprise Server 12 SP2 gnutls Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry Pi gnutls Released