Upstream information

CVE-2017-7486 at MITRE

Description

PostgreSQL versions 8.4 - 9.6 are vulnerable to information leak in pg_user_mappings view which discloses foreign server passwords to any user having USAGE privilege on the associated foreign server.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.96 3.47
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N AV:N/AC:M/Au:S/C:P/I:N/A:N
Access Vector Network Network
Access Complexity Low Medium
Authentication None Single
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None

This issue is currently rated as having moderate severity.

SUSE Bugzilla entry: 1037624 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • postgresql94 >= 9.4.12-20.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1039
SUSE Linux Enterprise Server 12 SP2
  • postgresql94 >= 9.4.12-20.1
  • postgresql94-contrib >= 9.4.12-20.1
  • postgresql94-docs >= 9.4.12-20.1
  • postgresql94-server >= 9.4.12-20.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1039
SUSE Linux Enterprise Server 12-LTSS
  • postgresql93 >= 9.3.17-24.2
  • postgresql93-contrib >= 9.3.17-24.2
  • postgresql93-docs >= 9.3.17-24.2
  • postgresql93-server >= 9.3.17-24.2
Patchnames:
SUSE-SLE-SERVER-12-2017-881
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • postgresql94 >= 9.4.12-20.1
  • postgresql94-contrib >= 9.4.12-20.1
  • postgresql94-docs >= 9.4.12-20.1
  • postgresql94-server >= 9.4.12-20.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1039
SUSE Linux Enterprise Software Development Kit 12 SP2
  • postgresql94-devel >= 9.4.12-20.1
  • postgresql94-libs >= 9.4.12-20.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1039
SUSE Linux Enterprise for SAP 12
  • postgresql93 >= 9.3.17-24.2
  • postgresql93-contrib >= 9.3.17-24.2
  • postgresql93-docs >= 9.3.17-24.2
  • postgresql93-server >= 9.3.17-24.2
Patchnames:
SUSE-SLE-SAP-12-2017-881
openSUSE Leap 42.2
  • postgresql93 >= 9.3.17-5.9.1
  • postgresql93-contrib >= 9.3.17-5.9.1
  • postgresql93-contrib-debuginfo >= 9.3.17-5.9.1
  • postgresql93-debuginfo >= 9.3.17-5.9.1
  • postgresql93-debugsource >= 9.3.17-5.9.1
  • postgresql93-devel >= 9.3.17-5.9.1
  • postgresql93-devel-debuginfo >= 9.3.17-5.9.1
  • postgresql93-docs >= 9.3.17-5.9.1
  • postgresql93-libs >= 9.3.17-5.9.1
  • postgresql93-libs-debugsource >= 9.3.17-5.9.1
  • postgresql93-plperl >= 9.3.17-5.9.1
  • postgresql93-plperl-debuginfo >= 9.3.17-5.9.1
  • postgresql93-plpython >= 9.3.17-5.9.1
  • postgresql93-plpython-debuginfo >= 9.3.17-5.9.1
  • postgresql93-pltcl >= 9.3.17-5.9.1
  • postgresql93-pltcl-debuginfo >= 9.3.17-5.9.1
  • postgresql93-server >= 9.3.17-5.9.1
  • postgresql93-server-debuginfo >= 9.3.17-5.9.1
  • postgresql93-test >= 9.3.17-5.9.1
Patchnames:
openSUSE-2017-657

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Server 11 SP4
  • libecpg6 >= 9.4.12-0.22.3
  • libpq5 >= 9.4.12-0.22.3
  • libpq5-32bit >= 9.4.12-0.22.3
  • postgresql94 >= 9.4.12-0.22.3
  • postgresql94-contrib >= 9.4.12-0.22.3
  • postgresql94-docs >= 9.4.12-0.22.3
  • postgresql94-libs >= 9.4.12-0.22.3
  • postgresql94-server >= 9.4.12-0.22.3
SUSE Linux Enterprise Software Development Kit 11 SP4
  • postgresql94-devel >= 9.4.12-0.22.3
  • postgresql94-libs >= 9.4.12-0.22.3