Upstream information

CVE-2017-7481 at MITRE

Description

Ansible before versions 2.3.1.0 and 2.4.0.0 fails to properly mark lookup-plugin results as unsafe. If an attacker could control the results of lookup() calls, they could inject Unicode strings to be parsed by the jinja2 templating system, resulting in code execution. By default, the jinja2 templating language is now marked as 'unsafe' and is not evaluated.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1038785 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE OpenStack Cloud 7
  • ansible >= 2.2.3.0-5.1
  • monasca-installer >= 20170912_10.45-5.1
Patchnames:
SUSE-OpenStack-Cloud-7-2017-1793
SUSE Package Hub for SUSE Linux Enterprise 12
  • ansible >= 2.4.1.0-6.1
Patchnames:
openSUSE-2017-1259
openSUSE Leap 42.2
  • ansible >= 2.4.1.0-2.4.1
Patchnames:
openSUSE-2017-1259
openSUSE Leap 42.3
  • ansible >= 2.4.1.0-6.1
Patchnames:
openSUSE-2017-1259


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Openstack Cloud 7 ansible Released