Upstream information

CVE-2017-7374 at MITRE

Description

Use-after-free vulnerability in fs/crypto/ in the Linux kernel before 4.10.7 allows local users to cause a denial of service (NULL pointer dereference) or possibly gain privileges by revoking keyring keys being used for ext4, f2fs, or ubifs encryption, causing cryptographic transform objects to be freed prematurely.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.2 6.6
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C AV:L/AC:M/Au:S/C:C/I:C/A:C
Access Vector Local Local
Access Complexity Low Medium
Authentication None Single
Confidentiality Impact Complete Complete
Integrity Impact Complete Complete
Availability Impact Complete Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 1027179 [RESOLVED], 1032006 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • kernel-default >= 4.4.59-92.17.3
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-697
SUSE Linux Enterprise Build System Kit 12 SP2
  • kernel-zfcpdump >= 4.4.59-92.17.3
Patchnames:
SUSE-SLE-BSK-12-SP2-2017-697
SUSE Linux Enterprise Desktop 12 SP2
  • kernel-default >= 4.4.59-92.17.3
  • kernel-default-devel >= 4.4.59-92.17.3
  • kernel-default-extra >= 4.4.59-92.17.3
  • kernel-devel >= 4.4.59-92.17.2
  • kernel-macros >= 4.4.59-92.17.2
  • kernel-source >= 4.4.59-92.17.2
  • kernel-syms >= 4.4.59-92.17.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-697
SUSE Linux Enterprise Desktop 12 SP3
  • kernel-default >= 4.4.73-5.1
  • kernel-default-devel >= 4.4.73-5.1
  • kernel-default-extra >= 4.4.73-5.1
  • kernel-devel >= 4.4.73-5.1
  • kernel-macros >= 4.4.73-5.1
  • kernel-source >= 4.4.73-5.1
  • kernel-syms >= 4.4.73-5.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA kernel-default
SUSE Linux Enterprise High Availability 12 SP2
  • cluster-md-kmp-default >= 4.4.59-92.17.3
  • cluster-network-kmp-default >= 4.4.59-92.17.3
  • dlm-kmp-default >= 4.4.59-92.17.3
  • gfs2-kmp-default >= 4.4.59-92.17.3
  • kernel-default >= 4.4.59-92.17.3
  • ocfs2-kmp-default >= 4.4.59-92.17.3
Patchnames:
SUSE-SLE-HA-12-SP2-2017-697
SUSE Linux Enterprise High Availability 12 SP3
  • cluster-md-kmp-default >= 4.4.73-5.1
  • dlm-kmp-default >= 4.4.73-5.1
  • gfs2-kmp-default >= 4.4.73-5.1
  • ocfs2-kmp-default >= 4.4.73-5.1
Patchnames:
SUSE Linux Enterprise High Availability 12 SP3 GA cluster-md-kmp-default
SUSE Linux Enterprise Live Patching 12
  • kgraft-patch-4_4_59-92_17-default >= 1-2.3
  • kgraft-patch-SLE12-SP2_Update_7 >= 1-2.3
Patchnames:
SUSE-SLE-Live-Patching-12-2017-697
SUSE Linux Enterprise Real Time Extension 12 SP2
  • cluster-md-kmp-rt >= 4.4.74-7.10.1
  • cluster-network-kmp-rt >= 4.4.74-7.10.1
  • dlm-kmp-rt >= 4.4.74-7.10.1
  • gfs2-kmp-rt >= 4.4.74-7.10.1
  • kernel-devel-rt >= 4.4.74-7.10.1
  • kernel-rt >= 4.4.74-7.10.1
  • kernel-rt-base >= 4.4.74-7.10.1
  • kernel-rt-devel >= 4.4.74-7.10.1
  • kernel-rt_debug >= 4.4.74-7.10.1
  • kernel-rt_debug-devel >= 4.4.74-7.10.1
  • kernel-source-rt >= 4.4.74-7.10.1
  • kernel-syms-rt >= 4.4.74-7.10.1
  • ocfs2-kmp-rt >= 4.4.74-7.10.1
Patchnames:
SUSE-SLE-RT-12-SP2-2017-1231
SUSE Linux Enterprise Server 12 SP2
  • kernel-default >= 4.4.59-92.17.3
  • kernel-default-base >= 4.4.59-92.17.3
  • kernel-default-devel >= 4.4.59-92.17.3
  • kernel-default-man >= 4.4.59-92.17.3
  • kernel-devel >= 4.4.59-92.17.2
  • kernel-macros >= 4.4.59-92.17.2
  • kernel-source >= 4.4.59-92.17.2
  • kernel-syms >= 4.4.59-92.17.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-697
SUSE Linux Enterprise Server 12 SP3
  • kernel-default >= 4.4.73-5.1
  • kernel-default-base >= 4.4.73-5.1
  • kernel-default-devel >= 4.4.73-5.1
  • kernel-default-man >= 4.4.73-5.1
  • kernel-devel >= 4.4.73-5.1
  • kernel-macros >= 4.4.73-5.1
  • kernel-source >= 4.4.73-5.1
  • kernel-syms >= 4.4.73-5.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA kernel-default
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • kernel-default >= 4.4.59-92.17.3
  • kernel-default-base >= 4.4.59-92.17.3
  • kernel-default-devel >= 4.4.59-92.17.3
  • kernel-devel >= 4.4.59-92.17.2
  • kernel-macros >= 4.4.59-92.17.2
  • kernel-source >= 4.4.59-92.17.2
  • kernel-syms >= 4.4.59-92.17.2
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-697
SUSE Linux Enterprise Software Development Kit 12 SP2
  • kernel-docs >= 4.4.59-92.17.8
  • kernel-obs-build >= 4.4.59-92.17.3
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-697
SUSE Linux Enterprise Software Development Kit 12 SP3
  • kernel-docs >= 4.4.73-5.1
  • kernel-obs-build >= 4.4.73-5.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA kernel-docs
SUSE Linux Enterprise Workstation Extension 12 SP2
  • kernel-default >= 4.4.59-92.17.3
  • kernel-default-extra >= 4.4.59-92.17.3
Patchnames:
SUSE-SLE-WE-12-SP2-2017-697
SUSE Linux Enterprise Workstation Extension 12 SP3
  • kernel-default-extra >= 4.4.73-5.1
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA kernel-default-extra
openSUSE Leap 42.2
  • kernel-debug >= 4.4.62-18.6.1
  • kernel-debug-base >= 4.4.62-18.6.1
  • kernel-debug-base-debuginfo >= 4.4.62-18.6.1
  • kernel-debug-debuginfo >= 4.4.62-18.6.1
  • kernel-debug-debugsource >= 4.4.62-18.6.1
  • kernel-debug-devel >= 4.4.62-18.6.1
  • kernel-debug-devel-debuginfo >= 4.4.62-18.6.1
  • kernel-default >= 4.4.62-18.6.1
  • kernel-default-base >= 4.4.62-18.6.1
  • kernel-default-base-debuginfo >= 4.4.62-18.6.1
  • kernel-default-debuginfo >= 4.4.62-18.6.1
  • kernel-default-debugsource >= 4.4.62-18.6.1
  • kernel-default-devel >= 4.4.62-18.6.1
  • kernel-devel >= 4.4.62-18.6.1
  • kernel-docs >= 4.4.62-18.6.2
  • kernel-docs-html >= 4.4.62-18.6.2
  • kernel-docs-pdf >= 4.4.62-18.6.2
  • kernel-macros >= 4.4.62-18.6.1
  • kernel-obs-build >= 4.4.62-18.6.1
  • kernel-obs-build-debugsource >= 4.4.62-18.6.1
  • kernel-obs-qa >= 4.4.62-18.6.1
  • kernel-source >= 4.4.62-18.6.1
  • kernel-source-vanilla >= 4.4.62-18.6.1
  • kernel-syms >= 4.4.62-18.6.1
  • kernel-vanilla >= 4.4.62-18.6.1
  • kernel-vanilla-base >= 4.4.62-18.6.1
  • kernel-vanilla-base-debuginfo >= 4.4.62-18.6.1
  • kernel-vanilla-debuginfo >= 4.4.62-18.6.1
  • kernel-vanilla-debugsource >= 4.4.62-18.6.1
  • kernel-vanilla-devel >= 4.4.62-18.6.1
Patchnames:
openSUSE-2017-532
openSUSE Leap 42.3
  • kernel-default >= 4.4.76-1.1
  • kernel-default-devel >= 4.4.76-1.1
  • kernel-devel >= 4.4.76-1.1
  • kernel-docs >= 4.4.76-1.1
  • kernel-macros >= 4.4.76-1.1
  • kernel-source >= 4.4.76-1.1
  • kernel-syms >= 4.4.76-1.1
Patchnames:
openSUSE Leap 42.3 GA kernel-default


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 kernel-source Unsupported
SUSE Linux Enterprise Desktop 12 SP2 kernel-source Released
SUSE Linux Enterprise Server 11 SP3 LTSS kernel-source Not affected
SUSE Linux Enterprise Server 11 SP4 kernel-source Not affected
SUSE Linux Enterprise Server 12 GA LTSS kernel-source Not affected
SUSE Linux Enterprise Server 12 SP1 kernel-source Unsupported
SUSE Linux Enterprise Server 12 SP2 kernel-source Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI kernel-source Released