Upstream information

CVE-2017-7186 at MITRE

Description

libpcre1 in PCRE 8.40 and libpcre2 in PCRE2 10.23 allow remote attackers to cause a denial of service (segmentation violation for read access, and application crash) by triggering an invalid Unicode property lookup.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 4.3
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entries: 1030066 [NEW], 1037164 [RESOLVED / DUPLICATE]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • libpcre1 >= 8.41-4.20
  • libpcre1-32bit >= 8.41-4.20
  • libpcre16-0 >= 8.41-4.20
  • libpcre2-16-0 >= 10.31-1.14
  • libpcre2-32-0 >= 10.31-1.14
  • libpcre2-8-0 >= 10.31-1.14
  • libpcrecpp0 >= 8.41-4.20
  • libpcrecpp0-32bit >= 8.41-4.20
  • libpcreposix0 >= 8.41-4.20
  • pcre-devel >= 8.41-4.20
  • pcre-tools >= 8.41-4.20
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libpcre1-32bit
SUSE Linux Enterprise Module for Basesystem 15 GA libpcre2-16-0
SUSE Linux Enterprise Module for Desktop Applications 15
  • libpcre2-posix2 >= 10.31-1.14
  • pcre2-devel >= 10.31-1.14
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libpcre2-posix2
openSUSE Leap 15.0
  • libpcre1 >= 8.41-lp150.4.15
  • libpcre1-32bit >= 8.41-lp150.4.15
  • libpcre2-8-0 >= 10.31-lp150.1.3
  • libpcrecpp0-32bit >= 8.41-lp150.4.15
Patchnames:
openSUSE Leap 15.0 GA libpcre1-32bit
openSUSE Leap 15.0 GA libpcre2-8-0


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
OpenStack Cloud Magnum Orchestration 7.0 pcre Affected
SUSE Linux Enterprise Desktop 12 SP1 pcre Unsupported
SUSE Linux Enterprise Desktop 12 SP2 pcre Affected
SUSE Linux Enterprise High Availability 12 GA pcre Affected
SUSE Linux Enterprise High Availability 12 SP1 pcre Affected
SUSE Linux Enterprise High Availability 12 SP2 pcre Affected
SUSE Linux Enterprise SDK 11 SP4 pcre Affected
SUSE Linux Enterprise SDK 12 SP1 pcre Unsupported
SUSE Linux Enterprise SDK 12 SP2 pcre Affected
SUSE Linux Enterprise Server 11 SP3 LTSS pcre Affected
SUSE Linux Enterprise Server 11 SP4 pcre Affected
SUSE Linux Enterprise Server 12 GA LTSS pcre Affected
SUSE Linux Enterprise Server 12 SP1 pcre Unsupported
SUSE Linux Enterprise Server 12 SP2 pcre Affected
SUSE Linux Enterprise Workstation Extension 12 SP1 pcre Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP2 pcre Affected