Upstream information

CVE-2017-6969 at MITRE

Description

readelf in GNU Binutils 2.28 is vulnerable to a heap-based buffer over-read while processing corrupt RL78 binaries. The vulnerability can trigger program crashes. It may lead to an information leak as well.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.42
Vector AV:N/AC:L/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial

This issue is currently rated as having important severity.

SUSE Bugzilla entries: 1029907 [REOPENED], 1030295 [NEW]

No SUSE Security Announcements cross referenced.