Upstream information

CVE-2017-6349 at MITRE

Description

An integer overflow at a u_read_undo memory allocation site would occur for vim before patch 8.0.0377, if it does not properly validate values for tree length when reading a corrupted undo file, which may lead to resultant buffer overflows.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.5 4.1
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:L/AC:M/Au:S/C:P/I:P/A:P
Access Vector Network Local
Access Complexity Low Medium
Authentication None Single
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1027057 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • vim >= 7.4.326-16.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-1063
SUSE Linux Enterprise Desktop 12 SP2
  • gvim >= 7.4.326-16.1
  • vim >= 7.4.326-16.1
  • vim-data >= 7.4.326-16.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1063
SUSE Linux Enterprise Desktop 12 SP3
  • gvim >= 7.4.326-16.1
  • vim >= 7.4.326-16.1
  • vim-data >= 7.4.326-16.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA gvim
SUSE Linux Enterprise Server 12 SP2
  • gvim >= 7.4.326-16.1
  • vim >= 7.4.326-16.1
  • vim-data >= 7.4.326-16.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1063
SUSE Linux Enterprise Server 12 SP3
  • gvim >= 7.4.326-16.1
  • vim >= 7.4.326-16.1
  • vim-data >= 7.4.326-16.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA gvim
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gvim >= 7.4.326-16.1
  • vim >= 7.4.326-16.1
  • vim-data >= 7.4.326-16.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1063
openSUSE Leap 42.2
  • gvim >= 7.4.326-10.3.1
  • gvim-debuginfo >= 7.4.326-10.3.1
  • vim >= 7.4.326-10.3.1
  • vim-data >= 7.4.326-10.3.1
  • vim-debuginfo >= 7.4.326-10.3.1
  • vim-debugsource >= 7.4.326-10.3.1
Patchnames:
openSUSE-2017-788
openSUSE Leap 42.3
  • gvim >= 7.4.326-12.1
  • vim >= 7.4.326-12.1
  • vim-data >= 7.4.326-12.1
Patchnames:
openSUSE Leap 42.3 GA gvim


Status of this issue by product and package

Product(s) Source package State
OpenStack Cloud Magnum Orchestration 7.0 vim Released
SUSE Linux Enterprise Desktop 12 SP1 vim Unsupported
SUSE Linux Enterprise Desktop 12 SP2 vim Released
SUSE Linux Enterprise Server 11 SP4 vim Not affected
SUSE Linux Enterprise Server 12 SP1 vim Unsupported
SUSE Linux Enterprise Server 12 SP2 vim Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI vim Released