Upstream information

CVE-2017-6058 at MITRE

Description

Buffer overflow in NetRxPkt::ehdr_buf in hw/net/net_rx_pkt.c in QEMU (aka Quick Emulator), when the VLANSTRIP feature is enabled on the vmxnet3 device, allows remote attackers to cause a denial of service (out-of-bounds access and QEMU process crash) via vectors related to VLAN stripping.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1025837 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • qemu >= 2.9.0-5.10
  • qemu-block-curl >= 2.9.0-5.10
  • qemu-ipxe >= 1.0.0-5.10
  • qemu-kvm >= 2.9.0-5.10
  • qemu-seabios >= 1.10.2-5.10
  • qemu-sgabios >= 8-5.10
  • qemu-tools >= 2.9.0-5.10
  • qemu-vgabios >= 1.10.2-5.10
  • qemu-x86 >= 2.9.0-5.10
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA qemu
SUSE Linux Enterprise Server 12 SP3
  • qemu >= 2.9.0-5.10
  • qemu-arm >= 2.9.0-5.10
  • qemu-block-curl >= 2.9.0-5.10
  • qemu-block-rbd >= 2.9.0-5.10
  • qemu-block-ssh >= 2.9.0-5.10
  • qemu-guest-agent >= 2.9.0-5.10
  • qemu-ipxe >= 1.0.0-5.10
  • qemu-kvm >= 2.9.0-5.10
  • qemu-lang >= 2.9.0-5.10
  • qemu-ppc >= 2.9.0-5.10
  • qemu-s390 >= 2.9.0-5.10
  • qemu-seabios >= 1.10.2-5.10
  • qemu-sgabios >= 8-5.10
  • qemu-tools >= 2.9.0-5.10
  • qemu-vgabios >= 1.10.2-5.10
  • qemu-x86 >= 2.9.0-5.10
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA qemu
openSUSE Leap 42.3
  • qemu >= 2.9.0-30.1
  • qemu-arm >= 2.9.0-30.1
  • qemu-block-curl >= 2.9.0-30.1
  • qemu-block-dmg >= 2.9.0-30.1
  • qemu-block-iscsi >= 2.9.0-30.1
  • qemu-block-rbd >= 2.9.0-30.1
  • qemu-block-ssh >= 2.9.0-30.1
  • qemu-extra >= 2.9.0-30.1
  • qemu-ipxe >= 1.0.0-30.1
  • qemu-ksm >= 2.9.0-30.1
  • qemu-kvm >= 2.9.0-30.1
  • qemu-lang >= 2.9.0-30.1
  • qemu-ppc >= 2.9.0-30.1
  • qemu-s390 >= 2.9.0-30.1
  • qemu-seabios >= 1.10.2-30.1
  • qemu-sgabios >= 8-30.1
  • qemu-tools >= 2.9.0-30.1
  • qemu-vgabios >= 1.10.2-30.1
  • qemu-x86 >= 2.9.0-30.1
Patchnames:
openSUSE Leap 42.3 GA qemu


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 qemu Unsupported
SUSE Linux Enterprise Desktop 12 SP2 qemu Not affected
SUSE Linux Enterprise Point of Sale 11 SP3 qemu Not affected
SUSE Linux Enterprise SDK 11 SP4 qemu Not affected
SUSE Linux Enterprise Server 12 SP1 qemu Unsupported
SUSE Linux Enterprise Server 12 SP2 qemu Not affected
SUSE Studio Onsite 1.3 qemu Not affected