Upstream information

CVE-2017-6004 at MITRE

Description

The compile_bracket_matchingpath function in pcre_jit_compile.c in PCRE through 8.x before revision 1680 (e.g., the PHP 7.1.1 bundled version) allows remote attackers to cause a denial of service (out-of-bounds read and application crash) via a crafted regular expression.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1025709 [NEW]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • libpcre1 >= 8.41-4.20
  • libpcre1-32bit >= 8.41-4.20
  • libpcre16-0 >= 8.41-4.20
  • libpcrecpp0 >= 8.41-4.20
  • libpcrecpp0-32bit >= 8.41-4.20
  • libpcreposix0 >= 8.41-4.20
  • pcre-devel >= 8.41-4.20
  • pcre-tools >= 8.41-4.20
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libpcre1-32bit
openSUSE Leap 15.0
  • libpcre1 >= 8.41-lp150.4.15
  • libpcre1-32bit >= 8.41-lp150.4.15
  • libpcrecpp0-32bit >= 8.41-lp150.4.15
Patchnames:
openSUSE Leap 15.0 GA libpcre1-32bit


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 pcre Unsupported
SUSE Linux Enterprise Desktop 12 SP2 pcre Affected
SUSE Linux Enterprise High Availability 12 SP1 pcre Affected
SUSE Linux Enterprise High Availability 12 SP2 pcre Affected
SUSE Linux Enterprise SDK 11 SP4 pcre Not affected
SUSE Linux Enterprise SDK 12 SP1 pcre Unsupported
SUSE Linux Enterprise SDK 12 SP2 pcre Affected
SUSE Linux Enterprise Server 11 SP4 pcre Not affected
SUSE Linux Enterprise Server 12 SP1 pcre Unsupported
SUSE Linux Enterprise Server 12 SP2 pcre Affected
SUSE Linux Enterprise Workstation Extension 12 SP1 pcre Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP2 pcre Affected