Upstream information

CVE-2017-5969 at MITRE

Description

** DISPUTED ** libxml2 2.9.4, when used in recover mode, allows remote attackers to cause a denial of service (NULL pointer dereference) via a crafted XML document. NOTE: The maintainer states "I would disagree of a CVE with the Recover parsing option which should only be used for manual recovery at least for XML parser."

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 2.57 2.57
Vector AV:N/AC:H/Au:N/C:N/I:N/A:P AV:N/AC:H/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity High High
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 4.7
Vector AV:L/AC:H/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Local
Access Complexity High
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High

This issue is currently rated as having low severity.

SUSE Bugzilla entry: 1024989 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • libxml2 >= 2.9.4-42.1
  • libxml2-2 >= 2.9.4-42.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-1036
SUSE Linux Enterprise Desktop 12 SP2
  • libxml2 >= 2.9.4-42.1
  • libxml2-2 >= 2.9.4-42.1
  • libxml2-2-32bit >= 2.9.4-42.1
  • libxml2-tools >= 2.9.4-42.1
  • python-libxml2 >= 2.9.4-42.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1036
SUSE Linux Enterprise Server 12 SP2
  • libxml2 >= 2.9.4-42.1
  • libxml2-2 >= 2.9.4-42.1
  • libxml2-2-32bit >= 2.9.4-42.1
  • libxml2-doc >= 2.9.4-42.1
  • libxml2-tools >= 2.9.4-42.1
  • python-libxml2 >= 2.9.4-42.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1036
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libxml2 >= 2.9.4-42.1
  • libxml2-2 >= 2.9.4-42.1
  • libxml2-doc >= 2.9.4-42.1
  • libxml2-tools >= 2.9.4-42.1
  • python-libxml2 >= 2.9.4-42.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1036
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libxml2 >= 2.9.4-42.1
  • libxml2-devel >= 2.9.4-42.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1036

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Server 11 SP4
  • libxml2 >= 2.7.6-0.76.1
  • libxml2-32bit >= 2.7.6-0.76.1
  • libxml2-doc >= 2.7.6-0.76.1
  • libxml2-python >= 2.7.6-0.76.4
  • libxml2-x86 >= 2.7.6-0.76.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libxml2 >= 2.7.6-0.76.1
  • libxml2-devel >= 2.7.6-0.76.1
  • libxml2-devel-32bit >= 2.7.6-0.76.1