Upstream information

CVE-2017-5846 at MITRE

Description

The gst_asf_demux_process_ext_stream_props function in gst/asfdemux/gstasfdemux.c in gst-plugins-ugly in GStreamer before 1.10.3 allows remote attackers to cause a denial of service (invalid memory read and crash) via vectors related to the number of languages in a video file.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1023259 [RESOLVED / MOVED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • gstreamer >= 1.12.5-1.17
  • gstreamer-lang >= 1.12.5-1.17
  • libgstreamer-1_0-0 >= 1.12.5-1.17
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA gstreamer
SUSE Linux Enterprise Module for Desktop Applications 15
  • gstreamer-devel >= 1.12.5-1.17
  • gstreamer-utils >= 1.12.5-1.17
  • typelib-1_0-Gst-1_0 >= 1.12.5-1.17
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA gstreamer-devel
openSUSE Leap 15.0
  • gstreamer >= 1.12.5-lp150.1.1
  • gstreamer-lang >= 1.12.5-lp150.1.1
  • gstreamer-utils >= 1.12.5-lp150.1.1
  • libgstreamer-1_0-0 >= 1.12.5-lp150.1.1
  • typelib-1_0-Gst-1_0 >= 1.12.5-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA gstreamer