Upstream information

CVE-2017-5843 at MITRE

Description

Multiple use-after-free vulnerabilities in the (1) gst_mini_object_unref, (2) gst_tag_list_unref, and (3) gst_mxf_demux_update_essence_tracks functions in GStreamer before 1.10.3 allow remote attackers to cause a denial of service (crash) via vectors involving stream tags, as demonstrated by 02785736.mxf.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 4.3
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entries: 1023259 [RESOLVED / MOVED], 1024044 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • gstreamer-plugins-bad >= 1.8.3-17.2
  • gstreamer-plugins-bad-lang >= 1.8.3-17.2
  • libgstadaptivedemux-1_0-0 >= 1.8.3-17.2
  • libgstbadaudio-1_0-0 >= 1.8.3-17.2
  • libgstbadbase-1_0-0 >= 1.8.3-17.2
  • libgstbadvideo-1_0-0 >= 1.8.3-17.2
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-17.2
  • libgstcodecparsers-1_0-0 >= 1.8.3-17.2
  • libgstgl-1_0-0 >= 1.8.3-17.2
  • libgstmpegts-1_0-0 >= 1.8.3-17.2
  • libgstphotography-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-554
SUSE Linux Enterprise Desktop 12 SP3
  • gstreamer-plugins-bad >= 1.8.3-17.2
  • gstreamer-plugins-bad-lang >= 1.8.3-17.2
  • libgstadaptivedemux-1_0-0 >= 1.8.3-17.2
  • libgstbadaudio-1_0-0 >= 1.8.3-17.2
  • libgstbadbase-1_0-0 >= 1.8.3-17.2
  • libgstbadvideo-1_0-0 >= 1.8.3-17.2
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-17.2
  • libgstcodecparsers-1_0-0 >= 1.8.3-17.2
  • libgstgl-1_0-0 >= 1.8.3-17.2
  • libgstmpegts-1_0-0 >= 1.8.3-17.2
  • libgstphotography-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA gstreamer-plugins-bad
SUSE Linux Enterprise Server 12 SP2
  • gstreamer-plugins-bad >= 1.8.3-17.2
  • gstreamer-plugins-bad-lang >= 1.8.3-17.2
  • libgstadaptivedemux-1_0-0 >= 1.8.3-17.2
  • libgstbadaudio-1_0-0 >= 1.8.3-17.2
  • libgstbadbase-1_0-0 >= 1.8.3-17.2
  • libgstbadvideo-1_0-0 >= 1.8.3-17.2
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-17.2
  • libgstcodecparsers-1_0-0 >= 1.8.3-17.2
  • libgstgl-1_0-0 >= 1.8.3-17.2
  • libgstmpegts-1_0-0 >= 1.8.3-17.2
  • libgstphotography-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-554
SUSE Linux Enterprise Server 12 SP3
  • gstreamer-plugins-bad >= 1.8.3-17.2
  • gstreamer-plugins-bad-lang >= 1.8.3-17.2
  • libgstadaptivedemux-1_0-0 >= 1.8.3-17.2
  • libgstbadaudio-1_0-0 >= 1.8.3-17.2
  • libgstbadbase-1_0-0 >= 1.8.3-17.2
  • libgstbadvideo-1_0-0 >= 1.8.3-17.2
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-17.2
  • libgstcodecparsers-1_0-0 >= 1.8.3-17.2
  • libgstgl-1_0-0 >= 1.8.3-17.2
  • libgstmpegts-1_0-0 >= 1.8.3-17.2
  • libgstphotography-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA gstreamer-plugins-bad
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gstreamer-plugins-bad >= 1.8.3-17.2
  • gstreamer-plugins-bad-lang >= 1.8.3-17.2
  • libgstadaptivedemux-1_0-0 >= 1.8.3-17.2
  • libgstbadaudio-1_0-0 >= 1.8.3-17.2
  • libgstbadbase-1_0-0 >= 1.8.3-17.2
  • libgstbadvideo-1_0-0 >= 1.8.3-17.2
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-17.2
  • libgstcodecparsers-1_0-0 >= 1.8.3-17.2
  • libgstgl-1_0-0 >= 1.8.3-17.2
  • libgstmpegts-1_0-0 >= 1.8.3-17.2
  • libgstphotography-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-554
SUSE Linux Enterprise Software Development Kit 12 SP2
  • gstreamer-plugins-bad >= 1.8.3-17.2
  • gstreamer-plugins-bad-devel >= 1.8.3-17.2
  • libgstinsertbin-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-554
SUSE Linux Enterprise Software Development Kit 12 SP3
  • gstreamer-plugins-bad-devel >= 1.8.3-17.2
  • libgstinsertbin-1_0-0 >= 1.8.3-17.2
  • libgsturidownloader-1_0-0 >= 1.8.3-17.2
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA gstreamer-plugins-bad-devel
openSUSE Leap 42.2
  • gstreamer-plugins-bad >= 1.8.3-5.3.1
  • gstreamer-plugins-bad-32bit >= 1.8.3-5.3.1
  • gstreamer-plugins-bad-debuginfo >= 1.8.3-5.3.1
  • gstreamer-plugins-bad-debuginfo-32bit >= 1.8.3-5.3.1
  • gstreamer-plugins-bad-debugsource >= 1.8.3-5.3.1
  • gstreamer-plugins-bad-devel >= 1.8.3-5.3.1
  • gstreamer-plugins-bad-doc >= 1.8.3-5.3.1
  • gstreamer-plugins-bad-lang >= 1.8.3-5.3.1
  • libgstadaptivedemux-1_0-0 >= 1.8.3-5.3.1
  • libgstadaptivedemux-1_0-0-32bit >= 1.8.3-5.3.1
  • libgstadaptivedemux-1_0-0-debuginfo >= 1.8.3-5.3.1
  • libgstadaptivedemux-1_0-0-debuginfo-32bit >= 1.8.3-5.3.1
  • libgstbadaudio-1_0-0 >= 1.8.3-5.3.1
  • libgstbadaudio-1_0-0-32bit >= 1.8.3-5.3.1
  • libgstbadaudio-1_0-0-debuginfo >= 1.8.3-5.3.1
  • libgstbadaudio-1_0-0-debuginfo-32bit >= 1.8.3-5.3.1
  • libgstbadbase-1_0-0 >= 1.8.3-5.3.1
  • libgstbadbase-1_0-0-32bit >= 1.8.3-5.3.1
  • libgstbadbase-1_0-0-debuginfo >= 1.8.3-5.3.1
  • libgstbadbase-1_0-0-debuginfo-32bit >= 1.8.3-5.3.1
  • libgstbadvideo-1_0-0 >= 1.8.3-5.3.1
  • libgstbadvideo-1_0-0-32bit >= 1.8.3-5.3.1
  • libgstbadvideo-1_0-0-debuginfo >= 1.8.3-5.3.1
  • libgstbadvideo-1_0-0-debuginfo-32bit >= 1.8.3-5.3.1
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-5.3.1
  • libgstbasecamerabinsrc-1_0-0-32bit >= 1.8.3-5.3.1
  • libgstbasecamerabinsrc-1_0-0-debuginfo >= 1.8.3-5.3.1
  • libgstbasecamerabinsrc-1_0-0-debuginfo-32bit >= 1.8.3-5.3.1
  • libgstcodecparsers-1_0-0 >= 1.8.3-5.3.1
  • libgstcodecparsers-1_0-0-32bit >= 1.8.3-5.3.1
  • libgstcodecparsers-1_0-0-debuginfo >= 1.8.3-5.3.1
  • libgstcodecparsers-1_0-0-debuginfo-32bit >= 1.8.3-5.3.1
  • libgstgl-1_0-0 >= 1.8.3-5.3.1
  • libgstgl-1_0-0-32bit >= 1.8.3-5.3.1
  • libgstgl-1_0-0-debuginfo >= 1.8.3-5.3.1
  • libgstgl-1_0-0-debuginfo-32bit >= 1.8.3-5.3.1
  • libgstinsertbin-1_0-0 >= 1.8.3-5.3.1
  • libgstinsertbin-1_0-0-32bit >= 1.8.3-5.3.1
  • libgstinsertbin-1_0-0-debuginfo >= 1.8.3-5.3.1
  • libgstinsertbin-1_0-0-debuginfo-32bit >= 1.8.3-5.3.1
  • libgstmpegts-1_0-0 >= 1.8.3-5.3.1
  • libgstmpegts-1_0-0-32bit >= 1.8.3-5.3.1
  • libgstmpegts-1_0-0-debuginfo >= 1.8.3-5.3.1
  • libgstmpegts-1_0-0-debuginfo-32bit >= 1.8.3-5.3.1
  • libgstphotography-1_0-0 >= 1.8.3-5.3.1
  • libgstphotography-1_0-0-32bit >= 1.8.3-5.3.1
  • libgstphotography-1_0-0-debuginfo >= 1.8.3-5.3.1
  • libgstphotography-1_0-0-debuginfo-32bit >= 1.8.3-5.3.1
  • libgstplayer-1_0-0 >= 1.8.3-5.3.1
  • libgstplayer-1_0-0-32bit >= 1.8.3-5.3.1
  • libgstplayer-1_0-0-debuginfo >= 1.8.3-5.3.1
  • libgstplayer-1_0-0-debuginfo-32bit >= 1.8.3-5.3.1
  • libgsturidownloader-1_0-0 >= 1.8.3-5.3.1
  • libgsturidownloader-1_0-0-32bit >= 1.8.3-5.3.1
  • libgsturidownloader-1_0-0-debuginfo >= 1.8.3-5.3.1
  • libgsturidownloader-1_0-0-debuginfo-32bit >= 1.8.3-5.3.1
  • libgstvdpau >= 1.8.3-5.3.1
  • libgstvdpau-32bit >= 1.8.3-5.3.1
  • libgstvdpau-debuginfo >= 1.8.3-5.3.1
  • libgstvdpau-debuginfo-32bit >= 1.8.3-5.3.1
  • libgstwayland-1_0-0 >= 1.8.3-5.3.1
  • libgstwayland-1_0-0-32bit >= 1.8.3-5.3.1
  • libgstwayland-1_0-0-debuginfo >= 1.8.3-5.3.1
  • libgstwayland-1_0-0-debuginfo-32bit >= 1.8.3-5.3.1
Patchnames:
openSUSE-2017-479
openSUSE Leap 42.3
  • gstreamer-plugins-bad >= 1.8.3-7.4
  • gstreamer-plugins-bad-lang >= 1.8.3-7.4
  • libgstadaptivedemux-1_0-0 >= 1.8.3-7.4
  • libgstbadaudio-1_0-0 >= 1.8.3-7.4
  • libgstbadbase-1_0-0 >= 1.8.3-7.4
  • libgstbadvideo-1_0-0 >= 1.8.3-7.4
  • libgstbasecamerabinsrc-1_0-0 >= 1.8.3-7.4
  • libgstcodecparsers-1_0-0 >= 1.8.3-7.4
  • libgstgl-1_0-0 >= 1.8.3-7.4
  • libgstmpegts-1_0-0 >= 1.8.3-7.4
  • libgstphotography-1_0-0 >= 1.8.3-7.4
  • libgsturidownloader-1_0-0 >= 1.8.3-7.4
  • libgstwayland-1_0-0 >= 1.8.3-7.4
Patchnames:
openSUSE Leap 42.3 GA gstreamer-plugins-bad


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 gstreamer-plugins-bad Unsupported
SUSE Linux Enterprise Desktop 12 SP2 gstreamer-plugins-bad Not affected
SUSE Linux Enterprise SDK 12 SP1 gstreamer-plugins-bad Unsupported
SUSE Linux Enterprise SDK 12 SP2 gstreamer-plugins-bad Released
SUSE Linux Enterprise Server 12 SP1 gstreamer-plugins-bad Unsupported
SUSE Linux Enterprise Server 12 SP2 gstreamer-plugins-bad Not affected