Upstream information

CVE-2017-5648 at MITRE

Description

While investigating bug 60718, it was noticed that some calls to application listeners in Apache Tomcat 9.0.0.M1 to 9.0.0.M17, 8.5.0 to 8.5.11, 8.0.0.RC1 to 8.0.41, and 7.0.0 to 7.0.75 did not use the appropriate facade object. When running an untrusted application under a SecurityManager, it was therefore possible for that untrusted application to retain a reference to the request or response object and thereby access and/or modify information associated with another web application.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.42 1.53
Vector AV:N/AC:L/Au:N/C:P/I:P/A:N AV:L/AC:M/Au:S/C:P/I:N/A:N
Access Vector Network Local
Access Complexity Low Medium
Authentication None Single
Confidentiality Impact Partial Partial
Integrity Impact Partial None
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.1
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact None
SUSE Bugzilla entry: 1033447 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 12 SP1
  • tomcat >= 8.0.43-10.19.1
  • tomcat-admin-webapps >= 8.0.43-10.19.1
  • tomcat-docs-webapp >= 8.0.43-10.19.1
  • tomcat-el-3_0-api >= 8.0.43-10.19.1
  • tomcat-javadoc >= 8.0.43-10.19.1
  • tomcat-jsp-2_3-api >= 8.0.43-10.19.1
  • tomcat-lib >= 8.0.43-10.19.1
  • tomcat-servlet-3_1-api >= 8.0.43-10.19.1
  • tomcat-webapps >= 8.0.43-10.19.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-848
SUSE Linux Enterprise Server 12 SP2
  • tomcat >= 8.0.43-23.1
  • tomcat-admin-webapps >= 8.0.43-23.1
  • tomcat-docs-webapp >= 8.0.43-23.1
  • tomcat-el-3_0-api >= 8.0.43-23.1
  • tomcat-javadoc >= 8.0.43-23.1
  • tomcat-jsp-2_3-api >= 8.0.43-23.1
  • tomcat-lib >= 8.0.43-23.1
  • tomcat-servlet-3_1-api >= 8.0.43-23.1
  • tomcat-webapps >= 8.0.43-23.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-733
SUSE Linux Enterprise Server 12-LTSS
  • tomcat >= 7.0.78-7.13.4
  • tomcat-admin-webapps >= 7.0.78-7.13.4
  • tomcat-docs-webapp >= 7.0.78-7.13.4
  • tomcat-el-2_2-api >= 7.0.78-7.13.4
  • tomcat-javadoc >= 7.0.78-7.13.4
  • tomcat-jsp-2_2-api >= 7.0.78-7.13.4
  • tomcat-lib >= 7.0.78-7.13.4
  • tomcat-servlet-3_0-api >= 7.0.78-7.13.4
  • tomcat-webapps >= 7.0.78-7.13.4
Patchnames:
SUSE-SLE-SERVER-12-2017-1027
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • tomcat >= 8.0.43-23.1
  • tomcat-admin-webapps >= 8.0.43-23.1
  • tomcat-docs-webapp >= 8.0.43-23.1
  • tomcat-el-3_0-api >= 8.0.43-23.1
  • tomcat-javadoc >= 8.0.43-23.1
  • tomcat-jsp-2_3-api >= 8.0.43-23.1
  • tomcat-lib >= 8.0.43-23.1
  • tomcat-servlet-3_1-api >= 8.0.43-23.1
  • tomcat-webapps >= 8.0.43-23.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-733
SUSE Linux Enterprise for SAP 12
  • tomcat >= 7.0.78-7.13.4
  • tomcat-admin-webapps >= 7.0.78-7.13.4
  • tomcat-docs-webapp >= 7.0.78-7.13.4
  • tomcat-el-2_2-api >= 7.0.78-7.13.4
  • tomcat-javadoc >= 7.0.78-7.13.4
  • tomcat-jsp-2_2-api >= 7.0.78-7.13.4
  • tomcat-lib >= 7.0.78-7.13.4
  • tomcat-servlet-3_0-api >= 7.0.78-7.13.4
  • tomcat-webapps >= 7.0.78-7.13.4
Patchnames:
SUSE-SLE-SAP-12-2017-1027
openSUSE Leap 42.1
  • tomcat >= 8.0.43-17.1
  • tomcat-admin-webapps >= 8.0.43-17.1
  • tomcat-docs-webapp >= 8.0.43-17.1
  • tomcat-el-3_0-api >= 8.0.43-17.1
  • tomcat-embed >= 8.0.43-17.1
  • tomcat-javadoc >= 8.0.43-17.1
  • tomcat-jsp-2_3-api >= 8.0.43-17.1
  • tomcat-jsvc >= 8.0.43-17.1
  • tomcat-lib >= 8.0.43-17.1
  • tomcat-servlet-3_1-api >= 8.0.43-17.1
  • tomcat-webapps >= 8.0.43-17.1
Patchnames:
openSUSE-2017-586
openSUSE Leap 42.2
  • tomcat >= 8.0.43-6.7.1
  • tomcat-admin-webapps >= 8.0.43-6.7.1
  • tomcat-docs-webapp >= 8.0.43-6.7.1
  • tomcat-el-3_0-api >= 8.0.43-6.7.1
  • tomcat-embed >= 8.0.43-6.7.1
  • tomcat-javadoc >= 8.0.43-6.7.1
  • tomcat-jsp-2_3-api >= 8.0.43-6.7.1
  • tomcat-jsvc >= 8.0.43-6.7.1
  • tomcat-lib >= 8.0.43-6.7.1
  • tomcat-servlet-3_1-api >= 8.0.43-6.7.1
  • tomcat-webapps >= 8.0.43-6.7.1
Patchnames:
openSUSE-2017-586