Upstream information

CVE-2017-5563 at MITRE

Description

LibTIFF version 4.0.7 is vulnerable to a heap-based buffer over-read in tif_lzw.c resulting in DoS or code execution via a crafted bmp image to tools/bmp2tiff.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 6.8 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1021652 [RESOLVED / WORKSFORME]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 tiff Unsupported
SUSE Linux Enterprise Desktop 12 SP2 tiff Already fixed
SUSE Linux Enterprise SDK 11 SP4 tiff Not affected
SUSE Linux Enterprise SDK 12 SP1 tiff Unsupported
SUSE Linux Enterprise SDK 12 SP2 tiff Already fixed
SUSE Linux Enterprise Server 11 SP4 tiff Not affected
SUSE Linux Enterprise Server 12 SP1 tiff Unsupported
SUSE Linux Enterprise Server 12 SP2 tiff Already fixed