Upstream information

CVE-2017-5336 at MITRE

Description

Stack-based buffer overflow in the cdk_pk_get_keyid function in lib/opencdk/pubkey.c in GnuTLS before 3.3.26 and 3.5.x before 3.5.8 allows remote attackers to have unspecified impact via a crafted OpenPGP certificate.

SUSE information

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 7.48 6.82
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact Partial Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entries: 1018832 [RESOLVED / FIXED], 1021057

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • gnutls >= 3.2.15-16.1
  • libgnutls28 >= 3.2.15-16.1
  • libgnutls28-32bit >= 3.2.15-16.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-177
SUSE Linux Enterprise Desktop 12 SP2
  • gnutls >= 3.2.15-16.1
  • libgnutls28 >= 3.2.15-16.1
  • libgnutls28-32bit >= 3.2.15-16.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-177
SUSE Linux Enterprise High Availability Extension 11 SP4
  • gnutls >= 2.4.1-24.39.67.1
  • libgnutls-extra26 >= 2.4.1-24.39.67.1
Patchnames:
slehasp4-gnutls-12957
SUSE Linux Enterprise Server 11 SP4
  • gnutls >= 2.4.1-24.39.67.1
  • libgnutls-extra26 >= 2.4.1-24.39.67.1
  • libgnutls26 >= 2.4.1-24.39.67.1
  • libgnutls26-32bit >= 2.4.1-24.39.67.1
  • libgnutls26-x86 >= 2.4.1-24.39.67.1
Patchnames:
slessp4-gnutls-12957
SUSE Linux Enterprise Server 12 SP1
  • gnutls >= 3.2.15-16.1
  • libgnutls-openssl27 >= 3.2.15-16.1
  • libgnutls28 >= 3.2.15-16.1
  • libgnutls28-32bit >= 3.2.15-16.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-177
SUSE Linux Enterprise Server 12 SP2
  • gnutls >= 3.2.15-16.1
  • libgnutls-openssl27 >= 3.2.15-16.1
  • libgnutls28 >= 3.2.15-16.1
  • libgnutls28-32bit >= 3.2.15-16.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-177
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • gnutls >= 3.2.15-16.1
  • libgnutls-openssl27 >= 3.2.15-16.1
  • libgnutls28 >= 3.2.15-16.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-177
SUSE Linux Enterprise Software Development Kit 11 SP4
  • gnutls >= 2.4.1-24.39.67.1
  • libgnutls-devel >= 2.4.1-24.39.67.1
  • libgnutls-extra-devel >= 2.4.1-24.39.67.1
  • libgnutls-extra26 >= 2.4.1-24.39.67.1
Patchnames:
sdksp4-gnutls-12957
SUSE Linux Enterprise Software Development Kit 12 SP1
  • gnutls >= 3.2.15-16.1
  • libgnutls-devel >= 3.2.15-16.1
  • libgnutls-openssl-devel >= 3.2.15-16.1
  • libgnutlsxx-devel >= 3.2.15-16.1
  • libgnutlsxx28 >= 3.2.15-16.1
Patchnames:
SUSE-SLE-SDK-12-SP1-2017-177
SUSE Linux Enterprise Software Development Kit 12 SP2
  • gnutls >= 3.2.15-16.1
  • libgnutls-devel >= 3.2.15-16.1
  • libgnutls-openssl-devel >= 3.2.15-16.1
  • libgnutlsxx-devel >= 3.2.15-16.1
  • libgnutlsxx28 >= 3.2.15-16.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-177
openSUSE Leap 42.1
  • gnutls >= 3.2.15-8.1
  • gnutls-debuginfo >= 3.2.15-8.1
  • gnutls-debugsource >= 3.2.15-8.1
  • libgnutls-devel >= 3.2.15-8.1
  • libgnutls-devel-32bit >= 3.2.15-8.1
  • libgnutls-openssl-devel >= 3.2.15-8.1
  • libgnutls-openssl27 >= 3.2.15-8.1
  • libgnutls-openssl27-debuginfo >= 3.2.15-8.1
  • libgnutls28 >= 3.2.15-8.1
  • libgnutls28-32bit >= 3.2.15-8.1
  • libgnutls28-debuginfo >= 3.2.15-8.1
  • libgnutls28-debuginfo-32bit >= 3.2.15-8.1
  • libgnutlsxx-devel >= 3.2.15-8.1
  • libgnutlsxx28 >= 3.2.15-8.1
  • libgnutlsxx28-debuginfo >= 3.2.15-8.1
Patchnames:
openSUSE-2017-207
openSUSE Leap 42.2
  • gnutls >= 3.2.15-9.1
  • gnutls-debuginfo >= 3.2.15-9.1
  • gnutls-debugsource >= 3.2.15-9.1
  • libgnutls-devel >= 3.2.15-9.1
  • libgnutls-devel-32bit >= 3.2.15-9.1
  • libgnutls-openssl-devel >= 3.2.15-9.1
  • libgnutls-openssl27 >= 3.2.15-9.1
  • libgnutls-openssl27-debuginfo >= 3.2.15-9.1
  • libgnutls28 >= 3.2.15-9.1
  • libgnutls28-32bit >= 3.2.15-9.1
  • libgnutls28-debuginfo >= 3.2.15-9.1
  • libgnutls28-debuginfo-32bit >= 3.2.15-9.1
  • libgnutlsxx-devel >= 3.2.15-9.1
  • libgnutlsxx28 >= 3.2.15-9.1
  • libgnutlsxx28-debuginfo >= 3.2.15-9.1
Patchnames:
openSUSE-2017-207


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Server for SAP 11 SP3
  • SUSE Linux Enterprise Server for SAP 12 GA
gnutls