Upstream information

CVE-2017-5196 at MITRE

Description

Irssi 0.8.18 before 0.8.21 allows remote attackers to cause a denial of service (out-of-bounds read and crash) via vectors involving strings that are not UTF8.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.96
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entry: 1018357 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 13.2
  • irssi >= 0.8.21-3.7.1
  • irssi-debuginfo >= 0.8.21-3.7.1
  • irssi-debugsource >= 0.8.21-3.7.1
  • irssi-devel >= 0.8.21-3.7.1
Patchnames:
openSUSE-2017-67
openSUSE Leap 42.1
  • irssi >= 0.8.21-9.1
  • irssi-debuginfo >= 0.8.21-9.1
  • irssi-debugsource >= 0.8.21-9.1
  • irssi-devel >= 0.8.21-9.1
Patchnames:
openSUSE-2017-67
openSUSE Leap 42.2
  • irssi >= 0.8.21-9.1
  • irssi-debuginfo >= 0.8.21-9.1
  • irssi-debugsource >= 0.8.21-9.1
  • irssi-devel >= 0.8.21-9.1
Patchnames:
openSUSE-2017-67