Upstream information

CVE-2017-3735 at MITRE

Description

While parsing an IPAddressFamily extension in an X.509 certificate, it is possible to do a one-byte overread. This would result in an incorrect text display of the certificate. This bug has been present since 2006 and is present in all versions of OpenSSL before 1.0.2m and 1.1.0g.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 5
Vector AV:N/AC:L/Au:N/C:N/I:P/A:N AV:N/AC:L/Au:N/C:N/I:P/A:N
Access Vector Network Network
Access Complexity Low Low
Authentication None None
Confidentiality Impact None None
Integrity Impact Partial Partial
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 5.3 5.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact Low Low
Availability Impact None None
SUSE Bugzilla entry: 1056058 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • libopenssl1_0_0 >= 1.0.2j-60.16.1
  • openssl >= 1.0.2j-60.16.1
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2017-1970
SUSE CaaS Platform ALL
  • libopenssl1_0_0 >= 1.0.2j-60.16.1
  • openssl >= 1.0.2j-60.16.1
  • sles12-caasp-dex-image >= 2.0.0-3.3.11
  • sles12-dnsmasq-nanny-image >= 2.0.1-2.3.15
  • sles12-haproxy-image >= 2.0.1-2.3.16
  • sles12-kubedns-image >= 2.0.1-2.3.11
  • sles12-mariadb-image >= 2.0.1-2.3.15
  • sles12-openldap-image >= 2.0.0-2.3.11
  • sles12-pause-image >= 2.0.1-2.3.9
  • sles12-pv-recycler-node-image >= 2.0.1-2.3.10
  • sles12-salt-api-image >= 2.0.1-2.3.10
  • sles12-salt-master-image >= 2.0.1-2.3.10
  • sles12-salt-minion-image >= 2.0.1-2.3.14
  • sles12-sidecar-image >= 2.0.1-2.3.11
  • sles12-tiller-image >= 2.0.0-2.3.11
  • sles12-velum-image >= 2.0.1-2.3.13
Patchnames:
SUSE-CAASP-ALL-2017-1970
SUSE-CAASP-ALL-2018-40
SUSE Enterprise Storage 4
  • nodejs4 >= 4.8.7-15.8.1
  • nodejs6 >= 6.12.2-11.8.1
Patchnames:
SUSE-Storage-4-2018-2
SUSE-Storage-4-2018-203
SUSE Linux Enterprise Desktop 12 SP2
  • libopenssl-devel >= 1.0.2j-60.16.1
  • libopenssl1_0_0 >= 1.0.2j-60.16.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.16.1
  • openssl >= 1.0.2j-60.16.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1970
SUSE Linux Enterprise Desktop 12 SP3
  • libopenssl-devel >= 1.0.2j-60.16.1
  • libopenssl1_0_0 >= 1.0.2j-60.16.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.16.1
  • openssl >= 1.0.2j-60.16.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1970
SUSE Linux Enterprise Module for Basesystem 15
  • libopenssl-1_1-devel >= 1.1.0h-2.3
  • libopenssl1_1 >= 1.1.0h-2.3
  • libopenssl1_1-32bit >= 1.1.0h-2.3
  • libopenssl1_1-hmac >= 1.1.0h-2.3
  • libopenssl1_1-hmac-32bit >= 1.1.0h-2.3
  • openssl-1_1 >= 1.1.0h-2.3
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libopenssl-1_1-devel
SUSE Linux Enterprise Module for Legacy Software 15
  • libopenssl-1_0_0-devel >= 1.0.2n-1.32
  • libopenssl1_0_0 >= 1.0.2n-1.32
  • openssl-1_0_0 >= 1.0.2n-1.32
Patchnames:
SUSE Linux Enterprise Module for Legacy Software 15 GA libopenssl-1_0_0-devel
SUSE Linux Enterprise Module for Web Scripting 12
  • nodejs4 >= 4.8.7-15.8.1
  • nodejs4-devel >= 4.8.7-15.8.1
  • nodejs4-docs >= 4.8.7-15.8.1
  • nodejs6 >= 6.12.2-11.8.1
  • nodejs6-devel >= 6.12.2-11.8.1
  • nodejs6-docs >= 6.12.2-11.8.1
  • npm4 >= 4.8.7-15.8.1
  • npm6 >= 6.12.2-11.8.1
Patchnames:
SUSE-SLE-Module-Web-Scripting-12-2018-2
SUSE-SLE-Module-Web-Scripting-12-2018-203
SUSE Linux Enterprise Module for Web Scripting 15
  • nodejs8 >= 8.11.1-1.19
  • nodejs8-devel >= 8.11.1-1.19
  • nodejs8-docs >= 8.11.1-1.19
  • npm8 >= 8.11.1-1.19
Patchnames:
SUSE Linux Enterprise Module for Web Scripting 15 GA nodejs8
SUSE Linux Enterprise Server 11-SECURITY
  • libopenssl1-devel >= 1.0.1g-0.58.3.1
  • libopenssl1_0_0 >= 1.0.1g-0.58.3.1
  • libopenssl1_0_0-32bit >= 1.0.1g-0.58.3.1
  • libopenssl1_0_0-x86 >= 1.0.1g-0.58.3.1
  • openssl1 >= 1.0.1g-0.58.3.1
  • openssl1-doc >= 1.0.1g-0.58.3.1
Patchnames:
secsp3-openssl1-13343
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libopenssl1_0_0 >= 1.0.1i-54.8.1
  • libopenssl1_0_0-32bit >= 1.0.1i-54.8.1
  • libopenssl1_0_0-hmac >= 1.0.1i-54.8.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-54.8.1
  • openssl >= 1.0.1i-54.8.1
  • openssl-doc >= 1.0.1i-54.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1846
SUSE Linux Enterprise Server 12 SP2
  • libopenssl-devel >= 1.0.2j-60.16.1
  • libopenssl1_0_0 >= 1.0.2j-60.16.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.16.1
  • libopenssl1_0_0-hmac >= 1.0.2j-60.16.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-60.16.1
  • openssl >= 1.0.2j-60.16.1
  • openssl-doc >= 1.0.2j-60.16.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1970
SUSE Linux Enterprise Server 12 SP3
  • libopenssl-devel >= 1.0.2j-60.16.1
  • libopenssl1_0_0 >= 1.0.2j-60.16.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.16.1
  • libopenssl1_0_0-hmac >= 1.0.2j-60.16.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-60.16.1
  • openssl >= 1.0.2j-60.16.1
  • openssl-doc >= 1.0.2j-60.16.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1970
SUSE Linux Enterprise Server 12-LTSS
  • libopenssl1_0_0 >= 1.0.1i-27.28.1
  • libopenssl1_0_0-32bit >= 1.0.1i-27.28.1
  • libopenssl1_0_0-hmac >= 1.0.1i-27.28.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-27.28.1
  • openssl >= 1.0.1i-27.28.1
  • openssl-doc >= 1.0.1i-27.28.1
Patchnames:
SUSE-SLE-SERVER-12-2018-79
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libopenssl-devel >= 1.0.2j-60.16.1
  • libopenssl1_0_0 >= 1.0.2j-60.16.1
  • libopenssl1_0_0-hmac >= 1.0.2j-60.16.1
  • openssl >= 1.0.2j-60.16.1
  • openssl-doc >= 1.0.2j-60.16.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1970
SUSE Linux Enterprise Server for SAP Applications 11-SECURITY
  • libopenssl1-devel >= 1.0.1g-0.58.3.1
  • libopenssl1_0_0 >= 1.0.1g-0.58.3.1
  • libopenssl1_0_0-32bit >= 1.0.1g-0.58.3.1
  • libopenssl1_0_0-x86 >= 1.0.1g-0.58.3.1
  • openssl1 >= 1.0.1g-0.58.3.1
  • openssl1-doc >= 1.0.1g-0.58.3.1
Patchnames:
secsp3-openssl1-13343
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libopenssl1_0_0 >= 1.0.1i-54.8.1
  • libopenssl1_0_0-32bit >= 1.0.1i-54.8.1
  • libopenssl1_0_0-hmac >= 1.0.1i-54.8.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-54.8.1
  • openssl >= 1.0.1i-54.8.1
  • openssl-doc >= 1.0.1i-54.8.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2017-1846
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • libopenssl1_0_0 >= 1.0.1i-54.8.1
  • libopenssl1_0_0-32bit >= 1.0.1i-54.8.1
  • libopenssl1_0_0-hmac >= 1.0.1i-54.8.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-54.8.1
  • openssl >= 1.0.1i-54.8.1
  • openssl-doc >= 1.0.1i-54.8.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1846
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libopenssl-devel >= 1.0.2j-60.16.1
  • libopenssl1_0_0 >= 1.0.2j-60.16.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.16.1
  • libopenssl1_0_0-hmac >= 1.0.2j-60.16.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-60.16.1
  • openssl >= 1.0.2j-60.16.1
  • openssl-doc >= 1.0.2j-60.16.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1970
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libopenssl-devel >= 1.0.2j-60.16.1
  • libopenssl1_0_0 >= 1.0.2j-60.16.1
  • libopenssl1_0_0-32bit >= 1.0.2j-60.16.1
  • libopenssl1_0_0-hmac >= 1.0.2j-60.16.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-60.16.1
  • openssl >= 1.0.2j-60.16.1
  • openssl-doc >= 1.0.2j-60.16.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1970
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • libopenssl1_0_0 >= 1.0.1i-27.28.1
  • libopenssl1_0_0-32bit >= 1.0.1i-27.28.1
  • libopenssl1_0_0-hmac >= 1.0.1i-27.28.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-27.28.1
  • openssl >= 1.0.1i-27.28.1
  • openssl-doc >= 1.0.1i-27.28.1
Patchnames:
SUSE-SLE-SERVER-12-2018-79
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libopenssl-devel >= 1.0.2j-60.16.1
  • openssl >= 1.0.2j-60.16.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1970
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libopenssl-devel >= 1.0.2j-60.16.1
  • openssl >= 1.0.2j-60.16.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1970
SUSE OpenStack Cloud 6
  • libopenssl1_0_0 >= 1.0.1i-54.8.1
  • libopenssl1_0_0-32bit >= 1.0.1i-54.8.1
  • libopenssl1_0_0-hmac >= 1.0.1i-54.8.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.1i-54.8.1
  • openssl >= 1.0.1i-54.8.1
  • openssl-doc >= 1.0.1i-54.8.1
Patchnames:
SUSE-OpenStack-Cloud-6-2017-1846
SUSE OpenStack Cloud 7
  • nodejs6 >= 6.12.2-11.8.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-203
openSUSE Leap 15.0
  • libopenssl1_0_0 >= 1.0.2n-lp150.1.25
  • libopenssl1_1 >= 1.1.0h-lp150.2.1
  • libopenssl1_1-32bit >= 1.1.0h-lp150.2.1
  • openssl-1_1 >= 1.1.0h-lp150.2.1
Patchnames:
openSUSE Leap 15.0 GA libopenssl1_0_0
openSUSE Leap 15.0 GA libopenssl1_1
openSUSE Leap 42.2
  • libopenssl-devel >= 1.0.2j-6.6.1
  • libopenssl-devel-32bit >= 1.0.2j-6.6.1
  • libopenssl1_0_0 >= 1.0.2j-6.6.1
  • libopenssl1_0_0-32bit >= 1.0.2j-6.6.1
  • libopenssl1_0_0-debuginfo >= 1.0.2j-6.6.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.2j-6.6.1
  • libopenssl1_0_0-hmac >= 1.0.2j-6.6.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-6.6.1
  • nodejs4 >= 4.8.7-5.9.1
  • nodejs4-debuginfo >= 4.8.7-5.9.1
  • nodejs4-debugsource >= 4.8.7-5.9.1
  • nodejs4-devel >= 4.8.7-5.9.1
  • nodejs4-docs >= 4.8.7-5.9.1
  • npm4 >= 4.8.7-5.9.1
  • openssl >= 1.0.2j-6.6.1
  • openssl-cavs >= 1.0.2j-6.6.1
  • openssl-cavs-debuginfo >= 1.0.2j-6.6.1
  • openssl-debuginfo >= 1.0.2j-6.6.1
  • openssl-debugsource >= 1.0.2j-6.6.1
  • openssl-doc >= 1.0.2j-6.6.1
Patchnames:
openSUSE-2017-1324
openSUSE-2018-5
openSUSE Leap 42.3
  • libopenssl-devel >= 1.0.2j-13.1
  • libopenssl-devel-32bit >= 1.0.2j-13.1
  • libopenssl1_0_0 >= 1.0.2j-13.1
  • libopenssl1_0_0-32bit >= 1.0.2j-13.1
  • libopenssl1_0_0-debuginfo >= 1.0.2j-13.1
  • libopenssl1_0_0-debuginfo-32bit >= 1.0.2j-13.1
  • libopenssl1_0_0-hmac >= 1.0.2j-13.1
  • libopenssl1_0_0-hmac-32bit >= 1.0.2j-13.1
  • nodejs4 >= 4.8.7-11.1
  • nodejs4-debuginfo >= 4.8.7-11.1
  • nodejs4-debugsource >= 4.8.7-11.1
  • nodejs4-devel >= 4.8.7-11.1
  • nodejs4-docs >= 4.8.7-11.1
  • nodejs6 >= 6.12.2-6.1
  • nodejs6-debuginfo >= 6.12.2-6.1
  • nodejs6-debugsource >= 6.12.2-6.1
  • nodejs6-devel >= 6.12.2-6.1
  • nodejs6-docs >= 6.12.2-6.1
  • npm4 >= 4.8.7-11.1
  • npm6 >= 6.12.2-6.1
  • openssl >= 1.0.2j-13.1
  • openssl-cavs >= 1.0.2j-13.1
  • openssl-cavs-debuginfo >= 1.0.2j-13.1
  • openssl-debuginfo >= 1.0.2j-13.1
  • openssl-debugsource >= 1.0.2j-13.1
  • openssl-doc >= 1.0.2j-13.1
Patchnames:
openSUSE-2017-1324
openSUSE-2018-116
openSUSE-2018-5


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 openssl Released
CaaS Platform 2.0 openssl Released
OpenStack Cloud Magnum Orchestration 7.0 openssl Released
SUSE Linux Enterprise Desktop 12 SP2 compat-openssl098 Not affected
SUSE Linux Enterprise Desktop 12 SP2 openssl Released
SUSE Linux Enterprise Desktop 12 SP3 compat-openssl098 Not affected
SUSE Linux Enterprise Desktop 12 SP3 openssl Released
SUSE Linux Enterprise Module for Legacy Software 12 compat-openssl098 Not affected
SUSE Linux Enterprise SDK 11 SP4 openssl Not affected
SUSE Linux Enterprise SDK 12 SP2 openssl Released
SUSE Linux Enterprise SDK 12 SP3 openssl Released
SUSE Linux Enterprise Security Module 11.3 GA openssl1 Released
SUSE Linux Enterprise Server 11 SP3 LTSS openssl Not affected
SUSE Linux Enterprise Server 11 SP4 openssl Not affected
SUSE Linux Enterprise Server 12 GA LTSS openssl Released
SUSE Linux Enterprise Server 12 SP1 LTSS openssl Released
SUSE Linux Enterprise Server 12 SP2 openssl Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI openssl Released
SUSE Linux Enterprise Server 12 SP3 openssl Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 compat-openssl097g Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP4 compat-openssl097g Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 compat-openssl098 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 compat-openssl098 Not affected
SUSE Studio Onsite 1.3 openssl Not affected