Upstream information

CVE-2017-3453 at MITRE

Description

Vulnerability in the MySQL Server component of Oracle MySQL (subcomponent: Server: Optimizer). Supported versions that are affected are 5.5.54 and earlier, 5.6.35 and earlier and 5.7.17 and earlier. Easily "exploitable" vulnerability allows low privileged attacker with network access via multiple protocols to compromise MySQL Server. Successful attacks of this vulnerability can result in unauthorized ability to cause a hang or frequently repeatable crash (complete DOS) of MySQL Server. CVSS 3.0 Base Score 6.5 (Availability impacts). CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4 2.1
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P AV:N/AC:H/Au:S/C:N/I:N/A:P
Access Vector Network Network
Access Complexity Low High
Authentication Single Single
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entries: 1034850 [RESOLVED / FIXED], 1048715 [RESOLVED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform ALL
  • caasp-container-manifests >= 0.0.0+git_r155_93e40ab-2.3.3
  • container-feeder >= 0.0.0+20170901.git_r55_17ecbd3-2.3.3
  • sles12-mariadb-docker-image >= 1.1.0-2.3.10
  • sles12-pause-docker-image >= 1.1.0-2.3.11
  • sles12-pv-recycler-node-docker-image >= 1.1.0-2.3.10
  • sles12-salt-api-docker-image >= 1.1.0-2.3.9
  • sles12-salt-master-docker-image >= 1.1.0-4.3.10
  • sles12-salt-minion-docker-image >= 1.1.0-2.3.8
  • sles12-velum-docker-image >= 1.1.0-4.3.9
Patchnames:
SUSE-CAASP-ALL-2017-1531
SUSE Linux Enterprise Desktop 12 SP2
  • libmysqlclient18 >= 10.0.31-29.3.1
  • libmysqlclient18-32bit >= 10.0.31-29.3.1
  • libmysqlclient_r18 >= 10.0.31-29.3.1
  • libmysqlclient_r18-32bit >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
  • mariadb-client >= 10.0.31-29.3.1
  • mariadb-errormessages >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1247
SUSE Linux Enterprise Desktop 12 SP3
  • libmysqlclient18 >= 10.0.31-29.3.1
  • libmysqlclient18-32bit >= 10.0.31-29.3.1
  • libmysqlclient_r18 >= 10.0.31-29.3.1
  • libmysqlclient_r18-32bit >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
  • mariadb-client >= 10.0.31-29.3.1
  • mariadb-errormessages >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1247
SUSE Linux Enterprise Module for Server Applications 15
  • libmysqld-devel >= 10.2.15-1.3
  • libmysqld19 >= 10.2.15-1.3
  • mariadb >= 10.2.15-1.3
  • mariadb-client >= 10.2.15-1.3
  • mariadb-errormessages >= 10.2.15-1.3
  • mariadb-tools >= 10.2.15-1.3
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA libmysqld-devel
SUSE Linux Enterprise Server 11 SP4
  • libmysql55client18 >= 5.5.55-0.38.1
  • libmysql55client18-32bit >= 5.5.55-0.38.1
  • libmysql55client18-x86 >= 5.5.55-0.38.1
  • libmysql55client_r18 >= 5.5.55-0.38.1
  • libmysql55client_r18-32bit >= 5.5.55-0.38.1
  • libmysql55client_r18-x86 >= 5.5.55-0.38.1
  • mysql >= 5.5.55-0.38.1
  • mysql-client >= 5.5.55-0.38.1
  • mysql-tools >= 5.5.55-0.38.1
Patchnames:
slessp4-mysql-13081
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libmysqlclient-devel >= 10.0.31-29.3.1
  • libmysqlclient18 >= 10.0.31-29.3.1
  • libmysqlclient18-32bit >= 10.0.31-29.3.1
  • libmysqlclient_r18 >= 10.0.31-29.3.1
  • libmysqld-devel >= 10.0.31-29.3.1
  • libmysqld18 >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
  • mariadb-client >= 10.0.31-29.3.1
  • mariadb-errormessages >= 10.0.31-29.3.1
  • mariadb-tools >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1247
SUSE Linux Enterprise Server 12 SP2
  • libmysqlclient18 >= 10.0.31-29.3.1
  • libmysqlclient18-32bit >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
  • mariadb-client >= 10.0.31-29.3.1
  • mariadb-errormessages >= 10.0.31-29.3.1
  • mariadb-tools >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1247
SUSE Linux Enterprise Server 12 SP3
  • libmysqlclient18 >= 10.0.31-29.3.1
  • libmysqlclient18-32bit >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
  • mariadb-client >= 10.0.31-29.3.1
  • mariadb-errormessages >= 10.0.31-29.3.1
  • mariadb-tools >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1247
SUSE Linux Enterprise Server 12-LTSS
  • libmysqlclient-devel >= 10.0.31-20.29.1
  • libmysqlclient18 >= 10.0.31-20.29.1
  • libmysqlclient18-32bit >= 10.0.31-20.29.1
  • libmysqlclient_r18 >= 10.0.31-20.29.1
  • libmysqld-devel >= 10.0.31-20.29.1
  • libmysqld18 >= 10.0.31-20.29.1
  • mariadb >= 10.0.31-20.29.1
  • mariadb-client >= 10.0.31-20.29.1
  • mariadb-errormessages >= 10.0.31-20.29.1
  • mariadb-tools >= 10.0.31-20.29.1
Patchnames:
SUSE-SLE-SERVER-12-2017-1244
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libmysqlclient18 >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
  • mariadb-client >= 10.0.31-29.3.1
  • mariadb-errormessages >= 10.0.31-29.3.1
  • mariadb-tools >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1247
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libmysql55client18 >= 5.5.55-0.38.1
  • libmysql55client18-32bit >= 5.5.55-0.38.1
  • libmysql55client18-x86 >= 5.5.55-0.38.1
  • libmysql55client_r18 >= 5.5.55-0.38.1
  • libmysql55client_r18-32bit >= 5.5.55-0.38.1
  • libmysql55client_r18-x86 >= 5.5.55-0.38.1
  • mysql >= 5.5.55-0.38.1
  • mysql-client >= 5.5.55-0.38.1
  • mysql-tools >= 5.5.55-0.38.1
Patchnames:
slessp4-mysql-13081
SUSE Linux Enterprise Server for SAP Applications 12
  • libmysqlclient-devel >= 10.0.31-20.29.1
  • libmysqlclient18 >= 10.0.31-20.29.1
  • libmysqlclient18-32bit >= 10.0.31-20.29.1
  • libmysqlclient_r18 >= 10.0.31-20.29.1
  • libmysqld-devel >= 10.0.31-20.29.1
  • libmysqld18 >= 10.0.31-20.29.1
  • mariadb >= 10.0.31-20.29.1
  • mariadb-client >= 10.0.31-20.29.1
  • mariadb-errormessages >= 10.0.31-20.29.1
  • mariadb-tools >= 10.0.31-20.29.1
Patchnames:
SUSE-SLE-SAP-12-2017-1244
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libmysqlclient-devel >= 10.0.31-29.3.1
  • libmysqlclient18 >= 10.0.31-29.3.1
  • libmysqlclient18-32bit >= 10.0.31-29.3.1
  • libmysqlclient_r18 >= 10.0.31-29.3.1
  • libmysqld-devel >= 10.0.31-29.3.1
  • libmysqld18 >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
  • mariadb-client >= 10.0.31-29.3.1
  • mariadb-errormessages >= 10.0.31-29.3.1
  • mariadb-tools >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2017-1247
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • libmysqlclient-devel >= 10.0.31-29.3.1
  • libmysqlclient18 >= 10.0.31-29.3.1
  • libmysqlclient18-32bit >= 10.0.31-29.3.1
  • libmysqlclient_r18 >= 10.0.31-29.3.1
  • libmysqld-devel >= 10.0.31-29.3.1
  • libmysqld18 >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
  • mariadb-client >= 10.0.31-29.3.1
  • mariadb-errormessages >= 10.0.31-29.3.1
  • mariadb-tools >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2017-1247
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libmysqlclient18 >= 10.0.31-29.3.1
  • libmysqlclient18-32bit >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
  • mariadb-client >= 10.0.31-29.3.1
  • mariadb-errormessages >= 10.0.31-29.3.1
  • mariadb-tools >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1247
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libmysqlclient18 >= 10.0.31-29.3.1
  • libmysqlclient18-32bit >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
  • mariadb-client >= 10.0.31-29.3.1
  • mariadb-errormessages >= 10.0.31-29.3.1
  • mariadb-tools >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1247
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • libmysqlclient-devel >= 10.0.31-20.29.1
  • libmysqlclient18 >= 10.0.31-20.29.1
  • libmysqlclient18-32bit >= 10.0.31-20.29.1
  • libmysqlclient_r18 >= 10.0.31-20.29.1
  • libmysqld-devel >= 10.0.31-20.29.1
  • libmysqld18 >= 10.0.31-20.29.1
  • mariadb >= 10.0.31-20.29.1
  • mariadb-client >= 10.0.31-20.29.1
  • mariadb-errormessages >= 10.0.31-20.29.1
  • mariadb-tools >= 10.0.31-20.29.1
Patchnames:
SUSE-SLE-SERVER-12-2017-1244
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libmysql55client_r18-32bit >= 5.5.55-0.38.1
  • libmysql55client_r18-x86 >= 5.5.55-0.38.1
  • mysql >= 5.5.55-0.38.1
Patchnames:
sdksp4-mysql-13081
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libmysqlclient-devel >= 10.0.31-29.3.1
  • libmysqlclient_r18 >= 10.0.31-29.3.1
  • libmysqld-devel >= 10.0.31-29.3.1
  • libmysqld18 >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1247
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libmysqlclient-devel >= 10.0.31-29.3.1
  • libmysqlclient_r18 >= 10.0.31-29.3.1
  • libmysqld-devel >= 10.0.31-29.3.1
  • libmysqld18 >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1247
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libmysqlclient_r18 >= 10.0.31-29.3.1
  • libmysqlclient_r18-32bit >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-WE-12-SP2-2017-1247
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libmysqlclient_r18 >= 10.0.31-29.3.1
  • libmysqlclient_r18-32bit >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
Patchnames:
SUSE-SLE-WE-12-SP3-2017-1247
SUSE OpenStack Cloud 6
  • libmysqlclient-devel >= 10.0.31-29.3.1
  • libmysqlclient18 >= 10.0.31-29.3.1
  • libmysqlclient18-32bit >= 10.0.31-29.3.1
  • libmysqlclient_r18 >= 10.0.31-29.3.1
  • libmysqld-devel >= 10.0.31-29.3.1
  • libmysqld18 >= 10.0.31-29.3.1
  • mariadb >= 10.0.31-29.3.1
  • mariadb-client >= 10.0.31-29.3.1
  • mariadb-errormessages >= 10.0.31-29.3.1
  • mariadb-tools >= 10.0.31-29.3.1
Patchnames:
SUSE-OpenStack-Cloud-6-2017-1247
SUSE OpenStack Cloud 7
  • galera-3 >= 25.3.23-8.3
  • galera-3-wsrep-provider >= 25.3.23-8.3
  • libmariadb3 >= 3.0.3-1.3.3
  • mariadb >= 10.2.15-7.1
  • mariadb-client >= 10.2.15-7.1
  • mariadb-connector-c >= 3.0.3-1.3.3
  • mariadb-errormessages >= 10.2.15-7.1
  • mariadb-galera >= 10.2.15-7.1
  • mariadb-tools >= 10.2.15-7.1
  • ruby2.1-rubygem-mysql2 >= 0.4.10-7.2
  • rubygem-mysql2 >= 0.4.10-7.2
  • xtrabackup >= 2.4.10-5.3
Patchnames:
SUSE-OpenStack-Cloud-7-2018-1253
openSUSE Leap 15.0
  • libmysqld19 >= 10.2.14-lp150.1.1
  • mariadb >= 10.2.14-lp150.1.1
  • mariadb-client >= 10.2.14-lp150.1.1
  • mariadb-errormessages >= 10.2.14-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA libmysqld19
openSUSE Leap 42.1
  • libmysql56client18 >= 5.6.36-25.3
  • libmysql56client18-32bit >= 5.6.36-25.3
  • libmysql56client18-debuginfo >= 5.6.36-25.3
  • libmysql56client18-debuginfo-32bit >= 5.6.36-25.3
  • libmysql56client_r18 >= 5.6.36-25.3
  • libmysql56client_r18-32bit >= 5.6.36-25.3
  • mysql-community-server >= 5.6.36-25.3
  • mysql-community-server-bench >= 5.6.36-25.3
  • mysql-community-server-bench-debuginfo >= 5.6.36-25.3
  • mysql-community-server-client >= 5.6.36-25.3
  • mysql-community-server-client-debuginfo >= 5.6.36-25.3
  • mysql-community-server-debuginfo >= 5.6.36-25.3
  • mysql-community-server-debugsource >= 5.6.36-25.3
  • mysql-community-server-errormessages >= 5.6.36-25.3
  • mysql-community-server-test >= 5.6.36-25.3
  • mysql-community-server-test-debuginfo >= 5.6.36-25.3
  • mysql-community-server-tools >= 5.6.36-25.3
  • mysql-community-server-tools-debuginfo >= 5.6.36-25.3
Patchnames:
openSUSE-2017-555
openSUSE Leap 42.2
  • libmysql56client18 >= 5.6.36-24.3.3
  • libmysql56client18-32bit >= 5.6.36-24.3.3
  • libmysql56client18-debuginfo >= 5.6.36-24.3.3
  • libmysql56client18-debuginfo-32bit >= 5.6.36-24.3.3
  • libmysql56client_r18 >= 5.6.36-24.3.3
  • libmysql56client_r18-32bit >= 5.6.36-24.3.3
  • libmysqlclient-devel >= 10.0.31-20.7.1
  • libmysqlclient18 >= 10.0.31-20.7.1
  • libmysqlclient18-32bit >= 10.0.31-20.7.1
  • libmysqlclient18-debuginfo >= 10.0.31-20.7.1
  • libmysqlclient18-debuginfo-32bit >= 10.0.31-20.7.1
  • libmysqlclient_r18 >= 10.0.31-20.7.1
  • libmysqlclient_r18-32bit >= 10.0.31-20.7.1
  • libmysqld-devel >= 10.0.31-20.7.1
  • libmysqld18 >= 10.0.31-20.7.1
  • libmysqld18-debuginfo >= 10.0.31-20.7.1
  • mariadb >= 10.0.31-20.7.1
  • mariadb-bench >= 10.0.31-20.7.1
  • mariadb-bench-debuginfo >= 10.0.31-20.7.1
  • mariadb-client >= 10.0.31-20.7.1
  • mariadb-client-debuginfo >= 10.0.31-20.7.1
  • mariadb-debuginfo >= 10.0.31-20.7.1
  • mariadb-debugsource >= 10.0.31-20.7.1
  • mariadb-errormessages >= 10.0.31-20.7.1
  • mariadb-test >= 10.0.31-20.7.1
  • mariadb-test-debuginfo >= 10.0.31-20.7.1
  • mariadb-tools >= 10.0.31-20.7.1
  • mariadb-tools-debuginfo >= 10.0.31-20.7.1
  • mysql-community-server >= 5.6.36-24.3.3
  • mysql-community-server-bench >= 5.6.36-24.3.3
  • mysql-community-server-bench-debuginfo >= 5.6.36-24.3.3
  • mysql-community-server-client >= 5.6.36-24.3.3
  • mysql-community-server-client-debuginfo >= 5.6.36-24.3.3
  • mysql-community-server-debuginfo >= 5.6.36-24.3.3
  • mysql-community-server-debugsource >= 5.6.36-24.3.3
  • mysql-community-server-errormessages >= 5.6.36-24.3.3
  • mysql-community-server-test >= 5.6.36-24.3.3
  • mysql-community-server-test-debuginfo >= 5.6.36-24.3.3
  • mysql-community-server-tools >= 5.6.36-24.3.3
  • mysql-community-server-tools-debuginfo >= 5.6.36-24.3.3
Patchnames:
openSUSE-2017-555
openSUSE-2017-902
openSUSE Leap 42.3
  • libmysqlclient-devel >= 10.0.31-23.1
  • libmysqlclient18 >= 10.0.31-23.1
  • libmysqlclient18-32bit >= 10.0.31-23.1
  • libmysqlclient18-debuginfo >= 10.0.31-23.1
  • libmysqlclient18-debuginfo-32bit >= 10.0.31-23.1
  • libmysqlclient_r18 >= 10.0.31-23.1
  • libmysqlclient_r18-32bit >= 10.0.31-23.1
  • libmysqld-devel >= 10.0.31-23.1
  • libmysqld18 >= 10.0.31-23.1
  • libmysqld18-debuginfo >= 10.0.31-23.1
  • mariadb >= 10.0.31-23.1
  • mariadb-bench >= 10.0.31-23.1
  • mariadb-bench-debuginfo >= 10.0.31-23.1
  • mariadb-client >= 10.0.31-23.1
  • mariadb-client-debuginfo >= 10.0.31-23.1
  • mariadb-debuginfo >= 10.0.31-23.1
  • mariadb-debugsource >= 10.0.31-23.1
  • mariadb-errormessages >= 10.0.31-23.1
  • mariadb-test >= 10.0.31-23.1
  • mariadb-test-debuginfo >= 10.0.31-23.1
  • mariadb-tools >= 10.0.31-23.1
  • mariadb-tools-debuginfo >= 10.0.31-23.1
Patchnames:
openSUSE-2017-902


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 SP4 mysql Ignore
SUSE Linux Enterprise Server 11 SP3 LTSS mysql Ignore
SUSE Linux Enterprise Server 11 SP4 mysql Released