Upstream information

CVE-2017-3060 at MITRE

Description

Adobe Flash Player versions 25.0.0.127 and earlier have an exploitable memory corruption vulnerability in the ActionScript2 code parser. Successful exploitation could lead to arbitrary code execution.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1033619 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • flash-player >= 25.0.0.148-165.1
  • flash-player-gnome >= 25.0.0.148-165.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-576
SUSE Linux Enterprise Workstation Extension 12 SP1
  • flash-player >= 25.0.0.148-165.1
  • flash-player-gnome >= 25.0.0.148-165.1
Patchnames:
SUSE-SLE-WE-12-SP1-2017-576


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 flash-player Released
SUSE Linux Enterprise Workstation Extension 12 SP1 flash-player Released