Upstream information

CVE-2017-2998 at MITRE

Description

Adobe Flash Player versions 24.0.0.221 and earlier have an exploitable memory corruption vulnerability in the Primetime TVSDK API functionality related to timeline interactions. Successful exploitation could lead to arbitrary code execution.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 10.00
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1029374 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • flash-player >= 25.0.0.127-162.1
  • flash-player-gnome >= 25.0.0.127-162.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-385
SUSE Linux Enterprise Workstation Extension 12 SP1
  • flash-player >= 25.0.0.127-162.1
  • flash-player-gnome >= 25.0.0.127-162.1
Patchnames:
SUSE-SLE-WE-12-SP1-2017-385