Upstream information

CVE-2017-2995 at MITRE

Description

Adobe Flash Player versions 24.0.0.194 and earlier have an exploitable type confusion vulnerability related to the MessageChannel class. Successful exploitation could lead to arbitrary code execution.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 8.8
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1025258 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • flash-player >= 24.0.0.221-158.1
  • flash-player-gnome >= 24.0.0.221-158.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-268
SUSE Linux Enterprise Workstation Extension 12 SP1
  • flash-player >= 24.0.0.221-158.1
  • flash-player-gnome >= 24.0.0.221-158.1
Patchnames:
SUSE-SLE-WE-12-SP1-2017-268


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 flash-player Released
SUSE Linux Enterprise Workstation Extension 12 SP1 flash-player Released