Upstream information

CVE-2017-2982 at MITRE

Description

Adobe Flash Player versions 24.0.0.194 and earlier have an exploitable use after free vulnerability in a routine related to player shutdown. Successful exploitation could lead to arbitrary code execution.

SUSE information

CVSS v2 Scores
  National Vulnerability Database
Base Score 10.00
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
CVSS v3 Scores
  National Vulnerability Database
Base Score 9.8
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1025258 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP1
  • flash-player >= 24.0.0.221-158.1
  • flash-player-gnome >= 24.0.0.221-158.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP1-2017-268
SUSE Linux Enterprise Workstation Extension 12 SP1
  • flash-player >= 24.0.0.221-158.1
  • flash-player-gnome >= 24.0.0.221-158.1
Patchnames:
SUSE-SLE-WE-12-SP1-2017-268