Upstream information

CVE-2017-2808 at MITRE

Description

An exploitable use-after-free vulnerability exists in the account parsing component of the Ledger-CLI 3.1.1. A specially crafted ledger file can cause a use-after-free vulnerability resulting in arbitrary code execution. An attacker can convince a user to load a journal file to trigger this vulnerability.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
No SUSE Bugzilla entries cross referenced.

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • ledger >= 3.1.3-lp150.2.3.1
  • ledger-debuginfo >= 3.1.3-lp150.2.3.1
  • ledger-debugsource >= 3.1.3-lp150.2.3.1
Patchnames:
openSUSE-2019-1779
openSUSE Leap 15.1
  • ledger >= 3.1.3-lp151.3.3.1
  • ledger-debuginfo >= 3.1.3-lp151.3.3.1
  • ledger-debugsource >= 3.1.3-lp151.3.3.1
Patchnames:
openSUSE-2019-1779