Upstream information

CVE-2017-2668 at MITRE

Description

389-ds-base before versions 1.3.5.17 and 1.3.6.10 is vulnerable to an invalid pointer dereference in the way LDAP bind requests are handled. A remote unauthenticated attacker could use this flaw to make ns-slapd crash via a specially crafted LDAP bind request, resulting in denial of service.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having critical severity.

SUSE Bugzilla entry: 1069067 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.2
  • 389-ds >= 1.3.4.5-5.5.1
  • 389-ds-debuginfo >= 1.3.4.5-5.5.1
  • 389-ds-debugsource >= 1.3.4.5-5.5.1
  • 389-ds-devel >= 1.3.4.5-5.5.1
Patchnames:
openSUSE-2017-1396
openSUSE Leap 42.3
  • 389-ds >= 1.3.4.5-8.1
  • 389-ds-debuginfo >= 1.3.4.5-8.1
  • 389-ds-debugsource >= 1.3.4.5-8.1
  • 389-ds-devel >= 1.3.4.5-8.1
Patchnames:
openSUSE-2017-1396