Upstream information

CVE-2017-2626 at MITRE

Description

It was discovered that libICE before 1.0.9-8 used a weak entropy to generate keys. A local attacker could potentially use this flaw for session hijacking using the information available from the process list.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 2.1 2.1
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N AV:L/AC:L/Au:N/C:P/I:N/A:N
Access Vector Local Local
Access Complexity Low Low
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact None None
CVSS v3 Scores
  National Vulnerability Database
Base Score 5.5
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 1025068 [RESOLVED / FIXED], 1025639 [RESOLVED / FIXED], 1048274 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libICE >= 1.0.8-10.1
  • libICE6 >= 1.0.8-10.1
  • libICE6-32bit >= 1.0.8-10.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1134
SUSE Linux Enterprise Desktop 12 SP3
  • libICE >= 1.0.8-12.1
  • libICE6 >= 1.0.8-12.1
  • libICE6-32bit >= 1.0.8-12.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-237
SUSE Linux Enterprise Module for Basesystem 15
  • libICE-devel >= 1.0.9-1.25
  • libICE6 >= 1.0.9-1.25
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libICE-devel
SUSE Linux Enterprise Module for Desktop Applications 15
  • libICE6-32bit >= 1.0.9-1.25
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libICE6-32bit
SUSE Linux Enterprise Server 11 SP4
  • xorg-x11-libICE >= 7.4-3.1
  • xorg-x11-libICE-32bit >= 7.4-3.1
  • xorg-x11-libICE-x86 >= 7.4-3.1
Patchnames:
slessp4-xorg-x11-libICE-13207
SUSE Linux Enterprise Server 12 SP2
  • libICE >= 1.0.8-10.1
  • libICE6 >= 1.0.8-10.1
  • libICE6-32bit >= 1.0.8-10.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1134
SUSE Linux Enterprise Server 12 SP3
  • libICE >= 1.0.8-12.1
  • libICE6 >= 1.0.8-12.1
  • libICE6-32bit >= 1.0.8-12.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-237
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libICE >= 1.0.8-10.1
  • libICE6 >= 1.0.8-10.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1134
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • xorg-x11-libICE >= 7.4-3.1
  • xorg-x11-libICE-32bit >= 7.4-3.1
  • xorg-x11-libICE-x86 >= 7.4-3.1
Patchnames:
slessp4-xorg-x11-libICE-13207
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libICE >= 1.0.8-10.1
  • libICE6 >= 1.0.8-10.1
  • libICE6-32bit >= 1.0.8-10.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1134
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libICE >= 1.0.8-12.1
  • libICE6 >= 1.0.8-12.1
  • libICE6-32bit >= 1.0.8-12.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-237
SUSE Linux Enterprise Software Development Kit 11 SP4
  • xorg-x11-libICE >= 7.4-3.1
  • xorg-x11-libICE-devel >= 7.4-3.1
  • xorg-x11-libICE-devel-32bit >= 7.4-3.1
Patchnames:
sdksp4-xorg-x11-libICE-13207
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libICE >= 1.0.8-10.1
  • libICE-devel >= 1.0.8-10.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1134
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libICE >= 1.0.8-12.1
  • libICE-devel >= 1.0.8-12.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-237
openSUSE Leap 15.0
  • libICE6 >= 1.0.9-lp150.1.6
Patchnames:
openSUSE Leap 15.0 GA libICE6
openSUSE Leap 42.2
  • libICE >= 1.0.9-5.3.1
  • libICE-debugsource >= 1.0.9-5.3.1
  • libICE-devel >= 1.0.9-5.3.1
  • libICE-devel-32bit >= 1.0.9-5.3.1
  • libICE6 >= 1.0.9-5.3.1
  • libICE6-32bit >= 1.0.9-5.3.1
  • libICE6-debuginfo >= 1.0.9-5.3.1
  • libICE6-debuginfo-32bit >= 1.0.9-5.3.1
Patchnames:
openSUSE-2017-784
openSUSE Leap 42.3
  • libICE-devel >= 1.0.9-7.1
  • libICE6 >= 1.0.9-7.1
  • libICE6-32bit >= 1.0.9-7.1
Patchnames:
openSUSE Leap 42.3 GA libICE-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 libICE Unsupported
SUSE Linux Enterprise Desktop 12 SP1 xorg-x11 Not affected
SUSE Linux Enterprise Desktop 12 SP2 libICE Released
SUSE Linux Enterprise Desktop 12 SP2 xorg-x11 Not affected
SUSE Linux Enterprise Desktop 12 SP3 libICE Released
SUSE Linux Enterprise SDK 11 SP4 xorg-x11-libICE Released
SUSE Linux Enterprise SDK 12 SP1 libICE Unsupported
SUSE Linux Enterprise SDK 12 SP2 libICE Released
SUSE Linux Enterprise SDK 12 SP3 libICE Released
SUSE Linux Enterprise Server 11 SP4 xorg-x11 Not affected
SUSE Linux Enterprise Server 11 SP4 xorg-x11-libICE Released
SUSE Linux Enterprise Server 12 SP1 libICE Unsupported
SUSE Linux Enterprise Server 12 SP1 xorg-x11 Not affected
SUSE Linux Enterprise Server 12 SP2 libICE Released
SUSE Linux Enterprise Server 12 SP2 xorg-x11 Not affected
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI libICE Released
SUSE Linux Enterprise Server 12 SP3 libICE Released