Upstream information

CVE-2017-2518 at MITRE

Description

An issue was discovered in certain Apple products. iOS before 10.3.2 is affected. macOS before 10.12.5 is affected. tvOS before 10.2.1 is affected. watchOS before 3.2.2 is affected. The issue involves the "SQLite" component. It allows remote attackers to execute arbitrary code or cause a denial of service (buffer overflow and application crash) via a crafted SQL statement.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 7.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Local
Access Complexity Low Low
Privileges Required None Low
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entry: 1155787 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
HPE-Helion-OpenStack-8-2019-3050
SUSE CaaS Platform 3.0
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-CAASP-3.0-2019-3050
SUSE Enterprise Storage 5
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-Storage-5-2019-3050
SUSE Linux Enterprise Desktop 12 SP4
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP4-2019-3050
SUSE Linux Enterprise Point of Sale 11 SP3
  • libsqlite3-0 >= 3.7.6.3-1.4.7.12.1
  • sqlite3 >= 3.7.6.3-1.4.7.12.1
Patchnames:
sleposp3-sqlite3-14227
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2019-3050
SUSE Linux Enterprise Server 11 SP4-LTSS
  • libsqlite3-0 >= 3.7.6.3-1.4.7.12.1
  • libsqlite3-0-32bit >= 3.7.6.3-1.4.7.12.1
  • sqlite3 >= 3.7.6.3-1.4.7.12.1
Patchnames:
slessp4-sqlite3-14227
SUSE Linux Enterprise Server 12 SP1-LTSS
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-3050
SUSE Linux Enterprise Server 12 SP2-BCL
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-3050
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-3050
SUSE Linux Enterprise Server 12 SP2-LTSS
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-3050
SUSE Linux Enterprise Server 12 SP3-BCL
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-3050
SUSE Linux Enterprise Server 12 SP3-ESPOS
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-3050
SUSE Linux Enterprise Server 12 SP3-LTSS
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-3050
SUSE Linux Enterprise Server 12 SP4
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-3050
SUSE Linux Enterprise Server 12 SP5
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-3050
SUSE Linux Enterprise Server for SAP Applications 11 SP4-LTSS
  • libsqlite3-0 >= 3.7.6.3-1.4.7.12.1
  • libsqlite3-0-32bit >= 3.7.6.3-1.4.7.12.1
  • sqlite3 >= 3.7.6.3-1.4.7.12.1
Patchnames:
slessp4-sqlite3-14227
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2019-3050
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2019-3050
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2019-3050
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2019-3050
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2019-3050
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2019-3050
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2019-3050
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2019-3050
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2019-3050
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2019-3050
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-2019-3050
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2019-3050
SUSE Linux Enterprise Software Development Kit 12 SP4
  • sqlite3 >= 3.8.10.2-9.15.1
  • sqlite3-devel >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SDK-12-SP4-2019-3050
SUSE Linux Enterprise Software Development Kit 12 SP5
  • sqlite3 >= 3.8.10.2-9.15.1
  • sqlite3-devel >= 3.8.10.2-9.15.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2019-3050
SUSE OpenStack Cloud 7
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-OpenStack-Cloud-7-2019-3050
SUSE OpenStack Cloud 8
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-OpenStack-Cloud-8-2019-3050
SUSE OpenStack Cloud Crowbar 8
  • libsqlite3-0 >= 3.8.10.2-9.15.1
  • libsqlite3-0-32bit >= 3.8.10.2-9.15.1
  • sqlite3 >= 3.8.10.2-9.15.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2019-3050


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 sqlite3 Affected
CaaS Platform 2.0 sqlite3 Affected
CaaS Platform 3.0 sqlite3 Released
OpenStack Cloud Magnum Orchestration 7.0 sqlite3 Affected
SUSE Business Critical Linux 12 SP2 sqlite3 Released
SUSE Linux Enterprise Desktop 11 GA sqlite2 Not affected
SUSE Linux Enterprise Desktop 11 GA sqlite3 Affected
SUSE Linux Enterprise Desktop 11 SP1 sqlite2 Not affected
SUSE Linux Enterprise Desktop 11 SP1 sqlite3 Affected
SUSE Linux Enterprise Desktop 11 SP2 sqlite2 Not affected
SUSE Linux Enterprise Desktop 11 SP2 sqlite3 Affected
SUSE Linux Enterprise Desktop 11 SP3 sqlite2 Not affected
SUSE Linux Enterprise Desktop 11 SP3 sqlite3 Affected
SUSE Linux Enterprise Desktop 11 SP4 sqlite2 Not affected
SUSE Linux Enterprise Desktop 11 SP4 sqlite3 Affected
SUSE Linux Enterprise Desktop 12 GA sqlite3 Affected
SUSE Linux Enterprise Desktop 12 SP1 sqlite3 Affected
SUSE Linux Enterprise Desktop 12 SP2 sqlite3 Affected
SUSE Linux Enterprise Desktop 12 SP3 sqlite3 Affected
SUSE Linux Enterprise Desktop 12 SP4 sqlite3 Released
SUSE Linux Enterprise High Availability 12 GA sqlite2 Not affected
SUSE Linux Enterprise High Availability 12 SP1 sqlite2 Not affected
SUSE Linux Enterprise High Availability 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise High Availability 12 SP3 sqlite2 Not affected
SUSE Linux Enterprise High Availability 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 11 GA sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 11 SP1 sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 11 SP2 sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 11 SP3 sqlite2 Not affected
SUSE Linux Enterprise High Availability Extension 11 SP4 sqlite2 Not affected
SUSE Linux Enterprise High Performance Computing 12 sqlite3 Released
SUSE Linux Enterprise Module for Basesystem 15 GA sqlite3 Already fixed
SUSE Linux Enterprise Module for Basesystem 15 SP1 sqlite3 Already fixed
SUSE Linux Enterprise SDK 11 GA sqlite2 Not affected
SUSE Linux Enterprise SDK 11 GA sqlite3 Affected
SUSE Linux Enterprise SDK 11 SP1 sqlite2 Not affected
SUSE Linux Enterprise SDK 11 SP1 sqlite3 Affected
SUSE Linux Enterprise SDK 11 SP2 sqlite2 Not affected
SUSE Linux Enterprise SDK 11 SP2 sqlite3 Affected
SUSE Linux Enterprise SDK 11 SP3 sqlite2 Not affected
SUSE Linux Enterprise SDK 11 SP3 sqlite3 Affected
SUSE Linux Enterprise SDK 11 SP4 sqlite2 Not affected
SUSE Linux Enterprise SDK 11 SP4 sqlite3 Affected
SUSE Linux Enterprise SDK 12 GA sqlite2 Not affected
SUSE Linux Enterprise SDK 12 GA sqlite3 Affected
SUSE Linux Enterprise SDK 12 SP1 sqlite2 Not affected
SUSE Linux Enterprise SDK 12 SP1 sqlite3 Affected
SUSE Linux Enterprise SDK 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise SDK 12 SP2 sqlite3 Affected
SUSE Linux Enterprise SDK 12 SP3 sqlite2 Not affected
SUSE Linux Enterprise SDK 12 SP3 sqlite3 Affected
SUSE Linux Enterprise SDK 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise SDK 12 SP4 sqlite3 Released
SUSE Linux Enterprise SDK 12 SP5 sqlite3 Released
SUSE Linux Enterprise Server 10 SP4 LTSS sqlite Not affected
SUSE Linux Enterprise Server 10 SP4 LTSS sqlite2 Not affected
SUSE Linux Enterprise Server 11 SP1 sqlite3 Affected
SUSE Linux Enterprise Server 11 SP1 LTSS sqlite3 Affected
SUSE Linux Enterprise Server 11 SP2 sqlite3 Affected
SUSE Linux Enterprise Server 11 SP2 LTSS sqlite3 Affected
SUSE Linux Enterprise Server 11 SP3 sqlite3 Affected
SUSE Linux Enterprise Server 11 SP3 LTSS sqlite3 Affected
SUSE Linux Enterprise Server 11 SP4 sqlite3 Affected
SUSE Linux Enterprise Server 11 SP4 LTSS sqlite3 Released
SUSE Linux Enterprise Server 12 GA sqlite3 Affected
SUSE Linux Enterprise Server 12 GA LTSS sqlite3 Affected
SUSE Linux Enterprise Server 12 SP1 sqlite3 Affected
SUSE Linux Enterprise Server 12 SP1 LTSS sqlite3 Released
SUSE Linux Enterprise Server 12 SP2 sqlite3 Affected
SUSE Linux Enterprise Server 12 SP2 LTSS sqlite3 Released
SUSE Linux Enterprise Server 12 SP2 for Raspberry PI sqlite3 Affected
SUSE Linux Enterprise Server 12 SP3 sqlite3 Affected
SUSE Linux Enterprise Server 12 SP3 LTSS sqlite3 Released
SUSE Linux Enterprise Server 12 SP4 sqlite3 Released
SUSE Linux Enterprise Server 12 SP5 sqlite3 Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP AIO 11 SP1 sqlite3 Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 sqlite3 Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 sqlite3 Affected
SUSE Linux Enterprise Server for SAP Applications 12 GA sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 GA sqlite3 Affected
SUSE Linux Enterprise Server for SAP Applications 12 SP1 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 sqlite3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 sqlite3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 sqlite3 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 sqlite3 Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 sqlite2 Not affected
SUSE Linux Enterprise Server for SAP ES 11 SP1 sqlite3 Affected
SUSE Linux Enterprise Server for VMWare 11 SP2 sqlite3 Affected
SUSE Linux Enterprise Server for VMWare 11 SP3 sqlite3 Affected
SUSE Studio Onsite 1.3 sqlite3 Affected