Upstream information

CVE-2017-2350 at MITRE

Description

An issue was discovered in certain Apple products. iOS before 10.2.1 is affected. Safari before 10.0.3 is affected. tvOS before 10.1.1 is affected. The issue involves the "WebKit" component. It allows remote attackers to bypass the Same Origin Policy and obtain sensitive information via a crafted web site.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4.3 6.8
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network Network
Access Complexity Medium Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None Partial
Availability Impact None Partial
CVSS v3 Scores
  National Vulnerability Database
Base Score 6.5
Vector AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:N/A:N
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 1024749

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libjavascriptcoregtk-4_0-18 >= 2.18.0-2.9.1
  • libwebkit2gtk-4_0-37 >= 2.18.0-2.9.1
  • libwebkit2gtk3-lang >= 2.18.0-2.9.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.18.0-2.9.1
  • typelib-1_0-WebKit2-4_0 >= 2.18.0-2.9.1
  • webkit2gtk-4_0-injected-bundles >= 2.18.0-2.9.1
  • webkit2gtk3 >= 2.18.0-2.9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-1815
SUSE Linux Enterprise Desktop 12 SP3
  • libjavascriptcoregtk-4_0-18 >= 2.18.0-2.9.1
  • libwebkit2gtk-4_0-37 >= 2.18.0-2.9.1
  • libwebkit2gtk3-lang >= 2.18.0-2.9.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.18.0-2.9.1
  • typelib-1_0-WebKit2-4_0 >= 2.18.0-2.9.1
  • webkit2gtk-4_0-injected-bundles >= 2.18.0-2.9.1
  • webkit2gtk3 >= 2.18.0-2.9.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-1815
SUSE Linux Enterprise Server 12 SP2
  • libjavascriptcoregtk-4_0-18 >= 2.18.0-2.9.1
  • libwebkit2gtk-4_0-37 >= 2.18.0-2.9.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.18.0-2.9.1
  • typelib-1_0-WebKit2-4_0 >= 2.18.0-2.9.1
  • webkit2gtk-4_0-injected-bundles >= 2.18.0-2.9.1
  • webkit2gtk3 >= 2.18.0-2.9.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-1815
SUSE Linux Enterprise Server 12 SP3
  • libjavascriptcoregtk-4_0-18 >= 2.18.0-2.9.1
  • libwebkit2gtk-4_0-37 >= 2.18.0-2.9.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.18.0-2.9.1
  • typelib-1_0-WebKit2-4_0 >= 2.18.0-2.9.1
  • webkit2gtk-4_0-injected-bundles >= 2.18.0-2.9.1
  • webkit2gtk3 >= 2.18.0-2.9.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-1815
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libjavascriptcoregtk-4_0-18 >= 2.18.0-2.9.1
  • libwebkit2gtk-4_0-37 >= 2.18.0-2.9.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.18.0-2.9.1
  • typelib-1_0-WebKit2-4_0 >= 2.18.0-2.9.1
  • webkit2gtk-4_0-injected-bundles >= 2.18.0-2.9.1
  • webkit2gtk3 >= 2.18.0-2.9.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-1815
SUSE Linux Enterprise Software Development Kit 12 SP2
  • webkit2gtk3 >= 2.18.0-2.9.1
  • webkit2gtk3-devel >= 2.18.0-2.9.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-1815
SUSE Linux Enterprise Software Development Kit 12 SP3
  • webkit2gtk3 >= 2.18.0-2.9.1
  • webkit2gtk3-devel >= 2.18.0-2.9.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-1815
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libwebkit2gtk3-lang >= 2.18.0-2.9.1
  • webkit2gtk3 >= 2.18.0-2.9.1
Patchnames:
SUSE-SLE-WE-12-SP2-2017-1815
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libwebkit2gtk3-lang >= 2.18.0-2.9.1
  • webkit2gtk3 >= 2.18.0-2.9.1
Patchnames:
SUSE-SLE-WE-12-SP3-2017-1815
openSUSE Leap 42.2
  • libjavascriptcoregtk-4_0-18 >= 2.18.0-2.3.1
  • libjavascriptcoregtk-4_0-18-32bit >= 2.18.0-2.3.1
  • libjavascriptcoregtk-4_0-18-debuginfo >= 2.18.0-2.3.1
  • libjavascriptcoregtk-4_0-18-debuginfo-32bit >= 2.18.0-2.3.1
  • libwebkit2gtk-4_0-37 >= 2.18.0-2.3.1
  • libwebkit2gtk-4_0-37-32bit >= 2.18.0-2.3.1
  • libwebkit2gtk-4_0-37-debuginfo >= 2.18.0-2.3.1
  • libwebkit2gtk-4_0-37-debuginfo-32bit >= 2.18.0-2.3.1
  • libwebkit2gtk3-lang >= 2.18.0-2.3.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.18.0-2.3.1
  • typelib-1_0-WebKit2-4_0 >= 2.18.0-2.3.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.18.0-2.3.1
  • webkit-jsc-4 >= 2.18.0-2.3.1
  • webkit-jsc-4-debuginfo >= 2.18.0-2.3.1
  • webkit2gtk-4_0-injected-bundles >= 2.18.0-2.3.1
  • webkit2gtk-4_0-injected-bundles-debuginfo >= 2.18.0-2.3.1
  • webkit2gtk3 >= 2.18.0-2.3.1
  • webkit2gtk3-debugsource >= 2.18.0-2.3.1
  • webkit2gtk3-devel >= 2.18.0-2.3.1
  • webkit2gtk3-plugin-process-gtk2 >= 2.18.0-2.3.1
  • webkit2gtk3-plugin-process-gtk2-debuginfo >= 2.18.0-2.3.1
Patchnames:
openSUSE-2017-1268
openSUSE Leap 42.3
  • libjavascriptcoregtk-4_0-18 >= 2.18.0-5.1
  • libjavascriptcoregtk-4_0-18-32bit >= 2.18.0-5.1
  • libjavascriptcoregtk-4_0-18-debuginfo >= 2.18.0-5.1
  • libjavascriptcoregtk-4_0-18-debuginfo-32bit >= 2.18.0-5.1
  • libwebkit2gtk-4_0-37 >= 2.18.0-5.1
  • libwebkit2gtk-4_0-37-32bit >= 2.18.0-5.1
  • libwebkit2gtk-4_0-37-debuginfo >= 2.18.0-5.1
  • libwebkit2gtk-4_0-37-debuginfo-32bit >= 2.18.0-5.1
  • libwebkit2gtk3-lang >= 2.18.0-5.1
  • typelib-1_0-JavaScriptCore-4_0 >= 2.18.0-5.1
  • typelib-1_0-WebKit2-4_0 >= 2.18.0-5.1
  • typelib-1_0-WebKit2WebExtension-4_0 >= 2.18.0-5.1
  • webkit-jsc-4 >= 2.18.0-5.1
  • webkit-jsc-4-debuginfo >= 2.18.0-5.1
  • webkit2gtk-4_0-injected-bundles >= 2.18.0-5.1
  • webkit2gtk-4_0-injected-bundles-debuginfo >= 2.18.0-5.1
  • webkit2gtk3 >= 2.18.0-5.1
  • webkit2gtk3-debugsource >= 2.18.0-5.1
  • webkit2gtk3-devel >= 2.18.0-5.1
  • webkit2gtk3-plugin-process-gtk2 >= 2.18.0-5.1
  • webkit2gtk3-plugin-process-gtk2-debuginfo >= 2.18.0-5.1
Patchnames:
openSUSE-2017-1268


List of planned updates

The following information is the current evaluation information for this security issue. It might neither be accurate nor complete, Use at own risk.
Product(s) Source package
  • SUSE Linux Enterprise Desktop 12 SP2
  • SUSE Linux Enterprise SDK 12 SP2
  • SUSE Linux Enterprise Workstation Extension 12 SP2
webkitgtk


Status of this issue by product and package

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP1 webkitgtk Unsupported
SUSE Linux Enterprise Desktop 12 SP2 webkitgtk Affected
SUSE Linux Enterprise SDK 12 SP1 webkitgtk Unsupported
SUSE Linux Enterprise SDK 12 SP2 webkitgtk Affected
SUSE Linux Enterprise Workstation Extension 12 SP1 webkitgtk Unsupported
SUSE Linux Enterprise Workstation Extension 12 SP2 webkitgtk Affected