Upstream information

CVE-2017-18922 at MITRE

Description

It was discovered that websockets.c in LibVNCServer prior to 0.9.12 did not properly decode certain WebSocket frames. A malicious attacker could exploit this by sending specially crafted WebSocket frames to a server, causing a heap-based buffer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 9.8 8.1
Vector CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Access Vector Network Network
Access Complexity Low High
Privileges Required None None
User Interaction None None
Scope Unchanged Unchanged
Confidentiality Impact High High
Integrity Impact High High
Availability Impact High High
CVSSv3 Version 3.1 3.1
SUSE Bugzilla entry: 1173477 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
HPE Helion Openstack 8
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
HPE-Helion-OpenStack-8-2020-2167
SUSE Enterprise Storage 5
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-Storage-5-2020-2167
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • LibVNCServer >= 0.9.10-4.22.1
  • LibVNCServer-devel >= 0.9.10-4.22.1
  • libvncserver0 >= 0.9.10-4.22.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1873
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2020-1922
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP2
  • LibVNCServer >= 0.9.10-4.22.1
  • LibVNCServer-devel >= 0.9.10-4.22.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-1873
SUSE-SLE-Module-Development-Tools-OBS-15-SP2-2020-1922
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP1
  • LibVNCServer >= 0.9.10-4.22.1
  • libvncserver0 >= 0.9.10-4.22.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP1-2020-1873
SUSE-SLE-Module-Packagehub-Subpackages-15-SP1-2020-1922
SUSE Linux Enterprise Module for additional PackageHub packages 15 SP2
  • LibVNCServer >= 0.9.10-4.22.1
  • libvncserver0 >= 0.9.10-4.22.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2020-1873
SUSE-SLE-Module-Packagehub-Subpackages-15-SP2-2020-1922
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2020-2167
SUSE Linux Enterprise Server 12 SP2-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2020-2167
SUSE Linux Enterprise Server 12 SP2-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2020-2167
SUSE Linux Enterprise Server 12 SP2-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2020-2167
SUSE Linux Enterprise Server 12 SP3-BCL
SUSE Linux Enterprise Server for SAP Applications 12 SP3-BCL
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-BCL-2020-2167
SUSE Linux Enterprise Server 12 SP3-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-ESPOS
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-ESPOS-2020-2167
SUSE Linux Enterprise Server 12 SP3-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP3-LTSS
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2020-2167
SUSE Linux Enterprise Server 12 SP4-ESPOS
SUSE Linux Enterprise Server for SAP Applications 12 SP4-ESPOS
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-ESPOS-2020-2167
SUSE Linux Enterprise Server 12 SP4-LTSS
SUSE Linux Enterprise Server for SAP Applications 12 SP4-LTSS
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-SERVER-12-SP4-LTSS-2020-2167
SUSE Linux Enterprise Server 12 SP5
SUSE Linux Enterprise Server for SAP Applications 12 SP5
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-SERVER-12-SP5-2020-2167
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2020-2167
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-SAP-12-SP3-2020-2167
SUSE Linux Enterprise Server for SAP Applications 12 SP4
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-SAP-12-SP4-2020-2167
SUSE Linux Enterprise Software Development Kit 12 SP5
  • LibVNCServer >= 0.9.9-17.31.1
  • LibVNCServer-devel >= 0.9.9-17.31.1
Patchnames:
SUSE-SLE-SDK-12-SP5-2020-2167
SUSE Linux Enterprise Workstation Extension 15 SP1
  • LibVNCServer >= 0.9.10-4.22.1
  • libvncclient0 >= 0.9.10-4.22.1
Patchnames:
SUSE-SLE-Product-WE-15-SP1-2020-1873
SUSE-SLE-Product-WE-15-SP1-2020-1922
SUSE Linux Enterprise Workstation Extension 15 SP2
  • LibVNCServer >= 0.9.10-4.22.1
  • libvncclient0 >= 0.9.10-4.22.1
  • libvncserver0 >= 0.9.10-4.22.1
Patchnames:
SUSE-SLE-Product-WE-15-SP2-2020-1873
SUSE-SLE-Product-WE-15-SP2-2020-1922
SUSE OpenStack Cloud 7
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-OpenStack-Cloud-7-2020-2167
SUSE OpenStack Cloud 8
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-OpenStack-Cloud-8-2020-2167
SUSE OpenStack Cloud 9
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-OpenStack-Cloud-9-2020-2167
SUSE OpenStack Cloud Crowbar 8
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-8-2020-2167
SUSE OpenStack Cloud Crowbar 9
  • LibVNCServer >= 0.9.9-17.31.1
  • libvncclient0 >= 0.9.9-17.31.1
  • libvncserver0 >= 0.9.9-17.31.1
Patchnames:
SUSE-OpenStack-Cloud-Crowbar-9-2020-2167
openSUSE Leap 15.1
  • LibVNCServer >= 0.9.10-lp151.7.9.1
  • LibVNCServer-debugsource >= 0.9.10-lp151.7.9.1
  • LibVNCServer-devel >= 0.9.10-lp151.7.9.1
  • libvncclient0 >= 0.9.10-lp151.7.9.1
  • libvncclient0-debuginfo >= 0.9.10-lp151.7.9.1
  • libvncserver0 >= 0.9.10-lp151.7.9.1
  • libvncserver0-debuginfo >= 0.9.10-lp151.7.9.1
Patchnames:
openSUSE-2020-960
openSUSE-2020-988
openSUSE Leap 15.2
  • LibVNCServer >= 0.9.10-lp152.9.8.1
  • LibVNCServer-debugsource >= 0.9.10-lp152.9.8.1
  • LibVNCServer-devel >= 0.9.10-lp152.9.8.1
  • libvncclient0 >= 0.9.10-lp152.9.8.1
  • libvncclient0-debuginfo >= 0.9.10-lp152.9.8.1
  • libvncserver0 >= 0.9.10-lp152.9.8.1
  • libvncserver0-debuginfo >= 0.9.10-lp152.9.8.1
Patchnames:
openSUSE-2020-1025
openSUSE-2020-1056
openSUSE-2020-978


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Performance Computing 12 SP4 LibVNCServer Affected
SUSE Linux Enterprise High Performance Computing 12 SP5 LibVNCServer Released
SUSE Linux Enterprise Server 11 SP4 LTSS LibVNCServer Not affected
SUSE Linux Enterprise Server 12 SP2 BCL LibVNCServer Released
SUSE Linux Enterprise Server 12 SP2 LTSS LibVNCServer Released
SUSE Linux Enterprise Server 12 SP3 BCL LibVNCServer Released
SUSE Linux Enterprise Server 12 SP3 LTSS LibVNCServer Released
SUSE Linux Enterprise Server 12 SP4 LibVNCServer Affected
SUSE Linux Enterprise Server 12 SP4 LTSS LibVNCServer Released
SUSE Linux Enterprise Server 12 SP5 LibVNCServer Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 LibVNCServer Released
SUSE Linux Enterprise Server for SAP Applications 12 SP3 LibVNCServer Released
SUSE Linux Enterprise Server for SAP Applications 12 SP4 LibVNCServer Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 LibVNCServer Released
SUSE Linux Enterprise Software Development Kit 12 SP4 LibVNCServer Affected
SUSE Linux Enterprise Software Development Kit 12 SP5 LibVNCServer Released
SUSE Linux Enterprise Workstation Extension 15 SP1 LibVNCServer Released
SUSE Linux Enterprise Workstation Extension 15 SP2 LibVNCServer Released