Upstream information

CVE-2017-18594 at MITRE

Description

nse_libssh2.cc in Nmap 7.70 is subject to a denial of service condition due to a double free when an SSH connection fails, as demonstrated by a leading \n character to ssh-brute.nse or ssh-auth-methods.nse.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 6.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Access Vector Network Network
Access Complexity Low Low
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact None None
Integrity Impact None None
Availability Impact High High
SUSE Bugzilla entry: 1148742 [IN_PROGRESS]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • nmap >= 7.70-3.12.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2019-2425
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • nmap >= 7.70-3.12.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-SP1-2019-2425
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15
  • ncat >= 7.70-3.12.1
  • ndiff >= 7.70-3.12.1
  • nmap >= 7.70-3.12.1
  • nping >= 7.70-3.12.1
  • zenmap >= 7.70-3.12.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-2019-2425
SUSE Linux Enterprise Module for Open Buildservice Development Tools 15 SP1
  • ncat >= 7.70-3.12.1
  • ndiff >= 7.70-3.12.1
  • nmap >= 7.70-3.12.1
  • nping >= 7.70-3.12.1
  • zenmap >= 7.70-3.12.1
Patchnames:
SUSE-SLE-Module-Development-Tools-OBS-15-SP1-2019-2425
SUSE Linux Enterprise Module for additional PackageHub packages 15
  • nmap >= 7.70-3.12.1
  • nping >= 7.70-3.12.1
Patchnames:
SUSE-SLE-Module-Packagehub-Subpackages-15-2019-2425
openSUSE Leap 15.0
  • ncat >= 7.70-lp150.2.9.1
  • ncat-debuginfo >= 7.70-lp150.2.9.1
  • ndiff >= 7.70-lp150.2.9.1
  • nmap >= 7.70-lp150.2.9.1
  • nmap-debuginfo >= 7.70-lp150.2.9.1
  • nmap-debugsource >= 7.70-lp150.2.9.1
  • nping >= 7.70-lp150.2.9.1
  • nping-debuginfo >= 7.70-lp150.2.9.1
  • zenmap >= 7.70-lp150.2.9.1
Patchnames:
openSUSE-2019-2198
openSUSE Leap 15.1
  • ncat >= 7.70-lp151.3.9.1
  • ncat-debuginfo >= 7.70-lp151.3.9.1
  • ndiff >= 7.70-lp151.3.9.1
  • nmap >= 7.70-lp151.3.9.1
  • nmap-debuginfo >= 7.70-lp151.3.9.1
  • nmap-debugsource >= 7.70-lp151.3.9.1
  • nping >= 7.70-lp151.3.9.1
  • nping-debuginfo >= 7.70-lp151.3.9.1
  • zenmap >= 7.70-lp151.3.9.1
Patchnames:
openSUSE-2019-2200


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Performance Computing 12 nmap Not affected
SUSE Linux Enterprise Module for Basesystem 15 GA nmap Released
SUSE Linux Enterprise Module for Basesystem 15 SP1 nmap Released
SUSE Linux Enterprise Server 11 SP4 LTSS nmap Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS nmap Not affected
SUSE Linux Enterprise Server 12 SP2 LTSS nmap Not affected
SUSE Linux Enterprise Server 12 SP3 LTSS nmap Not affected
SUSE Linux Enterprise Server 12 SP4 nmap Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP2 nmap Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP3 nmap Not affected
SUSE Linux Enterprise Server for SAP Applications 12 SP4 nmap Not affected