Upstream information

CVE-2017-18269 at MITRE

Description

An SSE2-optimized memmove implementation for i386 in sysdeps/i386/i686/multiarch/memcpy-sse2-unaligned.S in the GNU C Library (aka glibc or libc6) 2.21 through 2.27 does not correctly perform the overlapping memory check if the source memory range spans the middle of the address space, resulting in corrupt data being produced by the copy operation. This may disclose information to context-dependent attackers, or result in a denial of service, or, possibly, code execution.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 5.3
Vector AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
SUSE Bugzilla entry: 1094150 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Openstack Cloud Magnum Orchestration 7
  • glibc >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
Patchnames:
SUSE-OpenStack-Cloud-Magnum-Orchestration-7-2018-1077
SUSE CaaS Platform ALL
  • glibc >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
Patchnames:
SUSE-CAASP-ALL-2018-1077
SUSE Enterprise Storage 4
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-Storage-4-2018-1077
SUSE Linux Enterprise Desktop 12 SP3
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1077
SUSE Linux Enterprise Module for Basesystem 15
  • glibc >= 2.26-13.3.1
  • glibc-32bit >= 2.26-13.3.1
  • glibc-devel >= 2.26-13.3.1
  • glibc-extra >= 2.26-13.3.1
  • glibc-i18ndata >= 2.26-13.3.1
  • glibc-info >= 2.26-13.3.1
  • glibc-locale >= 2.26-13.3.1
  • glibc-locale-32bit >= 2.26-13.3.1
  • glibc-profile >= 2.26-13.3.1
  • nscd >= 2.26-13.3.1
Patchnames:
SUSE-SLE-Module-Basesystem-15-2018-1346
SUSE Linux Enterprise Module for Development Tools 15
  • glibc >= 2.26-13.3.1
  • glibc-devel-32bit >= 2.26-13.3.1
  • glibc-devel-static >= 2.26-13.3.1
  • glibc-utils >= 2.26-13.3.1
  • glibc-utils-src >= 2.26-13.3.1
Patchnames:
SUSE-SLE-Module-Development-Tools-15-2018-1346
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-1077
SUSE Linux Enterprise Server 12 SP2-BCL
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-1077
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-1077
SUSE Linux Enterprise Server 12 SP2-LTSS
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1077
SUSE Linux Enterprise Server 12 SP3
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1077
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-1077
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-1077
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-1077
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1077
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1077
SUSE Linux Enterprise Software Development Kit 12 SP3
  • glibc >= 2.22-62.13.2
  • glibc-devel-static >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1077
SUSE OpenStack Cloud 7
  • glibc >= 2.22-62.13.2
  • glibc-32bit >= 2.22-62.13.2
  • glibc-devel >= 2.22-62.13.2
  • glibc-devel-32bit >= 2.22-62.13.2
  • glibc-html >= 2.22-62.13.2
  • glibc-i18ndata >= 2.22-62.13.2
  • glibc-info >= 2.22-62.13.2
  • glibc-locale >= 2.22-62.13.2
  • glibc-locale-32bit >= 2.22-62.13.2
  • glibc-profile >= 2.22-62.13.2
  • glibc-profile-32bit >= 2.22-62.13.2
  • nscd >= 2.22-62.13.2
Patchnames:
SUSE-OpenStack-Cloud-7-2018-1077
openSUSE Leap 15.0
  • glibc >= 2.26-lp150.11.6.120
  • glibc-32bit >= 2.26-lp150.11.6.120
  • glibc-32bit-debuginfo >= 2.26-lp150.11.6.120
  • glibc-debuginfo >= 2.26-lp150.11.6.120
  • glibc-debugsource >= 2.26-lp150.11.6.120
  • glibc-devel >= 2.26-lp150.11.6.120
  • glibc-devel-32bit >= 2.26-lp150.11.6.120
  • glibc-devel-32bit-debuginfo >= 2.26-lp150.11.6.120
  • glibc-devel-debuginfo >= 2.26-lp150.11.6.120
  • glibc-devel-static >= 2.26-lp150.11.6.120
  • glibc-devel-static-32bit >= 2.26-lp150.11.6.120
  • glibc-extra >= 2.26-lp150.11.6.120
  • glibc-extra-debuginfo >= 2.26-lp150.11.6.120
  • glibc-html >= 2.26-lp150.11.6.120
  • glibc-i18ndata >= 2.26-lp150.11.6.120
  • glibc-info >= 2.26-lp150.11.6.120
  • glibc-locale >= 2.26-lp150.11.6.120
  • glibc-locale-32bit >= 2.26-lp150.11.6.120
  • glibc-locale-32bit-debuginfo >= 2.26-lp150.11.6.120
  • glibc-locale-debuginfo >= 2.26-lp150.11.6.120
  • glibc-profile >= 2.26-lp150.11.6.120
  • glibc-profile-32bit >= 2.26-lp150.11.6.120
  • glibc-testsuite-src >= 2.26-lp150.11.6.120
  • glibc-utils >= 2.26-lp150.11.6.120
  • glibc-utils-32bit >= 2.26-lp150.11.6.120
  • glibc-utils-32bit-debuginfo >= 2.26-lp150.11.6.120
  • glibc-utils-debuginfo >= 2.26-lp150.11.6.120
  • glibc-utils-src >= 2.26-lp150.11.6.120
  • glibc-utils-src-debugsource >= 2.26-lp150.11.6.120
  • nscd >= 2.26-lp150.11.6.120
  • nscd-debuginfo >= 2.26-lp150.11.6.120
Patchnames:
openSUSE-2018-788
openSUSE Leap 42.3
  • glibc >= 2.22-19.1
  • glibc-32bit >= 2.22-19.2
  • glibc-debuginfo >= 2.22-19.1
  • glibc-debuginfo-32bit >= 2.22-19.2
  • glibc-debugsource >= 2.22-19.1
  • glibc-devel >= 2.22-19.1
  • glibc-devel-32bit >= 2.22-19.2
  • glibc-devel-debuginfo >= 2.22-19.1
  • glibc-devel-debuginfo-32bit >= 2.22-19.2
  • glibc-devel-static >= 2.22-19.1
  • glibc-devel-static-32bit >= 2.22-19.2
  • glibc-extra >= 2.22-19.1
  • glibc-extra-debuginfo >= 2.22-19.1
  • glibc-html >= 2.22-19.1
  • glibc-i18ndata >= 2.22-19.1
  • glibc-info >= 2.22-19.1
  • glibc-locale >= 2.22-19.1
  • glibc-locale-32bit >= 2.22-19.2
  • glibc-locale-debuginfo >= 2.22-19.1
  • glibc-locale-debuginfo-32bit >= 2.22-19.2
  • glibc-obsolete >= 2.22-19.1
  • glibc-obsolete-debuginfo >= 2.22-19.1
  • glibc-profile >= 2.22-19.1
  • glibc-profile-32bit >= 2.22-19.2
  • glibc-testsuite >= 2.22-19.2
  • glibc-utils >= 2.22-19.1
  • glibc-utils-32bit >= 2.22-19.1
  • glibc-utils-debuginfo >= 2.22-19.1
  • glibc-utils-debuginfo-32bit >= 2.22-19.1
  • glibc-utils-debugsource >= 2.22-19.1
  • nscd >= 2.22-19.1
  • nscd-debuginfo >= 2.22-19.1
Patchnames:
openSUSE-2018-567


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 glibc Released
CaaS Platform 2.0 glibc Released
CaaS Platform 3.0 glibc Released
OpenStack Cloud Magnum Orchestration 7.0 glibc Released
SUSE Linux Enterprise Desktop 12 SP2 glibc Unsupported
SUSE Linux Enterprise Desktop 12 SP3 glibc Released
SUSE Linux Enterprise Module for Basesystem 15 GA glibc Released
SUSE Linux Enterprise Module for Development Tools 15 GA glibc Released
SUSE Linux Enterprise SDK 11 SP4 glibc Not affected
SUSE Linux Enterprise SDK 12 SP2 glibc Unsupported
SUSE Linux Enterprise SDK 12 SP3 glibc Released
SUSE Linux Enterprise Server 11 SP3 LTSS glibc Not affected
SUSE Linux Enterprise Server 11 SP4 glibc Not affected
SUSE Linux Enterprise Server 12 SP2 glibc Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS glibc Released
SUSE Linux Enterprise Server 12 SP3 glibc Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 glibc Released