Upstream information

CVE-2017-18266 at MITRE

Description

The open_envvar function in xdg-open in xdg-utils before 1.1.3 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL, as demonstrated by %s in this environment variable.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 5.3
Vector AV:L/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction Required
Scope Unchanged
Confidentiality Impact Low
Integrity Impact Low
Availability Impact Low
SUSE Bugzilla entry: 1093086 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP3
  • xdg-utils >= 20140630-6.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1022
SUSE Linux Enterprise Module for Basesystem 15
  • xdg-utils >= 20170508-3.2
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA xdg-utils
SUSE Linux Enterprise Server 12 SP3
  • xdg-utils >= 20140630-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1022
SUSE Linux Enterprise Server 12 SP4
  • xdg-utils >= 20140630-6.3.1
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA xdg-utils
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • xdg-utils >= 20140630-6.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1022
openSUSE Leap 15.0
  • xdg-utils >= 20170508-lp150.3.3.2
Patchnames:
openSUSE-2018-573


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 xdg-utils Unsupported
SUSE Linux Enterprise Desktop 12 SP3 xdg-utils Released
SUSE Linux Enterprise Server 11 SP3 LTSS xdg-utils Not affected
SUSE Linux Enterprise Server 11 SP4 xdg-utils Not affected
SUSE Linux Enterprise Server 12 GA LTSS xdg-utils Affected
SUSE Linux Enterprise Server 12 SP1 LTSS xdg-utils Affected
SUSE Linux Enterprise Server 12 SP2 xdg-utils Unsupported
SUSE Linux Enterprise Server 12 SP2 LTSS xdg-utils Affected
SUSE Linux Enterprise Server 12 SP3 xdg-utils Released