Upstream information

CVE-2017-17935 at MITRE

Description

The File_read_line function in epan/wslua/wslua_file.c in Wireshark through 2.2.11 does not properly strip '\n' characters, which allows remote attackers to cause a denial of service (buffer underflow and application crash) via a crafted packet that triggers the attempted processing of an empty line.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 1074171 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libwireshark8 >= 2.2.12-48.18.1
  • libwiretap6 >= 2.2.12-48.18.1
  • libwscodecs1 >= 2.2.12-48.18.1
  • libwsutil7 >= 2.2.12-48.18.1
  • wireshark >= 2.2.12-48.18.1
  • wireshark-gtk >= 2.2.12-48.18.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-134
SUSE Linux Enterprise Desktop 12 SP3
  • libwireshark8 >= 2.2.12-48.18.1
  • libwiretap6 >= 2.2.12-48.18.1
  • libwscodecs1 >= 2.2.12-48.18.1
  • libwsutil7 >= 2.2.12-48.18.1
  • wireshark >= 2.2.12-48.18.1
  • wireshark-gtk >= 2.2.12-48.18.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-134
SUSE Linux Enterprise Server 11 SP4
  • libwireshark8 >= 2.2.12-40.17.1
  • libwiretap6 >= 2.2.12-40.17.1
  • libwscodecs1 >= 2.2.12-40.17.1
  • libwsutil7 >= 2.2.12-40.17.1
  • wireshark >= 2.2.12-40.17.1
  • wireshark-gtk >= 2.2.12-40.17.1
Patchnames:
slessp4-wireshark-13431
SUSE Linux Enterprise Server 12 SP2
  • libwireshark8 >= 2.2.12-48.18.1
  • libwiretap6 >= 2.2.12-48.18.1
  • libwscodecs1 >= 2.2.12-48.18.1
  • libwsutil7 >= 2.2.12-48.18.1
  • wireshark >= 2.2.12-48.18.1
  • wireshark-gtk >= 2.2.12-48.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-134
SUSE Linux Enterprise Server 12 SP3
  • libwireshark8 >= 2.2.12-48.18.1
  • libwiretap6 >= 2.2.12-48.18.1
  • libwscodecs1 >= 2.2.12-48.18.1
  • libwsutil7 >= 2.2.12-48.18.1
  • wireshark >= 2.2.12-48.18.1
  • wireshark-gtk >= 2.2.12-48.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-134
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libwireshark8 >= 2.2.12-48.18.1
  • libwiretap6 >= 2.2.12-48.18.1
  • libwscodecs1 >= 2.2.12-48.18.1
  • libwsutil7 >= 2.2.12-48.18.1
  • wireshark >= 2.2.12-48.18.1
  • wireshark-gtk >= 2.2.12-48.18.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-134
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libwireshark8 >= 2.2.12-40.17.1
  • libwiretap6 >= 2.2.12-40.17.1
  • libwscodecs1 >= 2.2.12-40.17.1
  • libwsutil7 >= 2.2.12-40.17.1
  • wireshark >= 2.2.12-40.17.1
  • wireshark-gtk >= 2.2.12-40.17.1
Patchnames:
slessp4-wireshark-13431
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libwireshark8 >= 2.2.12-48.18.1
  • libwiretap6 >= 2.2.12-48.18.1
  • libwscodecs1 >= 2.2.12-48.18.1
  • libwsutil7 >= 2.2.12-48.18.1
  • wireshark >= 2.2.12-48.18.1
  • wireshark-gtk >= 2.2.12-48.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-134
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libwireshark8 >= 2.2.12-48.18.1
  • libwiretap6 >= 2.2.12-48.18.1
  • libwscodecs1 >= 2.2.12-48.18.1
  • libwsutil7 >= 2.2.12-48.18.1
  • wireshark >= 2.2.12-48.18.1
  • wireshark-gtk >= 2.2.12-48.18.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-134
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libwireshark8 >= 2.2.12-40.17.1
  • libwiretap6 >= 2.2.12-40.17.1
  • libwscodecs1 >= 2.2.12-40.17.1
  • libwsutil7 >= 2.2.12-40.17.1
  • wireshark >= 2.2.12-40.17.1
  • wireshark-devel >= 2.2.12-40.17.1
  • wireshark-gtk >= 2.2.12-40.17.1
Patchnames:
sdksp4-wireshark-13431
SUSE Linux Enterprise Software Development Kit 12 SP2
  • wireshark >= 2.2.12-48.18.1
  • wireshark-devel >= 2.2.12-48.18.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2018-134
SUSE Linux Enterprise Software Development Kit 12 SP3
  • wireshark >= 2.2.12-48.18.1
  • wireshark-devel >= 2.2.12-48.18.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-134


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 wireshark Released
SUSE Linux Enterprise Desktop 12 SP3 wireshark Released
SUSE Linux Enterprise SDK 11 SP4 wireshark Released
SUSE Linux Enterprise SDK 12 SP2 wireshark Released
SUSE Linux Enterprise SDK 12 SP3 wireshark Released
SUSE Linux Enterprise Server 11 SP3 LTSS wireshark Affected
SUSE Linux Enterprise Server 11 SP4 wireshark Released
SUSE Linux Enterprise Server 12 GA LTSS wireshark Affected
SUSE Linux Enterprise Server 12 SP1 LTSS wireshark Affected
SUSE Linux Enterprise Server 12 SP2 wireshark Released
SUSE Linux Enterprise Server 12 SP3 wireshark Released