Upstream information

CVE-2017-17531 at MITRE

Description

gozilla.c in GNU GLOBAL 4.8.6 does not validate strings before launching the program specified by the BROWSER environment variable, which might allow remote attackers to conduct argument-injection attacks via a crafted URL.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 1073197 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.2
  • global >= 6.5.1-3.3.1
  • global-debuginfo >= 6.5.1-3.3.1
  • global-debugsource >= 6.5.1-3.3.1
Patchnames:
openSUSE-2017-1420
openSUSE Leap 42.3
  • global >= 6.5.1-6.1
  • global-debuginfo >= 6.5.1-6.1
  • global-debugsource >= 6.5.1-6.1
Patchnames:
openSUSE-2017-1420