Upstream information

CVE-2017-17087 at MITRE

Description

fileio.c in Vim prior to 8.0.1263 sets the group ownership of a .swp file to the editor's primary group (which may be different from the group ownership of the original file), which allows local users to obtain sensitive information by leveraging an applicable group membership, as demonstrated by /etc/shadow owned by root:shadow mode 0640, but /etc/.shadow.swp owned by root:users mode 0640, a different vulnerability than CVE-2017-1000382.

SUSE information

Overall state of this security issue: Pending

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 2.1 1.9
Vector AV:L/AC:L/Au:N/C:P/I:N/A:N AV:L/AC:M/Au:N/C:P/I:N/A:N
Access Vector Local Local
Access Complexity Low Medium
Authentication None None
Confidentiality Impact Partial Partial
Integrity Impact None None
Availability Impact None None
CVSS v3 Scores
  SUSE
Base Score 4
Vector AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Access Vector Local
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact Low
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 1065958 [NEW], 1070955 [NEW]

No SUSE Security Announcements cross referenced.


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 vim Affected
OpenStack Cloud Magnum Orchestration 7.0 vim Affected
SUSE Linux Enterprise Desktop 12 SP2 vim Affected
SUSE Linux Enterprise Desktop 12 SP3 vim Affected
SUSE Linux Enterprise Server 11 SP3 LTSS vim Affected
SUSE Linux Enterprise Server 11 SP4 vim Affected
SUSE Linux Enterprise Server 12 GA LTSS vim Affected
SUSE Linux Enterprise Server 12 SP1 LTSS vim Affected
SUSE Linux Enterprise Server 12 SP2 vim Affected
SUSE Linux Enterprise Server 12 SP3 vim Affected