Upstream information

CVE-2017-16818 at MITRE

Description

RADOS Gateway in Ceph 12.1.0 through 12.2.1 allows remote authenticated users to cause a denial of service (assertion failure and application exit) by leveraging "full" (not necessarily admin) privileges to post an invalid profile to the admin API, related to rgw/rgw_iam_policy.cc, rgw/rgw_basic_types.h, and rgw/rgw_iam_types.h.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 4 6.8
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P AV:N/AC:L/Au:S/C:N/I:N/A:C
Access Vector Network Network
Access Complexity Low Low
Authentication Single Single
Confidentiality Impact None None
Integrity Impact None None
Availability Impact Partial Complete
CVSS v3 Scores
  SUSE
Base Score 7.5
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact High
SUSE Bugzilla entries: 1063014 [RESOLVED / FIXED], 1069253 [RESOLVED / DUPLICATE]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE CaaS Platform ALL
  • ceph >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • ceph-common >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libcephfs2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librados2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libradosstriper1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librbd1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librgw2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-cephfs >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rados >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rbd >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rgw >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
Patchnames:
SUSE-CAASP-ALL-2018-980
SUSE Enterprise Storage 5
  • ceph >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • ceph-base >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • ceph-common >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • ceph-fuse >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • ceph-mds >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • ceph-mgr >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • ceph-mon >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • ceph-osd >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • ceph-radosgw >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • libcephfs2 >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • librados2 >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • libradosstriper1 >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • librbd1 >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • librgw2 >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • python-ceph-compat >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • python-cephfs >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • python-rados >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • python-rbd >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • python-rgw >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • python3-ceph-argparse >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • python3-cephfs >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • python3-rados >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • python3-rbd >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • python3-rgw >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • rbd-fuse >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • rbd-mirror >= 12.2.2+git.1513357992.5030136da9-2.10.1
  • rbd-nbd >= 12.2.2+git.1513357992.5030136da9-2.10.1
Patchnames:
SUSE-Storage-5-2018-65
SUSE Linux Enterprise Desktop 12 SP3
  • ceph >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • ceph-common >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libcephfs2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librados2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libradosstriper1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librbd1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librgw2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-cephfs >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rados >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rbd >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rgw >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-980
SUSE Linux Enterprise Module for Basesystem 15
  • ceph-common >= 13.0.2.1874+ge31585919b-1.19
  • libcephfs-devel >= 13.0.2.1874+ge31585919b-1.19
  • libcephfs2 >= 13.0.2.1874+ge31585919b-1.19
  • librados-devel >= 13.0.2.1874+ge31585919b-1.19
  • librados2 >= 13.0.2.1874+ge31585919b-1.19
  • libradosstriper-devel >= 13.0.2.1874+ge31585919b-1.19
  • libradosstriper1 >= 13.0.2.1874+ge31585919b-1.19
  • librbd-devel >= 13.0.2.1874+ge31585919b-1.19
  • librbd1 >= 13.0.2.1874+ge31585919b-1.19
  • librgw-devel >= 13.0.2.1874+ge31585919b-1.19
  • librgw2 >= 13.0.2.1874+ge31585919b-1.19
  • python3-cephfs >= 13.0.2.1874+ge31585919b-1.19
  • python3-rados >= 13.0.2.1874+ge31585919b-1.19
  • python3-rbd >= 13.0.2.1874+ge31585919b-1.19
  • python3-rgw >= 13.0.2.1874+ge31585919b-1.19
  • rados-objclass-devel >= 13.0.2.1874+ge31585919b-1.19
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA ceph-common
SUSE Linux Enterprise Server 12 SP3
  • ceph >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • ceph-common >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libcephfs2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librados2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libradosstriper1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librbd1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librgw2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-cephfs >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rados >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rbd >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rgw >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-980
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • ceph >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • ceph-common >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libcephfs2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librados2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libradosstriper1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librbd1 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librgw2 >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-cephfs >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rados >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rbd >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • python-rgw >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-980
SUSE Linux Enterprise Software Development Kit 12 SP3
  • ceph >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • libcephfs-devel >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librados-devel >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
  • librbd-devel >= 12.2.5+git.1524775272.5e7ea8cf03-2.7.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-980
openSUSE Leap 15.0
  • librados2 >= 13.0.2.1874+ge31585919b-lp150.1.2
  • librbd1 >= 13.0.2.1874+ge31585919b-lp150.1.2
Patchnames:
openSUSE Leap 15.0 GA librados2
openSUSE Leap 42.3
  • ceph >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-base >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-base-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-common >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-common-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-debugsource >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-fuse >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-fuse-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-mds >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-mds-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-mgr >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-mgr-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-mon >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-mon-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-osd >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-osd-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-radosgw >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-radosgw-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-resource-agents >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-test >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-test-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • ceph-test-debugsource >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • libcephfs-devel >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • libcephfs2 >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • libcephfs2-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • librados-devel >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • librados-devel-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • librados2 >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • librados2-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • libradosstriper-devel >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • libradosstriper1 >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • libradosstriper1-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • librbd-devel >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • librbd1 >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • librbd1-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • librgw-devel >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • librgw2 >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • librgw2-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python-ceph-compat >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python-cephfs >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python-cephfs-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python-rados >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python-rados-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python-rbd >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python-rbd-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python-rgw >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python-rgw-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python3-ceph-argparse >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python3-cephfs >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python3-cephfs-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python3-rados >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python3-rados-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python3-rbd >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python3-rbd-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python3-rgw >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • python3-rgw-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • rados-objclass-devel >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • rbd-fuse >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • rbd-fuse-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • rbd-mirror >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • rbd-mirror-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • rbd-nbd >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
  • rbd-nbd-debuginfo >= 12.2.5+git.1524775272.5e7ea8cf03-9.1
Patchnames:
openSUSE-2018-541


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 1.0 ceph Released
CaaS Platform 2.0 ceph Released
SUSE Linux Enterprise Desktop 12 SP2 ceph Not affected
SUSE Linux Enterprise Desktop 12 SP3 ceph Released
SUSE Linux Enterprise SDK 11 SP4 ceph Not affected
SUSE Linux Enterprise SDK 12 SP2 ceph Not affected
SUSE Linux Enterprise SDK 12 SP3 ceph Released
SUSE Linux Enterprise Server 11 SP3 LTSS ceph Not affected
SUSE Linux Enterprise Server 11 SP4 ceph Not affected
SUSE Linux Enterprise Server 12 GA LTSS ceph Not affected
SUSE Linux Enterprise Server 12 SP1 LTSS ceph Not affected
SUSE Linux Enterprise Server 12 SP2 ceph Not affected
SUSE Linux Enterprise Server 12 SP3 ceph Released
SUSE Storage 3 ceph Not affected
SUSE Storage 4 ceph Not affected
SUSE Storage 5 ceph Released