Upstream information

CVE-2017-16612 at MITRE

Description

libXcursor before 1.1.15 has various integer overflows that could lead to heap buffer overflows when processing malicious cursors, e.g., with programs like GIMP. It is also possible that an attack vector exists against the related code in cursor/xcursor.c in Wayland through 1.14.0.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database SUSE
Base Score 5 4.6
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network Local
Access Complexity Low Low
Authentication None None
Confidentiality Impact None Partial
Integrity Impact None Partial
Availability Impact Partial Partial
CVSS v3 Scores
  National Vulnerability Database SUSE
Base Score 7.5 7.8
Vector CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Access Vector Network Local
Access Complexity Low Low
Privileges Required None None
User Interaction None Required
Scope Unchanged Unchanged
Confidentiality Impact None High
Integrity Impact None High
Availability Impact High High
CVSSv3 Version 3 3
SUSE Bugzilla entries: 1065386 [RESOLVED / FIXED], 1159415 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • libXcursor >= 1.1.14-4.3.1
  • libXcursor1 >= 1.1.14-4.3.1
  • libXcursor1-32bit >= 1.1.14-4.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2017-2000
SUSE Linux Enterprise Desktop 12 SP3
  • libXcursor >= 1.1.14-4.3.1
  • libXcursor1 >= 1.1.14-4.3.1
  • libXcursor1-32bit >= 1.1.14-4.3.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2017-2000
SUSE Linux Enterprise Desktop 12 SP4
SUSE Linux Enterprise High Performance Computing 12 SP5
SUSE Linux Enterprise Server 12 SP4
SUSE Linux Enterprise Server 12 SP5
  • libXcursor1 >= 1.1.14-4.6.1
  • libXcursor1-32bit >= 1.1.14-4.6.1
SUSE Linux Enterprise Module for Basesystem 15
SUSE Linux Enterprise Module for Basesystem 15 SP1
  • libXcursor-devel >= 1.1.15-1.18
  • libXcursor1 >= 1.1.15-1.18
SUSE Linux Enterprise Module for Desktop Applications 15
SUSE Linux Enterprise Module for Desktop Applications 15 SP1
  • libXcursor1-32bit >= 1.1.15-1.18
SUSE Linux Enterprise Server 11 SP4
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • xorg-x11-libs >= 7.4-8.26.50.5.3
  • xorg-x11-libs-32bit >= 7.4-8.26.50.5.3
  • xorg-x11-libs-x86 >= 7.4-8.26.50.5.3
Patchnames:
slessp4-xorg-x11-libs-13444
SUSE Linux Enterprise Server 12 SP2
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • libXcursor >= 1.1.14-4.3.1
  • libXcursor1 >= 1.1.14-4.3.1
  • libXcursor1-32bit >= 1.1.14-4.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2017-2000
SUSE Linux Enterprise Server 12 SP3
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libXcursor >= 1.1.14-4.3.1
  • libXcursor1 >= 1.1.14-4.3.1
  • libXcursor1-32bit >= 1.1.14-4.3.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2017-2000
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libXcursor >= 1.1.14-4.3.1
  • libXcursor1 >= 1.1.14-4.3.1
Patchnames:
SUSE-SLE-RPI-12-SP2-2017-2000
SUSE Linux Enterprise Software Development Kit 11 SP4
  • xorg-x11-devel >= 7.4-8.26.50.5.3
  • xorg-x11-devel-32bit >= 7.4-8.26.50.5.3
  • xorg-x11-libs >= 7.4-8.26.50.5.3
Patchnames:
sdksp4-xorg-x11-libs-13444
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libXcursor >= 1.1.14-4.3.1
  • libXcursor-devel >= 1.1.14-4.3.1
Patchnames:
SUSE-SLE-SDK-12-SP2-2017-2000
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libXcursor >= 1.1.14-4.3.1
  • libXcursor-devel >= 1.1.14-4.3.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2017-2000
SUSE Linux Enterprise Software Development Kit 12 SP4
SUSE Linux Enterprise Software Development Kit 12 SP5
  • libXcursor-devel >= 1.1.14-4.6.1
openSUSE Leap 15.0
  • libXcursor1 >= 1.1.15-lp150.1.3
Patchnames:
openSUSE Leap 15.0 GA libXcursor1
openSUSE Leap 42.3
  • libXcursor >= 1.1.14-10.3.1
  • libXcursor-debugsource >= 1.1.14-10.3.1
  • libXcursor-devel >= 1.1.14-10.3.1
  • libXcursor-devel-32bit >= 1.1.14-10.3.1
  • libXcursor1 >= 1.1.14-10.3.1
  • libXcursor1-32bit >= 1.1.14-10.3.1
  • libXcursor1-debuginfo >= 1.1.14-10.3.1
  • libXcursor1-debuginfo-32bit >= 1.1.14-10.3.1
Patchnames:
openSUSE-2018-196


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 libXcursor Released
SUSE Linux Enterprise Desktop 12 SP3 libXcursor Released
SUSE Linux Enterprise High Performance Computing 12 SP5 libXcursor Released
SUSE Linux Enterprise Server 11 SP1 xorg-x11-libs Released
SUSE Linux Enterprise Server 11 SP3 xorg-x11-libs Released
SUSE Linux Enterprise Server 12 LTSS libXcursor Analysis
SUSE Linux Enterprise Server 12 SP1 LTSS libXcursor Analysis
SUSE Linux Enterprise Server 12 SP2 libXcursor Released
SUSE Linux Enterprise Server 12 SP3 libXcursor Released
SUSE Linux Enterprise Server 12 SP5 libXcursor Released
SUSE Linux Enterprise Server for SAP Applications 12 SP5 libXcursor Released
SUSE Linux Enterprise Software Development Kit 12 libXcursor Released
SUSE Linux Enterprise Software Development Kit 12 SP3 libXcursor Released