Upstream information

CVE-2017-15923 at MITRE

Description

Konversation 1.4.x, 1.5.x, 1.6.x, and 1.7.x before 1.7.3 allow remote attackers to cause a denial of service (crash) via vectors related to parsing of IRC color formatting codes.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 5.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
SUSE Bugzilla entry: 1068097 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 15.0
  • konversation >= 1.7.4-lp150.2.1
  • konversation-lang >= 1.7.4-lp150.2.1
Patchnames:
openSUSE Leap 15.0 GA konversation
openSUSE Leap 42.2
  • konversation >= 1.6.2-2.3.1
  • konversation-debuginfo >= 1.6.2-2.3.1
  • konversation-debugsource >= 1.6.2-2.3.1
  • konversation-lang >= 1.6.2-2.3.1
Patchnames:
openSUSE-2017-1305
openSUSE Leap 42.3
  • konversation >= 1.7.4-3.1
  • konversation-debuginfo >= 1.7.4-3.1
  • konversation-debugsource >= 1.7.4-3.1
  • konversation-lang >= 1.7.4-3.1
Patchnames:
openSUSE-2017-1306