Upstream information

CVE-2017-15566 at MITRE

Description

Insecure SPANK environment variable handling exists in SchedMD Slurm before 16.05.11, 17.x before 17.02.9, and 17.11.x before 17.11.0rc2, allowing privilege escalation to root during Prolog or Epilog execution.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 1065697 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for High Performance Computing 12
  • libpmi0 >= 17.02.9-6.10.1
  • libslurm29 >= 16.05.8.1-6.1
  • libslurm31 >= 17.02.9-6.10.1
  • pdsh >= 2.33-7.5.17
  • perl-slurm >= 17.02.9-6.10.1
  • slurm >= 17.02.9-6.10.1
  • slurm-auth-none >= 17.02.9-6.10.1
  • slurm-devel >= 17.02.9-6.10.1
  • slurm-doc >= 17.02.9-6.10.1
  • slurm-lua >= 17.02.9-6.10.1
  • slurm-munge >= 17.02.9-6.10.1
  • slurm-pam_slurm >= 17.02.9-6.10.1
  • slurm-plugins >= 17.02.9-6.10.1
  • slurm-sched-wiki >= 17.02.9-6.10.1
  • slurm-slurmdb-direct >= 17.02.9-6.10.1
  • slurm-slurmdbd >= 17.02.9-6.10.1
  • slurm-sql >= 17.02.9-6.10.1
  • slurm-torque >= 17.02.9-6.10.1
  • slurmlibs >= 16.05.8.1-6.1
Patchnames:
SUSE-SLE-Module-HPC-12-2017-2072
SUSE Linux Enterprise Module for High Performance Computing 15
  • libpmi0 >= 17.11.5-4.28
  • libslurm32 >= 17.11.5-4.28
  • perl-slurm >= 17.11.5-4.28
  • slurm >= 17.11.5-4.28
  • slurm-auth-none >= 17.11.5-4.28
  • slurm-config >= 17.11.5-4.28
  • slurm-devel >= 17.11.5-4.28
  • slurm-doc >= 17.11.5-4.28
  • slurm-lua >= 17.11.5-4.28
  • slurm-munge >= 17.11.5-4.28
  • slurm-node >= 17.11.5-4.28
  • slurm-pam_slurm >= 17.11.5-4.28
  • slurm-plugins >= 17.11.5-4.28
  • slurm-slurmdbd >= 17.11.5-4.28
  • slurm-sql >= 17.11.5-4.28
  • slurm-torque >= 17.11.5-4.28
Patchnames:
SUSE Linux Enterprise Module for High Performance Computing 15 GA libpmi0


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Module for High Performance Computing 12 slurm Released