Upstream information

CVE-2017-15565 at MITRE

Description

In Poppler 0.59.0, a NULL Pointer Dereference exists in the GfxImageColorMap::getGrayLine() function in GfxState.cc via a crafted PDF document.

SUSE information

Overall state of this security issue: Running

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 1064593 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Build System Kit 12 SP3
  • libpoppler-cpp0 >= 0.43.0-16.15.1
  • poppler >= 0.43.0-16.15.1
Patchnames:
SUSE-SLE-BSK-12-SP3-2018-1125
SUSE Linux Enterprise Desktop 12 SP3
  • libpoppler-glib8 >= 0.43.0-16.15.1
  • libpoppler-qt4-4 >= 0.43.0-16.15.1
  • libpoppler60 >= 0.43.0-16.15.1
  • poppler >= 0.43.0-16.15.1
  • poppler-qt >= 0.43.0-16.15.1
  • poppler-tools >= 0.43.0-16.15.1
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-1125
SUSE Linux Enterprise Server 11 SP4
  • libpoppler-glib4 >= 0.12.3-1.13.3.2
  • libpoppler-qt4-3 >= 0.12.3-1.13.3.2
  • libpoppler5 >= 0.12.3-1.13.3.2
  • poppler >= 0.12.3-1.13.3.2
  • poppler-tools >= 0.12.3-1.13.3.2
Patchnames:
slessp4-poppler-13653
SUSE Linux Enterprise Server 12 SP3
  • libpoppler-glib8 >= 0.43.0-16.15.1
  • libpoppler-qt4-4 >= 0.43.0-16.15.1
  • libpoppler60 >= 0.43.0-16.15.1
  • poppler >= 0.43.0-16.15.1
  • poppler-qt >= 0.43.0-16.15.1
  • poppler-tools >= 0.43.0-16.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1125
SUSE Linux Enterprise Server for SAP Applications 11 SP4
  • libpoppler-glib4 >= 0.12.3-1.13.3.2
  • libpoppler-qt4-3 >= 0.12.3-1.13.3.2
  • libpoppler5 >= 0.12.3-1.13.3.2
  • poppler >= 0.12.3-1.13.3.2
  • poppler-tools >= 0.12.3-1.13.3.2
Patchnames:
slessp4-poppler-13653
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • libpoppler-glib8 >= 0.43.0-16.15.1
  • libpoppler-qt4-4 >= 0.43.0-16.15.1
  • libpoppler60 >= 0.43.0-16.15.1
  • poppler >= 0.43.0-16.15.1
  • poppler-qt >= 0.43.0-16.15.1
  • poppler-tools >= 0.43.0-16.15.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1125
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libpoppler-devel >= 0.12.3-1.13.3.2
  • libpoppler-glib-devel >= 0.12.3-1.13.3.2
  • libpoppler-qt2 >= 0.12.3-1.13.3.2
  • libpoppler-qt3-devel >= 0.12.3-1.13.3.2
  • libpoppler-qt4-devel >= 0.12.3-1.13.3.2
  • poppler >= 0.12.3-1.13.3.2
  • poppler-tools >= 0.12.3-1.13.3.2
Patchnames:
sdksp4-poppler-13653
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libpoppler-cpp0 >= 0.43.0-16.15.1
  • libpoppler-devel >= 0.43.0-16.15.1
  • libpoppler-glib-devel >= 0.43.0-16.15.1
  • libpoppler-qt4-devel >= 0.43.0-16.15.1
  • poppler >= 0.43.0-16.15.1
  • poppler-qt >= 0.43.0-16.15.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-16.15.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1125
openSUSE Leap 42.3
  • libpoppler-cpp0 >= 0.43.0-8.1
  • libpoppler-cpp0-32bit >= 0.43.0-8.1
  • libpoppler-cpp0-debuginfo >= 0.43.0-8.1
  • libpoppler-cpp0-debuginfo-32bit >= 0.43.0-8.1
  • libpoppler-devel >= 0.43.0-8.1
  • libpoppler-glib-devel >= 0.43.0-8.1
  • libpoppler-glib8 >= 0.43.0-8.1
  • libpoppler-glib8-32bit >= 0.43.0-8.1
  • libpoppler-glib8-debuginfo >= 0.43.0-8.1
  • libpoppler-glib8-debuginfo-32bit >= 0.43.0-8.1
  • libpoppler-qt4-4 >= 0.43.0-8.1
  • libpoppler-qt4-4-32bit >= 0.43.0-8.1
  • libpoppler-qt4-4-debuginfo >= 0.43.0-8.1
  • libpoppler-qt4-4-debuginfo-32bit >= 0.43.0-8.1
  • libpoppler-qt4-devel >= 0.43.0-8.1
  • libpoppler-qt5-1 >= 0.43.0-8.1
  • libpoppler-qt5-1-32bit >= 0.43.0-8.1
  • libpoppler-qt5-1-debuginfo >= 0.43.0-8.1
  • libpoppler-qt5-1-debuginfo-32bit >= 0.43.0-8.1
  • libpoppler-qt5-devel >= 0.43.0-8.1
  • libpoppler60 >= 0.43.0-8.1
  • libpoppler60-32bit >= 0.43.0-8.1
  • libpoppler60-debuginfo >= 0.43.0-8.1
  • libpoppler60-debuginfo-32bit >= 0.43.0-8.1
  • poppler >= 0.43.0-8.1
  • poppler-debugsource >= 0.43.0-8.1
  • poppler-qt >= 0.43.0-8.1
  • poppler-qt-debugsource >= 0.43.0-8.1
  • poppler-qt5 >= 0.43.0-8.1
  • poppler-qt5-debugsource >= 0.43.0-8.1
  • poppler-tools >= 0.43.0-8.1
  • poppler-tools-debuginfo >= 0.43.0-8.1
  • typelib-1_0-Poppler-0_18 >= 0.43.0-8.1
Patchnames:
openSUSE-2018-648

List of packages in QA

Product(s) Package(s)
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libpoppler44 >= 0.24.4-14.16.1
  • libpoppler44-debuginfo >= 0.24.4-14.16.1
  • poppler >= 0.24.4-14.16.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise BSK 12 SP2 poppler Unsupported
SUSE Linux Enterprise BSK 12 SP3 poppler Released
SUSE Linux Enterprise Desktop 12 SP2 poppler Unsupported
SUSE Linux Enterprise Desktop 12 SP3 poppler Released
SUSE Linux Enterprise SDK 11 SP4 poppler Released
SUSE Linux Enterprise SDK 12 SP2 poppler Unsupported
SUSE Linux Enterprise SDK 12 SP3 poppler In progress
SUSE Linux Enterprise Server 11 SP3 LTSS poppler Affected
SUSE Linux Enterprise Server 11 SP4 poppler Released
SUSE Linux Enterprise Server 12 GA LTSS poppler Affected
SUSE Linux Enterprise Server 12 SP1 LTSS poppler Affected
SUSE Linux Enterprise Server 12 SP2 poppler Unsupported
SUSE Linux Enterprise Server 12 SP3 poppler Released