Upstream information

CVE-2017-15130 at MITRE

Description

A denial of service flaw was found in dovecot before 2.2.34. An attacker able to generate random SNI server names could exploit TLS SNI configuration lookups, leading to excessive memory usage and the process to restart.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 5.3
Vector AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
Access Vector Network
Access Complexity Low
Privileges Required None
User Interaction None
Scope Unchanged
Confidentiality Impact None
Integrity Impact None
Availability Impact Low
SUSE Bugzilla entry: 1082828 [NEW]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Enterprise Storage 4
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-Storage-4-2018-1844
SUSE Linux Enterprise Module for Server Applications 15
  • dovecot23 >= 2.3.1-2.20
  • dovecot23-backend-mysql >= 2.3.1-2.20
  • dovecot23-backend-pgsql >= 2.3.1-2.20
  • dovecot23-backend-sqlite >= 2.3.1-2.20
  • dovecot23-devel >= 2.3.1-2.20
  • dovecot23-fts >= 2.3.1-2.20
  • dovecot23-fts-lucene >= 2.3.1-2.20
  • dovecot23-fts-solr >= 2.3.1-2.20
  • dovecot23-fts-squat >= 2.3.1-2.20
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA dovecot23
SUSE Linux Enterprise Point of Sale 12 SP2-CLIENT
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-POS-12-SP2-CLIENT-2018-1844
SUSE Linux Enterprise Server 12 SP1-LTSS
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-1844
SUSE Linux Enterprise Server 12 SP2-BCL
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-1844
SUSE Linux Enterprise Server 12 SP2-ESPOS
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-1844
SUSE Linux Enterprise Server 12 SP2-LTSS
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1844
SUSE Linux Enterprise Server 12 SP3
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1844
SUSE Linux Enterprise Server 12-LTSS
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-2018-1844
SUSE Linux Enterprise Server for SAP Applications 12 SP1
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SAP-12-SP1-2018-1844
SUSE Linux Enterprise Server for SAP Applications 12 SP1-LTSS
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP1-2018-1844
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SAP-12-SP2-2018-1844
SUSE Linux Enterprise Server for SAP Applications 12 SP2-BCL
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-BCL-2018-1844
SUSE Linux Enterprise Server for SAP Applications 12 SP2-ESPOS
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-ESPOS-2018-1844
SUSE Linux Enterprise Server for SAP Applications 12 SP2-LTSS
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-1844
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-1844
SUSE Linux Enterprise Server for SAP Applications 12-LTSS
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SERVER-12-2018-1844
SUSE Linux Enterprise Software Development Kit 12 SP3
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-devel >= 2.2.31-19.11.1
Patchnames:
SUSE-SLE-SDK-12-SP3-2018-1844
SUSE OpenStack Cloud 7
  • dovecot22 >= 2.2.31-19.11.1
  • dovecot22-backend-mysql >= 2.2.31-19.11.1
  • dovecot22-backend-pgsql >= 2.2.31-19.11.1
  • dovecot22-backend-sqlite >= 2.2.31-19.11.1
Patchnames:
SUSE-OpenStack-Cloud-7-2018-1844
openSUSE Leap 42.3
  • dovecot22 >= 2.2.31-2.9.1
  • dovecot22-backend-mysql >= 2.2.31-2.9.1
  • dovecot22-backend-mysql-debuginfo >= 2.2.31-2.9.1
  • dovecot22-backend-pgsql >= 2.2.31-2.9.1
  • dovecot22-backend-pgsql-debuginfo >= 2.2.31-2.9.1
  • dovecot22-backend-sqlite >= 2.2.31-2.9.1
  • dovecot22-backend-sqlite-debuginfo >= 2.2.31-2.9.1
  • dovecot22-debuginfo >= 2.2.31-2.9.1
  • dovecot22-debugsource >= 2.2.31-2.9.1
  • dovecot22-devel >= 2.2.31-2.9.1
  • dovecot22-fts >= 2.2.31-2.9.1
  • dovecot22-fts-debuginfo >= 2.2.31-2.9.1
  • dovecot22-fts-lucene >= 2.2.31-2.9.1
  • dovecot22-fts-lucene-debuginfo >= 2.2.31-2.9.1
  • dovecot22-fts-solr >= 2.2.31-2.9.1
  • dovecot22-fts-solr-debuginfo >= 2.2.31-2.9.1
  • dovecot22-fts-squat >= 2.2.31-2.9.1
  • dovecot22-fts-squat-debuginfo >= 2.2.31-2.9.1
Patchnames:
openSUSE-2018-973


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 12 SP2 dovecot22 Affected
SUSE Linux Enterprise SDK 12 SP3 dovecot22 Released
SUSE Linux Enterprise Server 12 GA LTSS dovecot22 Released
SUSE Linux Enterprise Server 12 SP1 LTSS dovecot22 Released
SUSE Linux Enterprise Server 12 SP2 dovecot22 Affected
SUSE Linux Enterprise Server 12 SP2 LTSS dovecot22 Released
SUSE Linux Enterprise Server 12 SP3 dovecot22 Released
SUSE Linux Enterprise Server for SAP Applications 12 SP2 dovecot22 Released