Upstream information

CVE-2017-15118 at MITRE

Description

A stack-based buffer overflow vulnerability was found in NBD server implementation in qemu before 2.11 allowing a client to request an export name of size up to 4096 bytes, which in fact should be limited to 256 bytes, causing an out-of-bounds stack write in the qemu process. If NBD server requires TLS, the attacker cannot trigger the buffer overflow without first successfully negotiating TLS.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 1070147 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Module for Basesystem 15
  • qemu-tools >= 2.11.1-7.5
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA qemu-tools
SUSE Linux Enterprise Module for Server Applications 15
  • qemu >= 2.11.1-7.5
  • qemu-block-curl >= 2.11.1-7.5
  • qemu-block-iscsi >= 2.11.1-7.5
  • qemu-block-rbd >= 2.11.1-7.5
  • qemu-block-ssh >= 2.11.1-7.5
  • qemu-guest-agent >= 2.11.1-7.5
  • qemu-ipxe >= 1.0.0-7.5
  • qemu-kvm >= 2.11.1-7.5
  • qemu-lang >= 2.11.1-7.5
  • qemu-seabios >= 1.11.0-7.5
  • qemu-sgabios >= 8-7.5
  • qemu-vgabios >= 1.11.0-7.5
  • qemu-x86 >= 2.11.1-7.5
Patchnames:
SUSE Linux Enterprise Module for Server Applications 15 GA qemu
openSUSE Leap 15.0
  • qemu >= 2.11.1-lp150.6.7
  • qemu-block-curl >= 2.11.1-lp150.6.7
  • qemu-block-rbd >= 2.11.1-lp150.6.7
  • qemu-block-ssh >= 2.11.1-lp150.6.7
  • qemu-guest-agent >= 2.11.1-lp150.6.7
  • qemu-ipxe >= 1.0.0-lp150.6.7
  • qemu-ksm >= 2.11.1-lp150.6.7
  • qemu-seabios >= 1.11.0-lp150.6.7
  • qemu-sgabios >= 8-lp150.6.7
  • qemu-tools >= 2.11.1-lp150.6.7
  • qemu-vgabios >= 1.11.0-lp150.6.7
  • qemu-x86 >= 2.11.1-lp150.6.7
Patchnames:
openSUSE Leap 15.0 GA qemu


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
CaaS Platform 2.0 qemu Not affected
SUSE Linux Enterprise Desktop 12 SP2 qemu Not affected
SUSE Linux Enterprise Desktop 12 SP3 qemu Not affected
SUSE Linux Enterprise Server 11 SP3 LTSS kvm Not affected
SUSE Linux Enterprise Server 11 SP4 kvm Not affected
SUSE Linux Enterprise Server 12 SP2 qemu Not affected
SUSE Linux Enterprise Server 12 SP3 qemu Not affected