Upstream information

CVE-2017-15108 at MITRE

Description

spice-vdagent up to and including 0.17.0 does not properly escape save directory before passing to shell, allowing local attacker with access to the session the agent runs in to inject arbitrary commands to be executed.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
CVSS v3 Scores
  SUSE
Base Score 7.3
Vector AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H
Access Vector Local
Access Complexity Low
Privileges Required Low
User Interaction Required
Scope Unchanged
Confidentiality Impact High
Integrity Impact High
Availability Impact High
SUSE Bugzilla entry: 1070724 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12 SP2
  • spice-vdagent >= 0.16.0-8.5.15
Patchnames:
SUSE-SLE-DESKTOP-12-SP2-2018-262
SUSE Linux Enterprise Desktop 12 SP3
  • spice-vdagent >= 0.16.0-8.5.15
Patchnames:
SUSE-SLE-DESKTOP-12-SP3-2018-262
SUSE Linux Enterprise Desktop 12 SP4
  • spice-vdagent >= 0.16.0-8.5.15
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA spice-vdagent
SUSE Linux Enterprise Module for Desktop Applications 15
  • spice-vdagent >= 0.17.0-2.39
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA spice-vdagent
SUSE Linux Enterprise Server 12 SP2
  • spice-vdagent >= 0.16.0-8.5.15
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-262
SUSE Linux Enterprise Server 12 SP3
  • spice-vdagent >= 0.16.0-8.5.15
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-262
SUSE Linux Enterprise Server 12 SP4
  • spice-vdagent >= 0.16.0-8.5.15
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA spice-vdagent
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • spice-vdagent >= 0.16.0-8.5.15
Patchnames:
SUSE-SLE-RPI-12-SP2-2018-262
SUSE Linux Enterprise Server for SAP Applications 12 SP2
  • spice-vdagent >= 0.16.0-8.5.15
Patchnames:
SUSE-SLE-SERVER-12-SP2-2018-262
SUSE Linux Enterprise Server for SAP Applications 12 SP3
  • spice-vdagent >= 0.16.0-8.5.15
Patchnames:
SUSE-SLE-SERVER-12-SP3-2018-262
openSUSE Leap 15.0
  • spice-vdagent >= 0.17.0-lp150.2.9
Patchnames:
openSUSE Leap 15.0 GA spice-vdagent
openSUSE Leap 42.3
  • spice-vdagent >= 0.16.0-8.1
  • spice-vdagent-debuginfo >= 0.16.0-8.1
  • spice-vdagent-debugsource >= 0.16.0-8.1
Patchnames:
openSUSE-2018-144


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 12 SP2 spice-vdagent Released
SUSE Linux Enterprise Desktop 12 SP3 spice-vdagent Released
SUSE Linux Enterprise Server 12 SP2 spice-vdagent Released
SUSE Linux Enterprise Server 12 SP3 spice-vdagent Released